RT 3.6.6 - httpd won't start

I went through the manual installation Wiki and cleaned up my rt3.conf. I think it should be correct now. However, httpd won’t start. Here is what I get in the error_log:

Tue May 13 15:46:51 2008] [error] Can’t locate Apache2.pm in @INC (@INC contains: /opt/rt3/local/lib /opt/rt3/lib /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 . /etc/httpd) at (eval 209) line
3.\n
[Tue May 13 15:46:51 2008] [error] Can’t load Perl module Apache2 for server itadmin_test.bigrocksports.com:0, exiting…

httpd -v shows:
Server version: Apache/2.2.8 (Unix)
Server built: Jan 28 2008 06:24:44

rt3.conf:
<VirtualHost 10.9.10.251>
ServerName itadmin_test.bigrocksports.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

this line applies to Apache2+mod_perl2 only

Below line might be incorrect, I had to use:

PerlModule Apache2::compat

mod_perl 2.0.1 from FC4 Linux

PerlModule Apache2 Apache::compat

Alias /rt "/opt/rt3/share/html"
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Directory /opt/rt3/share/html>
AllowOverride All
Options ExecCGI FollowSymLinks

Order allow,deny
Allow from all

<Location /rt>
RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Do you see anything that would cause httpd not to start?

Shannon

Hi Shannon,

While this probably wouldn’t keep httpd from starting, I’m pretty sure that
underscores are not legal characters in a host name. Hyphens yes,
underscores no. Making sure that the host name conforms to whatever the
current RFC says might prevent future head-scratchers.

Regards,
Gene

At 02:04 PM 5/13/2008, Shannon Adams wrote:

I went through the manual installation Wiki and cleaned up my rt3.conf. I
think it should be correct now. However, httpd won’t start. Here is what
I get in the error_log:

Tue May 13 15:46:51 2008] [error] Can’t locate Apache2.pm in @INC (@INC
contains: /opt/rt3/local/lib /opt/rt3/lib
/usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7
/usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/5.8.8 . /etc/httpd) at (eval 209) line
3.\n
[Tue May 13 15:46:51 2008] [error] Can’t load Perl module Apache2 for
server itadmin_test.bigrocksports.com:0, exiting…

httpd -v shows:
Server version: Apache/2.2.8 (Unix)
Server built: Jan 28 2008 06:24:44

rt3.conf:
<VirtualHost 10.9.10.251>
ServerName itadmin_test.bigrocksports.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

this line applies to Apache2+mod_perl2 only

Below line might be incorrect, I had to use:

PerlModule Apache2::compat

mod_perl 2.0.1 from FC4 Linux

PerlModule Apache2 Apache::compat

Alias /rt "/opt/rt3/share/html"
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Directory /opt/rt3/share/html>
AllowOverride All
Options ExecCGI FollowSymLinks

Order allow,deny
Allow from all

<Location /rt>
RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Do you see anything that would cause httpd not to start?

Shannon

Gene LeDuc, GSEC
Security Analyst
San Diego State University

I think there’s a typo in the Wiki, at least on the last line:

this line applies to Apache2+mod_perl2 only

Below line might be incorrect, I had to use:

PerlModule Apache2::compat

mod_perl 2.0.1 from FC4 Linux

PerlModule Apache2 Apache::compat

Sould be: PerlModule Apache2::compat

Look at the error logs, it’s trying to find an Apache2 perl module that
doesn’t exist.

James Moseley

         Shannon Adams                                                 
         <shannon_adams68@                                             
         yahoo.com>                                                 To 
         Sent by:                  rt-users@lists.bestpractical.com    
         rt-users-bounces@                                          cc 
         lists.bestpractic                                             
         al.com                                                Subject 
                                   [rt-users] RT 3.6.6 - httpd won't   
                                   start                               
         05/13/2008 04:04                                              
         PM                                                            

I went through the manual installation Wiki and cleaned up my rt3.conf. I
think it should be correct now. However, httpd won’t start. Here is what
I get in the error_log:

Tue May 13 15:46:51 2008] [error] Can’t locate Apache2.pm in @INC (@INC
contains: /opt/rt3/local/lib /opt/rt3/lib /usr/lib/perl5/site_perl/5.8.8
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8
/usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6
/usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/5.8.8 . /etc/httpd) at (eval 209) line
3.\n
[Tue May 13 15:46:51 2008] [error] Can’t load Perl module Apache2 for
server itadmin_test.bigrocksports.com:0, exiting…

httpd -v shows:
Server version: Apache/2.2.8 (Unix)
Server built: Jan 28 2008 06:24:44

rt3.conf:
<VirtualHost 10.9.10.251>
ServerName itadmin_test.bigrocksports.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

this line applies to Apache2+mod_perl2 only

Below line might be incorrect, I had to use:

PerlModule Apache2::compat

mod_perl 2.0.1 from FC4 Linux

PerlModule Apache2 Apache::compat

Alias /rt "/opt/rt3/share/html"
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Directory /opt/rt3/share/html>
AllowOverride All
Options ExecCGI FollowSymLinks

Order allow,deny
Allow from all

<Location /rt>
RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Do you see anything that would cause httpd not to start?

Shannon

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

IMPORTANT:

If you are using mod_perl 2.x and Apache2 then there is NO NEED in
Apache2::compat !!!

If you’re using mod_perl 1.9* and Apache2 then you MUST UPGRADE to MP
2.x or forget about mod_perl at all and use FastCGI instead.

If you’re using mod_perl1 + apache1 then… then just use it :slight_smile:

Point me to the doc where you guys find that shitty “compat” thing so
I can rip it out forever!On Wed, May 14, 2008 at 1:39 AM, jmoseley@corp.xanadoo.com wrote:

I think there’s a typo in the Wiki, at least on the last line:

this line applies to Apache2+mod_perl2 only

Below line might be incorrect, I had to use:

PerlModule Apache2::compat

mod_perl 2.0.1 from FC4 Linux

PerlModule Apache2 Apache::compat

Sould be: PerlModule Apache2::compat

Look at the error logs, it’s trying to find an Apache2 perl module that
doesn’t exist.

James Moseley

         Shannon Adams
         <shannon_adams68@
         yahoo.com>                                                 To
         Sent by:                  rt-users@lists.bestpractical.com
         rt-users-bounces@                                          cc
         lists.bestpractic
         al.com                                                Subject
                                   [rt-users] RT 3.6.6 - httpd won't
                                   start
         05/13/2008 04:04
         PM

I went through the manual installation Wiki and cleaned up my rt3.conf. I
think it should be correct now. However, httpd won’t start. Here is what
I get in the error_log:

Tue May 13 15:46:51 2008] [error] Can’t locate Apache2.pm in @INC (@INC
contains: /opt/rt3/local/lib /opt/rt3/lib /usr/lib/perl5/site_perl/5.8.8
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8
/usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6
/usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/5.8.8 . /etc/httpd) at (eval 209) line
3.\n
[Tue May 13 15:46:51 2008] [error] Can’t load Perl module Apache2 for
server itadmin_test.bigrocksports.com:0, exiting…

httpd -v shows:
Server version: Apache/2.2.8 (Unix)
Server built: Jan 28 2008 06:24:44

rt3.conf:
<VirtualHost 10.9.10.251>
ServerName itadmin_test.bigrocksports.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

this line applies to Apache2+mod_perl2 only

Below line might be incorrect, I had to use:

PerlModule Apache2::compat

mod_perl 2.0.1 from FC4 Linux

PerlModule Apache2 Apache::compat

Alias /rt "/opt/rt3/share/html"
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Directory /opt/rt3/share/html>
AllowOverride All
Options ExecCGI FollowSymLinks

Order allow,deny
Allow from all

<Location /rt>
RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Do you see anything that would cause httpd not to start?

Shannon


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Best regards, Ruslan.

http://wiki.bestpractical.com/view/ManualInstallation

James Moseley

         "Ruslan Zakirov"                                              
         <ruz@bestpractica                                             
         l.com>                                                     To 
         Sent by:                  jmoseley@corp.xanadoo.com           
         ruslan.zakirov@gm                                          cc 
         ail.com                   "Shannon Adams"                     
                                   <shannon_adams68@yahoo.com>,        
                                   rt-users@lists.bestpractical.com,   
         05/13/2008 05:42          rt-users-bounces@lists.bestpractica 
         PM                        l.com                               
                                                               Subject 
                                   Re: [rt-users] RT 3.6.6 - httpd     
                                   won't start                         

IMPORTANT:

If you are using mod_perl 2.x and Apache2 then there is NO NEED in
Apache2::compat !!!

If you’re using mod_perl 1.9* and Apache2 then you MUST UPGRADE to MP
2.x or forget about mod_perl at all and use FastCGI instead.

If you’re using mod_perl1 + apache1 then… then just use it :slight_smile:

Point me to the doc where you guys find that shitty “compat” thing so
I can rip it out forever!

I think there’s a typo in the Wiki, at least on the last line:

this line applies to Apache2+mod_perl2 only

Below line might be incorrect, I had to use:

PerlModule Apache2::compat

mod_perl 2.0.1 from FC4 Linux

PerlModule Apache2 Apache::compat

Sould be: PerlModule Apache2::compat

Look at the error logs, it’s trying to find an Apache2 perl module that
doesn’t exist.

James Moseley

         Shannon Adams
         <shannon_adams68@
         yahoo.com>

To

         Sent by:                  rt-users@lists.bestpractical.com
         rt-users-bounces@

cc

         lists.bestpractic
         al.com

Subject

                                   [rt-users] RT 3.6.6 - httpd won't
                                   start
         05/13/2008 04:04
         PM

I went through the manual installation Wiki and cleaned up my rt3.conf.
I
think it should be correct now. However, httpd won’t start. Here is
what
I get in the error_log:

Tue May 13 15:46:51 2008] [error] Can’t locate Apache2.pm in @INC (@INC
contains: /opt/rt3/local/lib /opt/rt3/lib /usr/lib/perl5/site_perl/5.8.8
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8
/usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6
/usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/5.8.8 . /etc/httpd) at (eval 209) line
3.\n
[Tue May 13 15:46:51 2008] [error] Can’t load Perl module Apache2 for
server itadmin_test.bigrocksports.com:0, exiting…

httpd -v shows:
Server version: Apache/2.2.8 (Unix)
Server built: Jan 28 2008 06:24:44

rt3.conf:
<VirtualHost 10.9.10.251>
ServerName itadmin_test.bigrocksports.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

this line applies to Apache2+mod_perl2 only

Below line might be incorrect, I had to use:

PerlModule Apache2::compat

mod_perl 2.0.1 from FC4 Linux

PerlModule Apache2 Apache::compat

Alias /rt "/opt/rt3/share/html"
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Directory /opt/rt3/share/html>
AllowOverride All
Options ExecCGI FollowSymLinks

Order allow,deny
Allow from all

<Location /rt>
RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Do you see anything that would cause httpd not to start?

Shannon


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Best regards, Ruslan.

Have you read Ruslan’s email yet? If you are running mod_perl 2.x, you
don’t need: PerlModule Apache2::compat

I’d remove that first and then see if things work before worrying about
which version of mod_perl you have or switching to FastCGI.

But, to answer your questions:

More than likely, if you’re running Apache 2.2.8, you are running mod_perl
2.x. To find out the version of mod_perl, use the package managment system
for that operating system. For Linux systems, simply do: yum info
mod_perl.

You can also do a rpm query: rpm -qa | grep mod_perl

If installed via source, go back and look at the source package. There are
other methods as well.

As for FastCGI, it’s a bit more complicated and depends on the flavor:

There’s the Apache mod_fastcgi module available from www.fastcgi.com

Then there is mod_fcgid available from fastcgi.coremail.cn

Depending on the Linux distro, either or both may be available via yum.
For Fedora, the latter version was available for 6/7, not sure about 8 (yum
info mod_fcgid).

Since I am using mod_fcgid, here’s my Apache RT config:

LoadModule fcgid_module modules/mod_fcgid.so

Use FastCGI to process .fcg .fcgi & .fpl scripts

Don’t do this if mod_fastcgi is present, as it will try to do the same

thing
<IfModule !mod_fastcgi.c>
AddHandler fcgid-script fcg fcgi fpl

Sane place to put sockets and shared memory file

SocketPath run/mod_fcgid
SharememPath run/fcgid_shm

Main instance

#FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 360 -processes
4
Alias /rt/NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi/

James Moseley

         Shannon Adams                                                 
         <shannon_adams68@                                             
         yahoo.com>                                                 To 
                                   jmoseley@corp.xanadoo.com           
         05/13/2008 06:35                                           cc 
         PM                                                            
                                                               Subject 
                                   Re: [rt-users] RT 3.6.6 - httpd     
                                   won't start                         

Hi James,

Thanks for the response. After making the correction, httpd now starts.

I am running Apache/2.2.8. I am not sure how to tell what version of
mod_perl I am running. How can I tell what version I am using or
better yet, what do I need to change in the in the following rt3.conf
to switch to FastCGI?

httpd starts - but I get the following when browsing to
rtbak.bigrocksports.com:

You’re almost there!

You haven’t yet configured your webserver to run RT.

You appear to have installed RT’s web interface correctly, but haven’t
yet configured your web server to “run” the RT server which powers the
web interface.

The next step is to edit your webserver’s configuration file to instruct it
to use RT’s mod_perl , fastcgi or speedycgi handler.

rt3.conf follows:

<VirtualHost 10.9.10.251>
ServerName itadmintest.bigrocksports.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

PerlModule Apache2::compat

Alias /rt "/opt/rt3/share/html"
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Directory /opt/rt3/share/html>
AllowOverride All
Options ExecCGI FollowSymLinks

Order allow,deny
Allow from all

<Location /rt>
RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Thanks for the help,
Shannon----- Original Message ----
From: "jmoseley@corp.xanadoo.com" jmoseley@corp.xanadoo.com
To: Shannon Adams shannon_adams68@yahoo.com
Cc: rt-users@lists.bestpractical.com;
rt-users-bounces@lists.bestpractical.com
Sent: Tuesday, May 13, 2008 5:39:39 PM
Subject: Re: [rt-users] RT 3.6.6 - httpd won’t start

I think there’s a typo in the Wiki, at least on the last line:

this line applies to Apache2+mod_perl2 only

Below line might be incorrect, I had to use:

PerlModule Apache2::compat

mod_perl 2.0.1 from FC4 Linux

PerlModule Apache2 Apache::compat

Sould be: PerlModule Apache2::compat

Look at the error logs, it’s trying to find an Apache2 perl module that
doesn’t exist.

James Moseley

         Shannon Adams
         <shannon_adams68@
        yahoo.com>                                                 To
         Sent by:                  rt-users@lists.bestpractical.com
         rt-users-bounces@                                          cc
         lists.bestpractic
        al.com                                                Subject
                                   [rt-users] RT 3.6.6 - httpd won't
                                   start
         05/13/2008 04:04
         PM

I went through the manual installation Wiki and cleaned up my rt3.conf. I
think it should be correct now. However, httpd won’t start. Here is what
I get in the error_log:

Tue May 13 15:46:51 2008] [error] Can’t locate Apache2.pm in @INC (@INC
contains: /opt/rt3/local/lib /opt/rt3/lib /usr/lib/perl5/site_perl/5.8.8
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8
/usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6
/usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/5.8.8 . /etc/httpd) at (eval 209) line
3.\n
[Tue May 13 15:46:51 2008] [error] Can’t load Perl module Apache2 for
server itadmin_test.bigrocksports.com:0, exiting…

httpd -v shows:
Server version: Apache/2.2.8 (Unix)
Server built: Jan 28 2008 06:24:44

rt3.conf:
<VirtualHost 10.9.10.251>
ServerName itadmin_test.bigrocksports.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

this line applies to Apache2+mod_perl2 only

Below line might be incorrect, I had to use:

PerlModule Apache2::compat

mod_perl 2.0.1 from FC4 Linux

PerlModule Apache2 Apache::compat

Alias /rt "/opt/rt3/share/html"
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Directory /opt/rt3/share/html>
AllowOverride All
Options ExecCGI FollowSymLinks

Order allow,deny
Allow from all

<Location /rt>
RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Do you see anything that would cause httpd not to start?

Shannon

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Never drop rt-users@ from list of recipients of your emails. If you
want me or other qualified admins and RT developers help privately
then please contact sales@bestpractical.com otherwise stick with
rt-users@ so other people can help you as well and may be solve their
problems by reading this thread.

We’re not distant disk readers :), so we couldn’t help you without
additional info and error message suggest you where to look for real
error message: "More information about this error may be available in
the server error log."On Wed, May 14, 2008 at 5:32 AM, Shannon Adams shannon_adams68@yahoo.com wrote:

This is so frustrating. Now, I am getting this when browsing to rtbak.bigrocksports.com (DNS has rtbak as 10.9.10.251):

Internal Server Error
The server encountered an internal error or
misconfiguration and was unable to complete
your request.
Please contact the server administrator, root@localhost and inform them of the time the error occurred,
and anything you might have done that may have
caused the error.
More information about this error may be available
in the server error log.


Apache/2.2.8 (Fedora) Server at rtbak.bigrocksports.com Port 80
Here is exactly how my rt3.conf looks now:

<VirtualHost 10.9.10.251>
ServerName itadmintest.bigrocksports.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8
PerlRequire /opt/rt3/bin/webmux.pl
<Directory /opt/rt3/share/html>
Order allow,deny
Allow from all
SetHandler perl-script
PerlHandler RT::Mason

Thanks again for helping me through this!

Shannon

----- Original Message ----
From: Ruslan Zakirov ruz@bestpractical.com
To: Shannon Adams shannon_adams68@yahoo.com

Sent: Tuesday, May 13, 2008 9:25:10 PM
Subject: Re: [rt-users] RT 3.6.6 - httpd won’t start

I hope you’ve changed properties of vistual host to something like:

<VirtualHost 10.9.10.251>
ServerName itadmintest.bigrocksports.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8
PerlRequire /opt/rt3/bin/webmux.pl
<Directory /opt/rt3/share/html>
Order allow,deny
Allow from all
SetHandler perl-script
PerlHandler RT::Mason

On Wed, May 14, 2008 at 5:07 AM, Shannon Adams shannon_adams68@yahoo.com wrote:

Okay, getting close. I got rid of my rt3.conf and used the one you provided below. Now, I receive the following when I browse to rtbak.bigrocksports.com:

"FEDORA TEST PAGE

This page is used to test the proper operation of the Apache HTTP server
after it has been installed. If you can read this page, it means that the web
server installed at this site is working properly, but has not yet been
configured."

I don’t know how to configure FastCGI. It doesn’t matter to me which is used mod_perl of FCGI. I have been fighting with this for days now and just want to get it to work.

Thank you very much for helping me through this. It looks like it is closer to working now. Do you know what I need to do next to get the RT login screen to show up instead of the Fedora test page?

Shannon

----- Original Message ----
From: Ruslan Zakirov ruz@bestpractical.com

To: Shannon Adams shannon_adams68@yahoo.com
Sent: Tuesday, May 13, 2008 8:58:38 PM
Subject: Re: [rt-users] RT 3.6.6 - httpd won’t start

As far as I can see:

  • mixed all suggestions from that manual in one place
  • as you want to run only RT on a vhost xxx.your-domain.com then you
    don’t need any Alias and other things that map RT to “/rt” location on
    that virtual host
  • Here is the minimal config for an IP based virtual host I just
    successfully started after wrting it from scratch:

Listen 8080
<VirtualHost *:8080>
ServerName localhost:8080
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8
PerlRequire /opt/rt3/bin/webmux.pl
<Directory /opt/rt3/share/html>
Order allow,deny
Allow from all
SetHandler perl-script
PerlHandler RT::Mason

That’s all. it just works with mod_perl2 on apache2

Do you know how to configure FastCGI? Let me help you with mod_perl
then you’ll decide if you want to switch to FCGI or not.

On Wed, May 14, 2008 at 3:34 AM, Shannon Adams shannon_adams68@yahoo.com wrote:

Hi Ruslan,

Thanks for the response.

I am running Apache/2.2.8. I am not sure how to tell what version of mod_perl I am running. How can I tell what version I am using or better yet, what do I need to change in the in the following rt3.conf to switch to FastCGI?

Right now, httpd starts - but I get the following when browsing to rtbak.bigrocksports.com:

You’re almost there!

You haven’t yet configured your webserver to run RT.

You appear to have installed RT’s web interface correctly, but haven’t yet configured your web server to “run” the RT server which powers the web interface.

The next step is to edit your webserver’s configuration file to instruct it to use RT’s mod_perl , fastcgi or speedycgi handler.

rt3.conf follows:

<VirtualHost 10.9.10.251>
ServerName itadmintest.bigrocksports.com

DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

PerlModule Apache2::compat

Alias /rt "/opt/rt3/share/html"
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Directory /opt/rt3/share/html>
AllowOverride All
Options ExecCGI FollowSymLinks

Order allow,deny
Allow from all

<Location /rt>
RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Thanks for the help,
Shannon

----- Original Message ----
From: Ruslan Zakirov ruz@bestpractical.com
To: jmoseley@corp.xanadoo.com
Cc: Shannon Adams shannon_adams68@yahoo.com; rt-users@lists.bestpractical.com; rt-users-bounces@lists.bestpractical.com
Sent: Tuesday, May 13, 2008 6:42:08 PM
Subject: Re: [rt-users] RT 3.6.6 - httpd won’t start

IMPORTANT:

If you are using mod_perl 2.x and Apache2 then there is NO NEED in
Apache2::compat !!!

If you’re using mod_perl 1.9* and Apache2 then you MUST UPGRADE to MP
2.x or forget about mod_perl at all and use FastCGI instead.

If you’re using mod_perl1 + apache1 then… then just use it :slight_smile:

Point me to the doc where you guys find that shitty “compat” thing so
I can rip it out forever!

On Wed, May 14, 2008 at 1:39 AM, jmoseley@corp.xanadoo.com wrote:

I think there’s a typo in the Wiki, at least on the last line:

this line applies to Apache2+mod_perl2 only

Below line might be incorrect, I had to use:

PerlModule Apache2::compat

mod_perl 2.0.1 from FC4 Linux

PerlModule Apache2 Apache::compat

Sould be: PerlModule Apache2::compat

Look at the error logs, it’s trying to find an Apache2 perl module that
doesn’t exist.

James Moseley

         Shannon Adams
         <shannon_adams68@
         yahoo.com>                                                 To
         Sent by:                  rt-users@lists.bestpractical.com
         rt-users-bounces@                                          cc
         lists.bestpractic
         al.com                                                Subject
                                   [rt-users] RT 3.6.6 - httpd won't
                                   start
         05/13/2008 04:04
         PM

I went through the manual installation Wiki and cleaned up my rt3.conf. I
think it should be correct now. However, httpd won’t start. Here is what
I get in the error_log:

Tue May 13 15:46:51 2008] [error] Can’t locate Apache2.pm in @INC (@INC
contains: /opt/rt3/local/lib /opt/rt3/lib /usr/lib/perl5/site_perl/5.8.8
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8
/usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6
/usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/5.8.8 . /etc/httpd) at (eval 209) line
3.\n
[Tue May 13 15:46:51 2008] [error] Can’t load Perl module Apache2 for
server itadmin_test.bigrocksports.com:0, exiting…

httpd -v shows:
Server version: Apache/2.2.8 (Unix)
Server built: Jan 28 2008 06:24:44

rt3.conf:
<VirtualHost 10.9.10.251>
ServerName itadmin_test.bigrocksports.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

this line applies to Apache2+mod_perl2 only

Below line might be incorrect, I had to use:

PerlModule Apache2::compat

mod_perl 2.0.1 from FC4 Linux

PerlModule Apache2 Apache::compat

Alias /rt "/opt/rt3/share/html"
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Directory /opt/rt3/share/html>
AllowOverride All
Options ExecCGI FollowSymLinks

Order allow,deny
Allow from all

<Location /rt>
RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Do you see anything that would cause httpd not to start?

Shannon


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Best regards, Ruslan.


Best regards, Ruslan.

Best regards, Ruslan.

Sorry about not copying rt_users. It was an oversight. It wasn’t intentional as I need all the help I can get!

I finally overcame httpd not starting up. However, now when I browse to the RT URL - I am getting the error message below. httpd is started as root. What should the permissions be under the /opt/rt3 structure? I don’t recall changing anything after the initial installation.

Permissions under /opt/rt3:
drwxrwxrwx 6 apache apache 4096 2008-05-12 15:30 var
drwxrwx— 5 apache apache 4096 2008-05-12 10:16 mason_data
drwxr-xr-x 2 apache apache 4096 2008-05-12 17:49 obj

Here is the error that pops up in the browser.

mkdir /opt/rt3/var/mason_data/obj/2362954981: Permission denied at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Compiler/ToObject.pm line 107

Trace begun at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Exceptions.pm line 129
HTML::Mason::Exceptions::rethrow_exception(‘mkdir /opt/rt3/var/mason_data/obj/2362954981: Permission denied at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Compiler/ToObject.pm line 107^J’) called at /usr/lib/perl5/5.8.8/Carp.pm line 269
Carp::croak(‘mkdir /opt/rt3/var/mason_data/obj/2362954981: Permission denied’) called at /usr/lib/perl5/5.8.8/File/Path.pm line 168
File::Path::mkpath(’/opt/rt3/var/mason_data/obj/2362954981’, 0, 509) called at /usr/lib/perl5/5.8.8/File/Path.pm line 161
File::Path::mkpath(’/opt/rt3/var/mason_data/obj/2362954981/standard’, 0, 509) called at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Compiler/ToObject.pm line 107
HTML::Mason::Compiler::ToObject::compile_to_file(undef, ‘file’, ‘/opt/rt3/var/mason_data/obj/2362954981/standard/index.html.obj’, ‘source’, ‘HTML::Mason::ComponentSource=HASH(0xbbf5eeac)’) called at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Interp.pm line 434
HTML::Mason::Interp::load(‘HTML::Mason::Interp=HASH(0xbb14cc74)’, ‘/index.html’) called at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Request.pm line 245
eval {…} at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Request.pm line 230
HTML::Mason::Request::_initialize(‘HTML::Mason::Request::ApacheHandler=HASH(0xbbf5ed80)’) called at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Request.pm line 210
HTML::Mason::Request::new(‘HTML::Mason::Request::ApacheHandler’, ‘error_mode’, ‘output’, ‘autoflush’, 0, ‘error_format’, ‘html’, ‘interp’, ‘HTML::Mason::Interp=HASH(0xbb14cc74)’, ‘comp’, ‘/index.html’, ‘args’, ‘ARRAY(0xbbe939dc)’, ‘ah’, ‘HTML::Mason::ApacheHandler=HASH(0xbb149fdc)’, ‘apache_req’, ‘Apache2::RequestRec=SCALAR(0xbaef9ec4)’, ‘container’, ‘HASH(0xbbf303dc)’) called at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/ApacheHandler.pm line 97
HTML::Mason::Request::ApacheHandler::new(‘HTML::Mason::Request::ApacheHandler’, ‘error_mode’, ‘output’, ‘autoflush’, 0, ‘error_format’, ‘html’, ‘interp’, ‘HTML::Mason::Interp=HASH(0xbb14cc74)’, ‘comp’, ‘/index.html’, ‘args’, ‘ARRAY(0xbbe939dc)’, ‘ah’, ‘HTML::Mason::ApacheHandler=HASH(0xbb149fdc)’, ‘apache_req’, ‘Apache2::RequestRec=SCALAR(0xbaef9ec4)’, ‘container’, ‘HASH(0xbbf303dc)’) called at /usr/lib/perl5/vendor_perl/5.8.8/Class/Container.pm line 275
Class::Container::call_method(‘HTML::Mason::Interp=HASH(0xbb14cc74)’, ‘request’, ‘new’, ‘interp’, ‘HTML::Mason::Interp=HASH(0xbb14cc74)’, ‘comp’, ‘/index.html’, ‘args’, ‘ARRAY(0xbbe939dc)’, ‘ah’, ‘HTML::Mason::ApacheHandler=HASH(0xbb149fdc)’, ‘apache_req’, ‘Apache2::RequestRec=SCALAR(0xbaef9ec4)’, ‘container’, ‘HASH(0xbbf303dc)’) called at /usr/lib/perl5/vendor_perl/5.8.8/Class/Container.pm line 353
Class::Container::create_delayed_object(‘interp’, ‘HTML::Mason::Interp=HASH(0xbb14cc74)’, ‘comp’, ‘/index.html’, ‘args’, ‘ARRAY(0xbbe939dc)’, ‘ah’, ‘HTML::Mason::ApacheHandler=HASH(0xbb149fdc)’, ‘apache_req’, ‘Apache2::RequestRec=SCALAR(0xbaef9ec4)’, ‘container’, ‘HASH(0xbbf303dc)’) called at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Interp.pm line 348
HTML::Mason::Interp::make_request(‘HTML::Mason::Interp=HASH(0xbb14cc74)’, ‘comp’, ‘/index.html’, ‘args’, ‘ARRAY(0xbbe939dc)’, ‘ah’, ‘HTML::Mason::ApacheHandler=HASH(0xbb149fdc)’, ‘apache_req’, ‘Apache2::RequestRec=SCALAR(0xbaef9ec4)’) called at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/ApacheHandler.pm line 869
eval {…} at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/ApacheHandler.pm line 868
HTML::Mason::ApacheHandler::prepare_request(‘HTML::Mason::ApacheHandler=HASH(0xbb149fdc)’, ‘Apache2::RequestRec=SCALAR(0xbaef9ec4)’) called at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/ApacheHandler.pm line 823
HTML::Mason::ApacheHandler::handle_request(‘HTML::Mason::ApacheHandler=HASH(0xbb149fdc)’, ‘Apache2::RequestRec=SCALAR(0xbaef9ec4)’) called at /opt/rt3/bin/webmux.pl line 125
eval {…} at /opt/rt3/bin/webmux.pl line 125
RT::Mason::handler(‘Apache2::RequestRec=SCALAR(0xbaef9ec4)’) called at -e line 0
eval {…} at -e line 0

Thanks,
ShannonFrom: Ruslan Zakirov ruz@bestpractical.com
To: Shannon Adams shannon_adams68@yahoo.com
Cc: RT users rt-users@lists.bestpractical.com
Sent: Tuesday, May 13, 2008 10:56:20 PM
Subject: Re: [rt-users] RT 3.6.6 - httpd won’t start

Never drop rt-users@ from list of recipients of your emails. If you
want me or other qualified admins and RT developers help privately
then please contact sales@bestpractical.com otherwise stick with
rt-users@ so other people can help you as well and may be solve their
problems by reading this thread.

We’re not distant disk readers :), so we couldn’t help you without
additional info and error message suggest you where to look for real
error message: “More information about this error may be available in
the server error log.”

Dear All,

Are these lines(there are more) added in httpd.conf . They should be there.

LoadModule auth_basic_module modules/mod_auth_basic.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule authn_file_module modules/mod_authn_file.so

Regards,

IT GUY
Yogesh

Those errors suggest me that your apache server is running under user
that is not “apache”. Look for Group and User derictives in your
httpd.conf. Also, the permissions you posted below are wierd in terms
of layout. By default RT has the following dirs:

rt3/var
rt3/var/mason_data

There is no “rt3/mason_data”. May be your server actually runs under
"apache" but you’ve ignored the fact that ./configure has options
–with-web-user and --with-web-group and tried to fix it later and
failed. You can re-run configure script and make install again to fix
permissions.On Wed, May 14, 2008 at 11:02 PM, Shannon Adams shannon_adams68@yahoo.com wrote:

Sorry about not copying rt_users. It was an oversight. It wasn’t intentional as I need all the help I can get!

I finally overcame httpd not starting up. However, now when I browse to the RT URL - I am getting the error message below. httpd is started as root. What should the permissions be under the /opt/rt3 structure? I don’t recall changing anything after the initial installation.

Permissions under /opt/rt3:
drwxrwxrwx 6 apache apache 4096 2008-05-12 15:30 var
drwxrwx— 5 apache apache 4096 2008-05-12 10:16 mason_data
drwxr-xr-x 2 apache apache 4096 2008-05-12 17:49 obj

Here is the error that pops up in the browser.

mkdir /opt/rt3/var/mason_data/obj/2362954981: Permission denied at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Compiler/ToObject.pm line 107

Trace begun at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Exceptions.pm line 129
HTML::Mason::Exceptions::rethrow_exception(‘mkdir /opt/rt3/var/mason_data/obj/2362954981: Permission denied at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Compiler/ToObject.pm line 107^J’) called at /usr/lib/perl5/5.8.8/Carp.pm line 269
Carp::croak(‘mkdir /opt/rt3/var/mason_data/obj/2362954981: Permission denied’) called at /usr/lib/perl5/5.8.8/File/Path.pm line 168
File::Path::mkpath(’/opt/rt3/var/mason_data/obj/2362954981’, 0, 509) called at /usr/lib/perl5/5.8.8/File/Path.pm line 161
File::Path::mkpath(’/opt/rt3/var/mason_data/obj/2362954981/standard’, 0, 509) called at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Compiler/ToObject.pm line 107
HTML::Mason::Compiler::ToObject::compile_to_file(undef, ‘file’, ‘/opt/rt3/var/mason_data/obj/2362954981/standard/index.html.obj’, ‘source’, ‘HTML::Mason::ComponentSource=HASH(0xbbf5eeac)’) called at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Interp.pm line 434
HTML::Mason::Interp::load(‘HTML::Mason::Interp=HASH(0xbb14cc74)’, ‘/index.html’) called at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Request.pm line 245
eval {…} at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Request.pm line 230
HTML::Mason::Request::_initialize(‘HTML::Mason::Request::ApacheHandler=HASH(0xbbf5ed80)’) called at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Request.pm line 210
HTML::Mason::Request::new(‘HTML::Mason::Request::ApacheHandler’, ‘error_mode’, ‘output’, ‘autoflush’, 0, ‘error_format’, ‘html’, ‘interp’, ‘HTML::Mason::Interp=HASH(0xbb14cc74)’, ‘comp’, ‘/index.html’, ‘args’, ‘ARRAY(0xbbe939dc)’, ‘ah’, ‘HTML::Mason::ApacheHandler=HASH(0xbb149fdc)’, ‘apache_req’, ‘Apache2::RequestRec=SCALAR(0xbaef9ec4)’, ‘container’, ‘HASH(0xbbf303dc)’) called at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/ApacheHandler.pm line 97
HTML::Mason::Request::ApacheHandler::new(‘HTML::Mason::Request::ApacheHandler’, ‘error_mode’, ‘output’, ‘autoflush’, 0, ‘error_format’, ‘html’, ‘interp’, ‘HTML::Mason::Interp=HASH(0xbb14cc74)’, ‘comp’, ‘/index.html’, ‘args’, ‘ARRAY(0xbbe939dc)’, ‘ah’, ‘HTML::Mason::ApacheHandler=HASH(0xbb149fdc)’, ‘apache_req’, ‘Apache2::RequestRec=SCALAR(0xbaef9ec4)’, ‘container’, ‘HASH(0xbbf303dc)’) called at /usr/lib/perl5/vendor_perl/5.8.8/Class/Container.pm line 275
Class::Container::call_method(‘HTML::Mason::Interp=HASH(0xbb14cc74)’, ‘request’, ‘new’, ‘interp’, ‘HTML::Mason::Interp=HASH(0xbb14cc74)’, ‘comp’, ‘/index.html’, ‘args’, ‘ARRAY(0xbbe939dc)’, ‘ah’, ‘HTML::Mason::ApacheHandler=HASH(0xbb149fdc)’, ‘apache_req’, ‘Apache2::RequestRec=SCALAR(0xbaef9ec4)’, ‘container’, ‘HASH(0xbbf303dc)’) called at /usr/lib/perl5/vendor_perl/5.8.8/Class/Container.pm line 353
Class::Container::create_delayed_object(‘interp’, ‘HTML::Mason::Interp=HASH(0xbb14cc74)’, ‘comp’, ‘/index.html’, ‘args’, ‘ARRAY(0xbbe939dc)’, ‘ah’, ‘HTML::Mason::ApacheHandler=HASH(0xbb149fdc)’, ‘apache_req’, ‘Apache2::RequestRec=SCALAR(0xbaef9ec4)’, ‘container’, ‘HASH(0xbbf303dc)’) called at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Interp.pm line 348
HTML::Mason::Interp::make_request(‘HTML::Mason::Interp=HASH(0xbb14cc74)’, ‘comp’, ‘/index.html’, ‘args’, ‘ARRAY(0xbbe939dc)’, ‘ah’, ‘HTML::Mason::ApacheHandler=HASH(0xbb149fdc)’, ‘apache_req’, ‘Apache2::RequestRec=SCALAR(0xbaef9ec4)’) called at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/ApacheHandler.pm line 869
eval {…} at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/ApacheHandler.pm line 868
HTML::Mason::ApacheHandler::prepare_request(‘HTML::Mason::ApacheHandler=HASH(0xbb149fdc)’, ‘Apache2::RequestRec=SCALAR(0xbaef9ec4)’) called at /usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/ApacheHandler.pm line 823
HTML::Mason::ApacheHandler::handle_request(‘HTML::Mason::ApacheHandler=HASH(0xbb149fdc)’, ‘Apache2::RequestRec=SCALAR(0xbaef9ec4)’) called at /opt/rt3/bin/webmux.pl line 125
eval {…} at /opt/rt3/bin/webmux.pl line 125
RT::Mason::handler(‘Apache2::RequestRec=SCALAR(0xbaef9ec4)’) called at -e line 0
eval {…} at -e line 0

Thanks,

Shannon

----- Original Message ----
From: Ruslan Zakirov ruz@bestpractical.com
To: Shannon Adams shannon_adams68@yahoo.com

Cc: RT users rt-users@lists.bestpractical.com
Sent: Tuesday, May 13, 2008 10:56:20 PM
Subject: Re: [rt-users] RT 3.6.6 - httpd won’t start

Never drop rt-users@ from list of recipients of your emails. If you
want me or other qualified admins and RT developers help privately
then please contact sales@bestpractical.com otherwise stick with
rt-users@ so other people can help you as well and may be solve their
problems by reading this thread.

We’re not distant disk readers :), so we couldn’t help you without
additional info and error message suggest you where to look for real
error message: “More information about this error may be available in
the server error log.”

On Wed, May 14, 2008 at 5:32 AM, Shannon Adams shannon_adams68@yahoo.com wrote:

This is so frustrating. Now, I am getting this when browsing to rtbak.bigrocksports.com (DNS has rtbak as 10.9.10.251):

Internal Server Error
The server encountered an internal error or
misconfiguration and was unable to complete
your request.
Please contact the server administrator, root@localhost and inform them of the time the error occurred,
and anything you might have done that may have
caused the error.
More information about this error may be available
in the server error log.


Apache/2.2.8 (Fedora) Server at rtbak.bigrocksports.com Port 80
Here is exactly how my rt3.conf looks now:

<VirtualHost 10.9.10.251>
ServerName itadmintest.bigrocksports.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8
PerlRequire /opt/rt3/bin/webmux.pl
<Directory /opt/rt3/share/html>
Order allow,deny
Allow from all
SetHandler perl-script
PerlHandler RT::Mason

Thanks again for helping me through this!

Shannon

----- Original Message ----
From: Ruslan Zakirov ruz@bestpractical.com
To: Shannon Adams shannon_adams68@yahoo.com

Sent: Tuesday, May 13, 2008 9:25:10 PM
Subject: Re: [rt-users] RT 3.6.6 - httpd won’t start

I hope you’ve changed properties of vistual host to something like:

<VirtualHost 10.9.10.251>
ServerName itadmintest.bigrocksports.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8
PerlRequire /opt/rt3/bin/webmux.pl
<Directory /opt/rt3/share/html>
Order allow,deny
Allow from all
SetHandler perl-script
PerlHandler RT::Mason

On Wed, May 14, 2008 at 5:07 AM, Shannon Adams shannon_adams68@yahoo.com wrote:

Okay, getting close. I got rid of my rt3.conf and used the one you provided below. Now, I receive the following when I browse to rtbak.bigrocksports.com:

"FEDORA TEST PAGE

This page is used to test the proper operation of the Apache HTTP server
after it has been installed. If you can read this page, it means that the web
server installed at this site is working properly, but has not yet been
configured."

I don’t know how to configure FastCGI. It doesn’t matter to me which is used mod_perl of FCGI. I have been fighting with this for days now and just want to get it to work.

Thank you very much for helping me through this. It looks like it is closer to working now. Do you know what I need to do next to get the RT login screen to show up instead of the Fedora test page?

Shannon

----- Original Message ----
From: Ruslan Zakirov ruz@bestpractical.com

To: Shannon Adams shannon_adams68@yahoo.com
Sent: Tuesday, May 13, 2008 8:58:38 PM
Subject: Re: [rt-users] RT 3.6.6 - httpd won’t start

As far as I can see:

  • mixed all suggestions from that manual in one place
  • as you want to run only RT on a vhost xxx.your-domain.com then you
    don’t need any Alias and other things that map RT to “/rt” location on
    that virtual host
  • Here is the minimal config for an IP based virtual host I just
    successfully started after wrting it from scratch:

Listen 8080
<VirtualHost *:8080>
ServerName localhost:8080
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8
PerlRequire /opt/rt3/bin/webmux.pl
<Directory /opt/rt3/share/html>
Order allow,deny
Allow from all
SetHandler perl-script
PerlHandler RT::Mason

That’s all. it just works with mod_perl2 on apache2

Do you know how to configure FastCGI? Let me help you with mod_perl
then you’ll decide if you want to switch to FCGI or not.

On Wed, May 14, 2008 at 3:34 AM, Shannon Adams shannon_adams68@yahoo.com wrote:

Hi Ruslan,

Thanks for the response.

I am running Apache/2.2.8. I am not sure how to tell what version of mod_perl I am running. How can I tell what version I am using or better yet, what do I need to change in the in the following rt3.conf to switch to FastCGI?

Right now, httpd starts - but I get the following when browsing to rtbak.bigrocksports.com:

You’re almost there!

You haven’t yet configured your webserver to run RT.

You appear to have installed RT’s web interface correctly, but haven’t yet configured your web server to “run” the RT server which powers the web interface.

The next step is to edit your webserver’s configuration file to instruct it to use RT’s mod_perl , fastcgi or speedycgi handler.

rt3.conf follows:

<VirtualHost 10.9.10.251>
ServerName itadmintest.bigrocksports.com

DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

PerlModule Apache2::compat

Alias /rt "/opt/rt3/share/html"
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Directory /opt/rt3/share/html>
AllowOverride All
Options ExecCGI FollowSymLinks

Order allow,deny
Allow from all

<Location /rt>
RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Thanks for the help,
Shannon

----- Original Message ----
From: Ruslan Zakirov ruz@bestpractical.com
To: jmoseley@corp.xanadoo.com
Cc: Shannon Adams shannon_adams68@yahoo.com; rt-users@lists.bestpractical.com; rt-users-bounces@lists.bestpractical.com
Sent: Tuesday, May 13, 2008 6:42:08 PM
Subject: Re: [rt-users] RT 3.6.6 - httpd won’t start

IMPORTANT:

If you are using mod_perl 2.x and Apache2 then there is NO NEED in
Apache2::compat !!!

If you’re using mod_perl 1.9* and Apache2 then you MUST UPGRADE to MP
2.x or forget about mod_perl at all and use FastCGI instead.

If you’re using mod_perl1 + apache1 then… then just use it :slight_smile:

Point me to the doc where you guys find that shitty “compat” thing so
I can rip it out forever!

On Wed, May 14, 2008 at 1:39 AM, jmoseley@corp.xanadoo.com wrote:

I think there’s a typo in the Wiki, at least on the last line:

this line applies to Apache2+mod_perl2 only

Below line might be incorrect, I had to use:

PerlModule Apache2::compat

mod_perl 2.0.1 from FC4 Linux

PerlModule Apache2 Apache::compat

Sould be: PerlModule Apache2::compat

Look at the error logs, it’s trying to find an Apache2 perl module that
doesn’t exist.

James Moseley

         Shannon Adams
         <shannon_adams68@
         yahoo.com>                                                 To
         Sent by:                  rt-users@lists.bestpractical.com
         rt-users-bounces@                                          cc
         lists.bestpractic
         al.com                                                Subject
                                   [rt-users] RT 3.6.6 - httpd won't
                                   start
         05/13/2008 04:04
         PM

I went through the manual installation Wiki and cleaned up my rt3.conf. I
think it should be correct now. However, httpd won’t start. Here is what
I get in the error_log:

Tue May 13 15:46:51 2008] [error] Can’t locate Apache2.pm in @INC (@INC
contains: /opt/rt3/local/lib /opt/rt3/lib /usr/lib/perl5/site_perl/5.8.8
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5
/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8
/usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6
/usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/5.8.8 . /etc/httpd) at (eval 209) line
3.\n
[Tue May 13 15:46:51 2008] [error] Can’t load Perl module Apache2 for
server itadmin_test.bigrocksports.com:0, exiting…

httpd -v shows:
Server version: Apache/2.2.8 (Unix)
Server built: Jan 28 2008 06:24:44

rt3.conf:
<VirtualHost 10.9.10.251>
ServerName itadmin_test.bigrocksports.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

this line applies to Apache2+mod_perl2 only

Below line might be incorrect, I had to use:

PerlModule Apache2::compat

mod_perl 2.0.1 from FC4 Linux

PerlModule Apache2 Apache::compat

Alias /rt "/opt/rt3/share/html"
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Directory /opt/rt3/share/html>
AllowOverride All
Options ExecCGI FollowSymLinks

Order allow,deny
Allow from all

<Location /rt>
RewriteEngine On
RedirectMatch permanent (.*)/$ $1/index.html
AddDefaultCharset UTF-8
SetHandler perl-script
PerlHandler RT::Mason

Do you see anything that would cause httpd not to start?

Shannon


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


Best regards, Ruslan.


Best regards, Ruslan.


Best regards, Ruslan.


Best regards, Ruslan.

Best regards, Ruslan.