RT 3.4.4 and mod_perl1.99

as well as support for mod_perl2 on Apache 2.

just a short question …
is there any chance to get it running with mod_perl1.99 ?

Regards,
Tom

So far i know not. try FastCGI.

Thanks in advance

: Torsten Brumm
: IT Security Engineer
:
: Kuehne + Nagel
: HAM - MI-C
:
: Ferdinand Strasse 29-33
: 20095 Hamburg
:
: +49 (40) 329 15 199
: +49 (40) 329 15 500
:
: torsten.brumm@kuehne-nagel.com
: www.kn-portal.com
: icq: 78258840
…Von: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] Im Auftrag von Knaupp,
Thomas
Gesendet: Dienstag, 13. September 2005 13:09
An: rt-users@lists.bestpractical.com
Betreff: [rt-users] RT 3.4.4 and mod_perl1.99

as well as support for mod_perl2 on Apache 2.

just a short question …
is there any chance to get it running with mod_perl1.99 ?

Regards,
Tom

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com

as well as support for mod_perl2 on Apache 2.

just a short question …
is there any chance to get it running with mod_perl1.99 ?
MP1.99XX is development branch, there is already MP2.X
You can use RT3.4.4(only 3.4.4 and higher) with MP2.X

Regards,
Tom


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com

Best regards, Ruslan.

as well as support for mod_perl2 on Apache 2.

just a short question …
is there any chance to get it running with mod_perl1.99 ?

The short answer is “no.” Because of the number of different bugs in
different versions of 1.99, as well as the number of different APIs that
different versions supported, we made the decision not to support the
development and beta 1.99 series.

Jesse

Knaupp, Thomas wrote:

as well as support for mod_perl2 on Apache 2.

just a short question …
is there any chance to get it running with mod_perl1.99 ?

Can I just get someone to confirm/clarify for me that as of RT 3.4.4
that you MUST use mod_perl2? (or FastCGI)

I am using RHEL4 and their stock mod_perl is mod_perl-1.99_16-4.

–Chris

At 9/13/2005 03:08 PM, you wrote:

Knaupp, Thomas wrote:

as well as support for mod_perl2 on Apache 2.

just a short question …
is there any chance to get it running with mod_perl1.99 ?

Can I just get someone to confirm/clarify for me that as of RT 3.4.4
that you MUST use mod_perl2? (or FastCGI)

I am using RHEL4 and their stock mod_perl is mod_perl-1.99_16-4.

–Chris

RT Essentials, page 14:

Any of the following will do:

  • Apache 1.3 with mod_perl 1.x
  • Apache 2.x with mod_perl 2.x

(Great book!)

We just completed the initial setup of the following:

OS,Distribution – Linux host.name.our.site 2.4.21-32.0.1.ELsmp #1 SMP
i686 i686 i386 GNU/Linux
RT Version – 3.4.4
Perl Version – 5.8.6
DBIx::SearchBuilder Version – 1.31
Apache Version – Server version: Apache/1.3.33 (Unix);
mod_perl Version – 1.29
mod_ssl Version – 2.8.22-1.3.33
MySQL Version – ./mysql Ver 14.7 Distrib 4.1.11, for pc-linux-gnu (i686)
C Compiler Version – GNU cc 3.2.3 20030502 (Red Hat Linux 3.2.3-49)

Going to start in-house alpha testing tomorrow. COOL new features!

Then comes the fun part… exporting our database from RT 3.0.0 and
hoping/praying that it imports cleanly for use with the new version of RT.

Graciously accepting any suggestions and/or pointers on the export/import.

Jennifer Moore
RT Administrator
Systems and Operations
Cornell University

Jennifer I. Moore wrote:

At 9/13/2005 03:08 PM, you wrote:

Knaupp, Thomas wrote:

as well as support for mod_perl2 on Apache 2.

just a short question …
is there any chance to get it running with mod_perl1.99 ?

Can I just get someone to confirm/clarify for me that as of RT 3.4.4
that you MUST use mod_perl2? (or FastCGI)

I am using RHEL4 and their stock mod_perl is mod_perl-1.99_16-4.

–Chris

RT Essentials, page 14:

Any of the following will do:

  • Apache 1.3 with mod_perl 1.x
  • Apache 2.x with mod_perl 2.x

RHEL3/4 Ships Apache2 with mod_perl 1.99

Knaupp, Thomas wrote:

as well as support for mod_perl2 on Apache 2.

just a short question …
is there any chance to get it running with mod_perl1.99 ?

Can I just get someone to confirm/clarify for me that as of RT 3.4.4
that you MUST use mod_perl2? (or FastCGI)

I am using RHEL4 and their stock mod_perl is mod_perl-1.99_16-4.

mod_perl-1.99 is indeed modperl2 (It is named as 1.99 because they
released only at 2.0.0 - May 20, 2005, despite devel started on April 6,
2002)

Check the Changelog at:
http://perl.apache.org/dist/mod_perl-2.0-current/Changes

and:
http://perl.apache.org/docs/2.0/rename.html

Paulo Matos

|Sys & Net Admin | Centro de Inform�tica |
|Faculdade de Ci�ncias e Tecnologia | Tel: +351-21-2948596 |
|Universidade Nova de Lisboa | Fax: +351-21-2948548 |
|P-2829-516 Caparica | e-Mail: pjsm@fct.unl.pt |


Paulo Matos wrote:> On Tue, 13 Sep 2005, Chris Stankaitis wrote:

Knaupp, Thomas wrote:

as well as support for mod_perl2 on Apache 2.

just a short question …
is there any chance to get it running with mod_perl1.99 ?

Can I just get someone to confirm/clarify for me that as of RT 3.4.4
that you MUST use mod_perl2? (or FastCGI)

I am using RHEL4 and their stock mod_perl is mod_perl-1.99_16-4.

mod_perl-1.99 is indeed modperl2 (It is named as 1.99 because they
released only at 2.0.0 - May 20, 2005, despite devel started on April 6,
2002)

Check the Changelog at:
http://perl.apache.org/dist/mod_perl-2.0-current/Changes

and:
http://perl.apache.org/docs/2.0/rename.html

So here in we hit a problem… RHEL3/4 will continue to backport fixes
to mod_perl 199, it will likely be years before they upgrade to a 2.0X
version (RHEL5 I would assume)

If 1.99 is mod_perl2 then why won’t 3.4.4 work under it?

Sep 13 19:14:23 rt httpd: [Tue Sep 13 19:14:23 2005] [error] RT does not
support mod_perl 1.99. Please upgrade to mod_perl 2.0 at
/opt/rt3/bin/webmux.pl line 59.\nBEGIN failed–compilation aborted at
/opt/rt3/bin/webmux.pl line 63.\nCompilation failed in require at (eval
2) line 1.\n
Sep 13 19:14:23 rt httpd: [Tue Sep 13 19:14:23 2005] [error] Can’t load
Perl file: /opt/rt3/bin/webmux.pl for server rt.dw:0, exiting…

So here in we hit a problem… RHEL3/4 will continue to backport fixes
to mod_perl 199, it will likely be years before they upgrade to a 2.0X
version (RHEL5 I would assume)

If 1.99 is mod_perl2 then why won’t 3.4.4 work under it?

mod_perl 1.99 is NOT mod_perl 2.0. It’s a now-deprecated set of beta
versions.

1.99 used several different APIs over its lifetime. Different,
incompatible APIs. And different, incompatible sets of bugs.

The versions of HTML::Mason that RT needs to run with mod_perl 2.0 have
explicitly removed support for the various beta versions of 1.99.

If you need support for RT on a given version of mod_perl 1.99, Best
Practical or another perl shop could likely do the work to make it run
for you. HOWEVER, it’s something we’re explicitly uninterested in doing
and will only consider doing for a paying customer.

If you need to use a non-standard, vendor-supplied version of
Apache, we’d strongly recommend that you consider FastCGI as a
relatively painless alternative.

The above statement is our definitive policy statement on mod_perl 1.99.
Barring major changes to the state of the tools, suitcases of currency
or particularly fine vintages of Scotch or PortI don’t plan to
comment further on it.

Best,
Jesse

Guys, read this http://marc.theaimsgroup.com/?l=rt-users&m=112662785026760&w=2On 9/13/05, Paulo Matos pjsm@fct.unl.pt wrote:

On Tue, 13 Sep 2005, Chris Stankaitis wrote:

Knaupp, Thomas wrote:

as well as support for mod_perl2 on Apache 2.

just a short question …
is there any chance to get it running with mod_perl1.99 ?

Can I just get someone to confirm/clarify for me that as of RT 3.4.4
that you MUST use mod_perl2? (or FastCGI)

I am using RHEL4 and their stock mod_perl is mod_perl-1.99_16-4.

mod_perl-1.99 is indeed modperl2 (It is named as 1.99 because they
released only at 2.0.0 - May 20, 2005, despite devel started on April 6,
2002)

Check the Changelog at:
http://perl.apache.org/dist/mod_perl-2.0-current/Changes

and:
http://perl.apache.org/docs/2.0/rename.html


Paulo Matos


|Sys & Net Admin | Centro de Informática |
|Faculdade de Ciências e Tecnologia | Tel: +351-21-2948596 |
|Universidade Nova de Lisboa | Fax: +351-21-2948548 |
|P-2829-516 Caparica | e-Mail: pjsm@fct.unl.pt |



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com

Best regards, Ruslan.

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
So here in we hit a problem… RHEL3/4 will continue to backport fixes
to mod_perl 199, it will likely be years before they upgrade to a 2.0X
version (RHEL5 I would assume)

If 1.99 is mod_perl2 then why won’t 3.4.4 work under it?

1.99 is NOT mod_perl2. 1.99 was a development branch that would, in time, become mod_perl2. Many people used it as mod_perl2 in order to get mod_perl working under Apache2. However when mod_perl2 was actually released the developers made a decision to alter the API making 1.99 and 2.0 incompatible.

Applications designed for 1.99 won’t work with 2.0 and vice-versa.

In the RT world:

3.4.4 requires mod_perl2 2.0 or higher and won’t work with 1.99. Older versions of RT will work with 1.99. Go ahead and get yourself some 3.4.3 and be happy in your work. Or upgrade mod_perl to 2.01 and also be happy (although this will necessitate many other upgrades (Mason, etc…)).

So. To summarize: mod_perl 1.99 IS NOT 2.0.

-Steve

Knaupp, Thomas wrote:

as well as support for mod_perl2 on Apache 2.

just a short question …
is there any chance to get it running with mod_perl1.99 ?

Can I just get someone to confirm/clarify for me that as of RT 3.4.4
that you MUST use mod_perl2? (or FastCGI)

I am using RHEL4 and their stock mod_perl is mod_perl-1.99_16-4.

Using fastcgi as described at
http://wiki.bestpractical.com/index.cgi?RHEL4InstallGuide
is the easy route. It won’t conflict with any existing things
you might currently be doing with mod_perl on the same machine so
there is no need to change or remove your apache/mod_perl versions.

Les Mikesell
les@futuresource.com

Applications designed for 1.99 won’t work with 2.0 and vice-versa.

More critically, applications designed for 1.0, which would work with
1.99 <=12, will not work with 2.0; the apps will have to be changed.

That’s the reason why there was so much gnashing of teeth when they
change was made.

Cheers,
– jra
Jay R. Ashworth jra@baylink.com
Designer Baylink RFC 2100
Ashworth & Associates The Things I Think '87 e24
St Petersburg FL USA http://baylink.pitas.com +1 727 647 1274

"NPR has a lot in common with Nascar... we both turn to the left."
	- Peter Sagal, on Wait Wait, Don't Tell Me!

Steven E. Ames wrote:

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
So here in we hit a problem… RHEL3/4 will continue to backport fixes
to mod_perl 199, it will likely be years before they upgrade to a 2.0X
version (RHEL5 I would assume)

If 1.99 is mod_perl2 then why won’t 3.4.4 work under it?

1.99 is NOT mod_perl2. 1.99 was a development branch that would, in time, become mod_perl2. Many people used it as mod_perl2 in order to get mod_perl working under Apache2. However when mod_perl2 was actually released the developers made a decision to alter the API making 1.99 and 2.0 incompatible.

Applications designed for 1.99 won’t work with 2.0 and vice-versa.

In the RT world:

3.4.4 requires mod_perl2 2.0 or higher and won’t work with 1.99. Older versions of RT will work with 1.99. Go ahead and get yourself some 3.4.3 and be happy in your work. Or upgrade mod_perl to 2.01 and also be happy (although this will necessitate many other upgrades (Mason, etc…)).

So. To summarize: mod_perl 1.99 IS NOT 2.0.

-Steve

Thanks for the clarification Steven.

–Chris

At 9/13/2005 04:06 PM, you wrote:

In the RT world:

3.4.4 requires mod_perl2 2.0 or higher and won’t work with 1.99. Older
versions of RT will work with 1.99.

Hmmm, maybe my “novice” is showing, but isn’t it the version of Apache,
rather than the version of RT, that determines the needed version of mod_perl?

RT Essentials, page 14:
Any of the following will do:

  • Apache 1.3 with mod_perl 1.x
  • Apache 2.x with mod_perl 2.x

We are running Apache 1.3.33 with mod_perl 1.29 and RT 3.4.4 seems happy
enough. Or are we in for some rude surprises?

Thanks,
Jennifer

At 9/13/2005 04:06 PM, you wrote:

In the RT world:

3.4.4 requires mod_perl2 2.0 or higher and won’t work with 1.99. Older
versions of RT will work with 1.99.

Hmmm, maybe my “novice” is showing, but isn’t it the version of Apache,
rather than the version of RT, that determines the needed version of
mod_perl?

It’s a combination thereof. Apache1/mod_perl 1.2x should work fine with
everything from RT 3.0.x through 3.4 and 3.5.

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com]On Behalf Of Jennifer
I. Moore
Sent: Tuesday, September 13, 2005 3:42 PM
To: rt-users@lists.bestpractical.com
Subject: RE: [rt-users] RT 3.4.4 and mod_perl1.99 - clarification

At 9/13/2005 04:06 PM, you wrote:

In the RT world:

3.4.4 requires mod_perl2 2.0 or higher and won’t work with
1.99. Older
versions of RT will work with 1.99.

Hmmm, maybe my “novice” is showing, but isn’t it the version
of Apache,
rather than the version of RT, that determines the needed
version of mod_perl?

You are correct. I was assuming Apache2 :slight_smile:

RT Essentials, page 14:
Any of the following will do:

  • Apache 1.3 with mod_perl 1.x
  • Apache 2.x with mod_perl 2.x

We are running Apache 1.3.33 with mod_perl 1.29 and RT 3.4.4
seems happy
enough. Or are we in for some rude surprises?

Your all good. I was totally not taking into account Apache 1.3 installations. The page 14 summary puts it quite clearly and correctly.

-Steve

Sorry to bring this back up, but I’m very confused now by this whole
topic. Our production server, is happily running the following:

Fedora Core 3
Apache/2.0.53
mod_perl-1.99_16-3
RT 3.4.2

And works 100% ok as far as we can tell. According to the stuff I’ve
read, this should NOT work!!

On a new test server we have tried the following, which should work and
doesn’t:

Fedora Core 4
Apache/2.0.54
mod_perl-2.0.0-0.rc5.3
RT 3.4.4 or RT 3.5.2 (tried both)

We get the “usual”:

[Wed Sep 14 16:05:22 2005] [error] RT does not support mod_perl 1.99.
Please upgrade to mod_perl 2.0 at /opt/rt3/bin/webmux.pl line 59.\nBEGIN
failed–compilation aborted at /opt/rt3/bin/webmux.pl line
63.\nCompilation failed in require at(eval 2) line 1.\n
[Wed Sep 14 16:05:22 2005] [error] Can’t load Perl file:
/opt/rt3/bin/webmux.pl for server ourserver:0, exiting…

Any aid to clear the mist of confusion would be gratefully received!

Thanks!

Stewart
Stewart Tranter
Computing Services
Loughborough University

E: s.g.tranter@lboro.ac.uk
W: http://www.lboro.ac.uk/computing/
T: +44 (0) 1509 223719
F: +44 (0) 1509 223989

Sorry to bring this back up, but I’m very confused now by this whole
topic.

As far as I understood:

rt-3.4.x < 3.4.4 -> mod_perl-1.99
rt-3.4.x>= 3.4.4 -> mod_perl >= 2.00

The change from 1.99 to 2.00 brought API changes that imply making changes
in the application code. This API changes makes applications designed for
1.99 incompatible with >=2.00 and vice-versa.

Paulo Matos

|Sys & Net Admin | Centro de Inform�tica |
|Faculdade de Ci�ncias e Tecnologia | Tel: +351-21-2948596 |
|Universidade Nova de Lisboa | Fax: +351-21-2948548 |
|P-2829-516 Caparica | e-Mail: pjsm@fct.unl.pt |