Rt-2-1-49 Can't call method "handle_request"

Hello !

after fixing the typo in testdeps i am getting the following error in
apache error log. This is the same error i am getting in previous
versions, may be there is in error in my Debian installation ?

hostname:~/rt-2-1-49# /etc/init.d/apache-perl start
Starting web server: apache-perl.

Internal Server Error Message within the browser while accsessing
http://hostname/rt

hostname:~/rt-2-1-49# cat /var/log/apache-perl/error.log
[Sun Dec 1 22:25:27 2002] [notice] Apache/1.3.26 (Unix) Debian GNU/Linux
mod_perl/1.26 configured – resuming normal operations
[Sun Dec 1 22:25:27 2002] [notice] suEXEC mechanism enabled (wrapper:
/usr/lib/apache/suexec)
[Sun Dec 1 22:25:27 2002] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Sun Dec 1 22:25:31 2002] [error] Can’t call method “handle_request” on
an undefined value at /opt/rt3/bin/webmux.pl line 88.

Many thanks for your help !

Mit freundlichen Grᅵᅵen / Kind Regards
Stefan Fischer

hostname:~/rt-2-1-49# cat /var/log/apache-perl/error.log
[Sun Dec 1 22:25:27 2002] [notice] Apache/1.3.26 (Unix) Debian GNU/Linux
mod_perl/1.26 configured – resuming normal operations
[Sun Dec 1 22:25:27 2002] [notice] suEXEC mechanism enabled (wrapper:
/usr/lib/apache/suexec)
[Sun Dec 1 22:25:27 2002] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Sun Dec 1 22:25:31 2002] [error] Can’t call method “handle_request” on
an undefined value at /opt/rt3/bin/webmux.pl line 88.

Do you have PerlFreshRestart set to ‘Off’ ?

Chris Reinhardt
ctriv@dyndns.org
Systems Architect
Dynamic DNS Network Services
http://www.dyndns.org/

Hi Chris,

thank you for your reply, this solves my problem but now i get a new one. :slight_smile:

I cannot login to RT because the make inintialize database script has failed:

hostname:~/rt-2-1-49# make initialize-database
/usr/bin/perl //opt/rt3/sbin/initdb --action init --dba root
–prompt-for-dba-password
In order to create a new database and grant RT access to that database,
this script needs to connect to your mysql instance on localhost as root.
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password: Now creating a database for RT.
Creating mysql database rt3.
Now populating database schema.
Creating database schema.
schema sucessfully inserted
Now inserting database ACLs
DBD::mysql::st execute failed: MySQL server has gone away at
//opt/rt3/sbin/initdb line 224, line 397.
Problem with statement:
USE mysql;
MySQL server has gone away at //opt/rt3/sbin/initdb line 225,
line 397.
make: *** [initialize-database] Error 255

Is there any solution for this?

Many Thanks for your help !!!> On Sun, 1 Dec 2002, Stefan Fischer wrote:

hostname:~/rt-2-1-49# cat /var/log/apache-perl/error.log
[Sun Dec 1 22:25:27 2002] [notice] Apache/1.3.26 (Unix) Debian
GNU/Linux
mod_perl/1.26 configured – resuming normal operations
[Sun Dec 1 22:25:27 2002] [notice] suEXEC mechanism enabled (wrapper:
/usr/lib/apache/suexec)
[Sun Dec 1 22:25:27 2002] [notice] Accept mutex: sysvsem (Default:
sysvsem)
[Sun Dec 1 22:25:31 2002] [error] Can’t call method “handle_request” on
an undefined value at /opt/rt3/bin/webmux.pl line 88.

Do you have PerlFreshRestart set to ‘Off’ ?


Chris Reinhardt
ctriv@dyndns.org
Systems Architect
Dynamic DNS Network Services
http://www.dyndns.org/


rt-devel mailing list
rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel

Mit freundlichen Grᅵᅵen / Kind Regards
Stefan Fischer

Hi Chris,

thank you for your reply, this solves my problem but now i get a new one. :slight_smile:

I cannot login to RT because the make inintialize database script has failed:

hostname:~/rt-2-1-49# make initialize-database
/usr/bin/perl //opt/rt3/sbin/initdb --action init --dba root
–prompt-for-dba-password

You might want to try 2.1.52.

»|« http://www.bestpractical.com/rt – Trouble Ticketing. Free.