Rt 1.0.7


#1

Hello,

I am attempting to install rt 1.0.7 on a Debian GNU/Linux system

(kernel 2.2.18pre21, i686). Perl 5.005_03 is being used on this system,
along with apache-perl 1.3.9 as the httpd (version of Apache with mod_perl
module statically linked). However, when I attempt to test the perl
module dependencies, by issuing the following command:

'perl bin/testdeps.pl -warn'

I get the following returned:

'Checking for DBI...DBI not installed'
'Checking for Digest::MD5...Digest::MD5 not installed'
'Checking for CGI 2.71 ....CGI 2.71  not installed.'
'Checking for CGI::Cookie 1.16 ....CGI::Cookie 1.16  not'
'installed.'

So, I executed the following after being told that I am missing

modules:

'perl bin/testdeps.pl -fix'

This accessed a CPAN site and downloaded what I needed, everything

seemed to go okay, however after testing the dependencies, CGI 2.71 and
(CGI::Cookie) modules still cannot be found (DBI and Digest::MD5 are
installed). Any suggestions? :slight_smile:

Thanks,

Rajesh Gupta

#2

hi,

‘Checking for DBI…DBI not installed’
‘Checking for Digest::MD5…Digest::MD5 not installed’
‘Checking for CGI 2.71 …CGI 2.71 not installed.’
‘Checking for CGI::Cookie 1.16 …CGI::Cookie 1.16 not’
‘installed.’

some of these tests are buggy … you need the following
packages:
libdbi-perl
libdigest-md5-perl
libcgi-pm-perl

This accessed a CPAN site and downloaded what I needed, everything
seemed to go okay, however after testing the dependencies, CGI 2.71 and
(CGI::Cookie) modules still cannot be found (DBI and Digest::MD5 are
installed). Any suggestions? :slight_smile:

even though all the necessary modules are installed it won’t
recon them. i haven’t bothered jesse yet with it … anyway,
install the above and be happy, they work, i know it :).

so long
Othmar


#3

Hi All,
At the moment we are running an RT1 installation but are looking
to move to RT2 when beta3 comes out. However at the momoent I am trying to
setup RT2 on a FreeBSD box. The only thing is that in the README you
configure RT2 access using a VirtualHost directive. Do you have to do it
like this (e.g. rt.blah.com) as I would rather use something like an Alias
as we do on RT1 (e.g. www.blah.com/rt).

Anyhelp would be appreciated

Cheers

Rus

We are the keepers of the sacred words: ‘Ni’, ‘Peng’, and ‘Neee-wom’!
Knights Who Say Ni - Monty Python and the Holy Grail


#4

From: Russell Foster rf@rf0.com
Date: Thu, 5 Apr 2001 09:53:37 +0100 (BST)
To: rt-users@lists.fsck.com
Subject: [rt-users] VirtualHost for RT2

Hi All,
At the moment we are running an RT1 installation but are looking
to move to RT2 when beta3 comes out. However at the momoent I am trying to
setup RT2 on a FreeBSD box. The only thing is that in the README you
configure RT2 access using a VirtualHost directive. Do you have to do it
like this (e.g. rt.blah.com) as I would rather use something like an Alias
as we do on RT1 (e.g. www.blah.com/rt).

I’ve got both RT1 and RT2 running on the same box without virtual hosts.
Here is what I used in the httpd.conf file for Apache.

Alias /rt2/ "/opt/rt2/WebRT/html/"

<Location /rt2>
 PerlRequire /opt/rt2/bin/webmux.pl
 SetHandler perl-script
 PerlHandler RT::Mason
</Location>

You also have to pay close attention to your config.pm file settings in
regards to the location of the web UI:

#If you're putting the web ui somewhere other than at / on a server
$WebPath = "/rt2";

#Scheme, server and port for constructing urls to webrt

$WebBaseURL = "http://server.name";

$WebURL = $WebBaseURL . $WebPath. "/";

This works for RedHat running Apache - I can’t vouch for any other setups.

Good luck!

-Joe Bossalini


#5

Hi,
Thanks that worked lovely. Problem is now that I am getting the
following

----- The following addresses had permanent fatal errors -----
|"/mine/rt2/bin/rt-mailgate --queue general --action correspond"
(reason: 255)
(expanded from: rt)

----- Transcript of session follows -----
Can’t do setuid
554 5.3.0 |"/mine/rt2/bin/rt-mailgate --queue general --action correspond"… unknown mailer error 255

I’ve got sendmail running as root and the following

bash-2.04# ls -l
total 80
-rwxr-sr-x 1 root rt 2192 Apr 5 15:43 mason_handler.fcgi
-rwxr-sr-x 1 root rt 4645 Apr 5 15:43 mason_handler.scgi
-rwxr-sr-x 1 root rt 28848 Apr 5 15:43 rt
-rwxr-sr-x 1 root rt 15184 Apr 5 15:43 rt-mailgate
-rwxr-sr-x 1 root rt 23725 Apr 5 15:43 rtadmin
-rwxr-xr-x 1 root rt 3915 Apr 5 15:43 webmux.pl

Also I have placed a symlink from in /etc/smrsh/rt-mailgate. I’ve not
changed any entries in the RT Makefile linked to sendmail so any help
would be appreciated. TIA

Rus


#6

Sounds like you haven’t installed perl with the ability to run setuid.
Most OSes that package perl have a seperate package for setuid-perl.

    -j (who really should be packing, not answering email ;)On Thu, Apr 05, 2001 at 03:49:03PM +0100, Rus wrote:

Hi,
Thanks that worked lovely. Problem is now that I am getting the
following

----- The following addresses had permanent fatal errors -----
|"/mine/rt2/bin/rt-mailgate --queue general --action correspond"
(reason: 255)
(expanded from: rt)

----- Transcript of session follows -----
Can’t do setuid
554 5.3.0 |"/mine/rt2/bin/rt-mailgate --queue general --action correspond"… unknown mailer error 255

I’ve got sendmail running as root and the following

bash-2.04# ls -l
total 80
-rwxr-sr-x 1 root rt 2192 Apr 5 15:43 mason_handler.fcgi
-rwxr-sr-x 1 root rt 4645 Apr 5 15:43 mason_handler.scgi
-rwxr-sr-x 1 root rt 28848 Apr 5 15:43 rt
-rwxr-sr-x 1 root rt 15184 Apr 5 15:43 rt-mailgate
-rwxr-sr-x 1 root rt 23725 Apr 5 15:43 rtadmin
-rwxr-xr-x 1 root rt 3915 Apr 5 15:43 webmux.pl

Also I have placed a symlink from in /etc/smrsh/rt-mailgate. I’ve not
changed any entries in the RT Makefile linked to sendmail so any help
would be appreciated. TIA

Rus


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

I admit that X is the second worst windowing system in the world, but all the
others I’ve used are tied for first.