Rich Text doesn't show up in ticket view

I pre-apologize if this is a total newbie question - but when I create a
comment or a ticket with Rich Text in the body (say I make a name blue), the
formatting does not appear when I view the ticket.

For example, I create a ticket and type “CRITICAL ISSUE” in all red letters
at the top of a comment. When I finish the comment and click “Display” at
the top of the ticket, CRITICAL ISSUE is there, but it doesn’t show red - it
just shows black. When I “download the attachment” the html code is correct

  • which makes me wonder if it’s a browser issue or if I’m just doing
    something that’s preventing it from displaying in the UI.

Thanks in advance!

Firefox 2 (cuz ff3 is just plain SLOW on all web pages)
RT 3.8.1
Ubuntu Linux
MySQL

Thanks,
-Chris

I think RT cleans up the html for safety reasons and only displays a
subset of the html formatting (such as bold text) in the ticket display.
Emails should contain the full html though.

Does anyone know exactly what can be displayed in the ticket?

I think a feature request has been previously made for a configuration
setting that allows display of full html in the ticket. It sounds like a
good idea to me.

Gordon

Chris Nelson wrote:

Hello everyone,
I have similar problem here. I just begin to install/use rt 381 on CentOS
5.2+MySQL. That rich text box has no problem when I create new ticket, but
if the owner reply/resolve this ticket, the message box is not available,
the box not shows.
Could someone know how to fix that?
Thanks in advanced.
Br,
Mika Chu2008/9/24 gordon@cryologic.com

I think RT cleans up the html for safety reasons and only displays a
subset of the html formatting (such as bold text) in the ticket display.
Emails should contain the full html though.

Does anyone know exactly what can be displayed in the ticket?

I think a feature request has been previously made for a configuration
setting that allows display of full html in the ticket. It sounds like a
good idea to me.

Gordon

Chris Nelson wrote:

I pre-apologize if this is a total newbie question - but when I create a
comment or a ticket with Rich Text in the body (say I make a name blue),
the formatting does not appear when I view the ticket.

For example, I create a ticket and type “CRITICAL ISSUE” in all red
letters at the top of a comment. When I finish the comment and click
"Display" at the top of the ticket, CRITICAL ISSUE is there, but it
doesn’t show red - it just shows black. When I "download the attachment"
the html code is correct - which makes me wonder if it’s a browser issue
or if I’m just doing something that’s preventing it from displaying in
the UI.

Thanks in advance!

Firefox 2 (cuz ff3 is just plain SLOW on all web pages)
RT 3.8.1
Ubuntu Linux
MySQL

Thanks,
-Chris


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com