RHEL FastCGI Problems

I have RT 3.4.2 installed on RHEL 4 with all the current updates. I am
able to run through the installation without any errors and RT installs
successfully. I edited the httpd.conf file according to the
instructions on wiki.bestpractical.com and the apache service starts
successfully. I can get to the login page and login but it never makes
it to the index.html page. I get a 404 error and in the error logs for
apache I get a message about index.html not being found.

Here is my httpd.conf configuration for the virtual host:

 NameVirtualHost *:80

<VirtualHost *:80>
ServerAdmin root
DocumentRoot /var/www/html/

Adding the following for RT (the ticket tracker)

AddHandler fastcgi-script fcgi
<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

Pass through requests to display images

Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

Here are the errors that I am getting in the error.log file:

[Mon May 16 13:16:02 2005] [notice] FastCGI: process manager
initialized (pid 12536)
[Mon May 16 13:16:02 2005] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 12537)
[Mon May 16 13:16:04 2005] [notice] mod_python: Creating 4 session
mutexes based on 256 max processes and 0 max threads.
[Mon May 16 13:16:06 2005] [notice] Apache/2.0.52 (Red Hat) configured
– resuming normal operations
[Mon May 16 13:16:25 2005] [error] [client 10.0.0.29] File does not
exist: /var/www/html/index.html, referer: http://10.0.0.29/rt
[Mon May 16 13:16:26 2005] [error] [client 10.0.0.29] File does not
exist: /var/www/html/favicon.ico
[Mon May 16 13:30:40 2005] [error] [client 10.0.0.5] File does not
exist: /var/www/html/index.html, referer: http://10.0.0.29/rt

Any help would be appreciated.

Thanks,
mhb

Michael H. Brown
Network Administrator
Senex Services Corp.
317.613.3000 ext. 217
http://www.senexservicescorp.com http://www.senexservicescorp.com

The Senex Services Corp. email system added the following official information to this message.
NOTICE OF CONFIDENTIALITY
The information in this email, including attachments, may be confidential and/or privileged and may contain confidential health information. This email is intended to be reviewed only by the individual or organization named as addressee. If you have received this email in error please notify Senex Services Corp. immediately - by return message to the sender or to security@senexco.com - and destroy all copies of this message and any attachments. Please note that any views or opinions presented in this email are solely those of the author and do not necessarily represent those of Senex Services Corp. Confidential health information is protected by state and federal law, including, but not limited to, the Health Insurance Portability and Accountability Act (HIPAA) of 1996 and related regulations.

DocumentRoot looks like it might be broken. It should be (I think)
/opt/rt3/share/html/

Michael H. Brown wrote:

I have RT 3.4.2 installed on RHEL 4 with all the current updates. I
am able to run through the installation without any errors and RT
installs successfully. I edited the httpd.conf file according to the
instructions on wiki.bestpractical.com and the apache service starts
successfully. I can get to the login page and login but it never
makes it to the index.html page. I get a 404 error and in the error
logs for apache I get a message about index.html not being found.

Here is my httpd.conf configuration for the virtual host:

 NameVirtualHost *:80

<VirtualHost *:80>

ServerAdmin root

DocumentRoot /var/www/html/

Adding the following for RT (the ticket tracker)

AddHandler fastcgi-script fcgi

<Directory “/opt/rt3/share/html”>

Options FollowSymLinks ExecCGI

AllowOverride None

Pass through requests to display images

Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120

ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

Here are the errors that I am getting in the error.log file:

[Mon May 16 13:16:02 2005] [notice] FastCGI: process manager
initialized (pid 12536)

[Mon May 16 13:16:02 2005] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 12537)

[Mon May 16 13:16:04 2005] [notice] mod_python: Creating 4 session
mutexes based on 256 max processes and 0 max threads.

[Mon May 16 13:16:06 2005] [notice] Apache/2.0.52 (Red Hat) configured
– resuming normal operations

[Mon May 16 13:16:25 2005] [error] [client 10.0.0.29] File does not
exist: /var/www/html/index.html, referer: http://10.0.0.29/rt

[Mon May 16 13:16:26 2005] [error] [client 10.0.0.29] File does not
exist: /var/www/html/favicon.ico

[Mon May 16 13:30:40 2005] [error] [client 10.0.0.5] File does not
exist: /var/www/html/index.html, referer: http://10.0.0.29/rt

Any help would be appreciated.

Thanks,

 mhb

Michael H. Brown

Network Administrator

Senex Services Corp.

317.613.3000 ext. 217

http://www.senexservicescorp.com


The Senex Services Corp. email system added the following official
information to this message.

NOTICE OF CONFIDENTIALITY

The information in this email, including attachments, may be
confidential and/or privileged and may contain confidential health
information. This email is intended to be reviewed only by the
individual or organization named as addressee. If you have received
this email in error please notify Senex Services Corp. immediately -
by return message to the sender or to security@senexco.com
mailto:security@senexco.com - and destroy all copies of this message
and any attachments. Please note that any views or opinions presented
in this email are solely those of the author and do not necessarily
represent those of Senex Services Corp. Confidential health
information is protected by state and federal law, including, but not
limited to, the Health Insurance Portability and Accountability Act
(HIPAA) of 1996 and related regulations.




http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Drew Barnes
Applications Analyst
Raymond Walters College
University of Cincinnati

That’s what I thought too but when I change it to /opt/rt3/share/html/ I
get the Index.html page that says You’re almost there. FastCGI is
running so I’m not sure what’s happening.

Thanks,
mhb

Michael H. Brown
Network Administrator
Senex Services Corp.
317.613.3000 ext. 217
http://www.senexservicescorp.comFrom: Drew Barnes [mailto:barnesaw@ucrwcu.rwc.uc.edu]
Sent: Monday, May 16, 2005 2:40 PM
To: Michael H. Brown
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] RHEL FastCGI Problems

DocumentRoot looks like it might be broken. It should be (I think)
/opt/rt3/share/html/

Michael H. Brown wrote:

I have RT 3.4.2 installed on RHEL 4 with all the current updates. I
am able to run through the installation without any errors and RT
installs successfully. I edited the httpd.conf file according to the
instructions on wiki.bestpractical.com and the apache service starts
successfully. I can get to the login page and login but it never
makes it to the index.html page. I get a 404 error and in the error
logs for apache I get a message about index.html not being found.

Here is my httpd.conf configuration for the virtual host:

 NameVirtualHost *:80

<VirtualHost *:80>

ServerAdmin root

DocumentRoot /var/www/html/

Adding the following for RT (the ticket tracker)

AddHandler fastcgi-script fcgi

<Directory “/opt/rt3/share/html”>

Options FollowSymLinks ExecCGI

AllowOverride None

Pass through requests to display images

Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120

ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

Here are the errors that I am getting in the error.log file:

[Mon May 16 13:16:02 2005] [notice] FastCGI: process manager
initialized (pid 12536)

[Mon May 16 13:16:02 2005] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 12537)

[Mon May 16 13:16:04 2005] [notice] mod_python: Creating 4 session
mutexes based on 256 max processes and 0 max threads.

[Mon May 16 13:16:06 2005] [notice] Apache/2.0.52 (Red Hat) configured

– resuming normal operations

[Mon May 16 13:16:25 2005] [error] [client 10.0.0.29] File does not
exist: /var/www/html/index.html, referer: http://10.0.0.29/rt

[Mon May 16 13:16:26 2005] [error] [client 10.0.0.29] File does not
exist: /var/www/html/favicon.ico

[Mon May 16 13:30:40 2005] [error] [client 10.0.0.5] File does not
exist: /var/www/html/index.html, referer: http://10.0.0.29/rt

Any help would be appreciated.

Thanks,

 mhb

Michael H. Brown

Network Administrator

Senex Services Corp.

317.613.3000 ext. 217

http://www.senexservicescorp.com

The Senex Services Corp. email system added the following official
information to this message.

NOTICE OF CONFIDENTIALITY

The information in this email, including attachments, may be
confidential and/or privileged and may contain confidential health
information. This email is intended to be reviewed only by the
individual or organization named as addressee. If you have received
this email in error please notify Senex Services Corp. immediately -
by return message to the sender or to security@senexco.com
mailto:security@senexco.com - and destroy all copies of this message

and any attachments. Please note that any views or opinions presented

in this email are solely those of the author and do not necessarily
represent those of Senex Services Corp. Confidential health
information is protected by state and federal law, including, but not
limited to, the Health Insurance Portability and Accountability Act
(HIPAA) of 1996 and related regulations.



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Drew Barnes
Applications Analyst
Raymond Walters College
University of Cincinnati

Michael H. Brown wrote:

Here is my httpd.conf configuration for the virtual host:

 NameVirtualHost *:80

<VirtualHost *:80>
ServerAdmin root
DocumentRoot /var/www/html/

Adding the following for RT (the ticket tracker)

AddHandler fastcgi-script fcgi
<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

Pass through requests to display images

Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/

FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

I think you are missing some things. First, the VirtualHost section
requires a ServerName directive.
Then, if you decided to put rt3 at /rt URI, all the paths must be coherent.
So maybe you should try something like:

# Tell FastCGI to put its temporary files somewhere sane.

FastCgiIpcDir /tmp/fcgi
# Number of processes is tunable, but you need at least 3 or 4
# “FastCgiServer” is illegal in the VirtualHost section
FastCgiServer /opt/rt3/bin/mason_handler.fcgi
-idle-timeout 300 -processes 4
<VirtualHost *:80>
ServerName fqdn.of.your.server
DocumentRoot /your/server’s/home/page
ErrorLog /var/log/httpd-rt-error.log
CustomLog /var/log/httpd-rt.log common

 # Pass through requests to display images
 Alias /rt/ /opt/rt3/share/html/
 ScriptAlias /rt/ /opt/rt3/bin/mason_handler.fcgi/

 AddDefaultCharset UTF-8
 #the following Directory is necessary only if the default
 #is blocking access to cgi.
 <Directory /opt/rt3/bin>
     Order allow,deny
     Allow from all
 </Directory>
 #don't pass images to mason
 <Location /rt/NoAuth/images >
     SetHandler default-handler
 </Location>
 AddHandler fastcgi-script fcgi

Hope this helps,

Angelo.