REST2, ticket created but not all fields populated


#1

Hi

i am testing REST2 apis. In my case this ticket is created but “from, content, costumfields,…” are not populated. What could be an issue?

{ “Queue”: “General”, “Subject”: “Create ticket test”,
“From”: "user1@example.com", “To”: "rt@example.com",
“Content”: “Testing a create”,
“CustomFields”: {“Severity”: “Low”}}

I have this errors in log but I guess they dont make this issue:

Can't create config directory (/.w3m)!Can't create config directory (/.w3m)!Can't create config directory (/.w3m)!Can't create config directory (/.w3m)![1665] [Tue Apr 16 08:12:05 2019] [info]: <rt-4.4.1-3+deb9u3-1665-1555402325-59.13-7-0@debian> #13/105 - Scrip 7 On Create Autoreply To Requestors (/usr/share/request-tracker4/lib/RT/Action/SendEmail.pm:285)
[1665] [Tue Apr 16 08:12:05 2019] [info]: <rt-4.4.1-3+deb9u3-1665-1555402325-59.13-7-0@debian> No recipients found. Not sending. (/usr/share/request-tracker4/lib/RT/Interface/Email.pm:806)
[1665] [Tue Apr 16 08:12:05 2019] [info]: <rt-4.4.1-3+deb9u3-1665-1555402325-1659.13-8-0@debian> #13/105 - Scrip 8 On Create Notify Owner and AdminCcs (/usr/share/request-tracker4/lib/RT/Action/SendEmail.pm:285)
[1665] [Tue Apr 16 08:12:05 2019] [info]: <rt-4.4.1-3+deb9u3-1665-1555402325-1659.13-8-0@debian> No recipients found. Not sending. (/usr/share/request-tracker4/lib/RT/Interface/Email.pm:806)
[1665] [Tue Apr 16 08:12:05 2019] [info]: <rt-4.4.1-3+deb9u3-1665-1555402325-1568.13-9-0@debian> #13/105 - Scrip 9 On Create Notify Ccs (/usr/share/request-tracker4/lib/RT/Action/SendEmail.pm:285)
[1665] [Tue Apr 16 08:12:05 2019] [info]: <rt-4.4.1-3+deb9u3-1665-1555402325-1568.13-9-0@debian> No recipients found. Not sending. (/usr/share/request-tracker4/lib/RT/Interface/Email.pm:806)
[1665] [Tue Apr 16 08:12:05 2019] [info]: <rt-4.4.1-3+deb9u3-1665-1555402325-35.13-10-0@debian> #13/105 - Scrip 10 On Create Notify Other Recipients (/usr/share/request-tracker4/lib/RT/Action/SendEmail.pm:285)
[1665] [Tue Apr 16 08:12:05 2019] [info]: <rt-4.4.1-3+deb9u3-1665-1555402325-35.13-10-0@debian> No recipients found. Not sending. (/usr/share/request-tracker4/lib/RT/Interface/Email.pm:806)
[1665] [Tue Apr 16 08:12:05 2019] [info]: Ticket 13 created in queue 'General' by root (/usr/share/request-tracker4/lib/RT/Ticket

#2

Perhaps try turning on debugging log level? You could also check your web server error log.

For the CustomFields, unless you’re using my patches you need to specify the CustomField by the Id number.

Cheers,
Andrew


#3

ok, thank you. Can you help me get debugging enabled? Wher this is done?

tnx


#4

I have enabled logging but I do not see any issue in logs regarding this:

{ “Subject”: “new”, “Text”: “asdasdasMihasadasd”, “Queue”:“General”}
Also reposnse is ok from server. I read that there was issue with REST2 api.