ReplyToRequestors and Mailing Lists

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On my RT 3.4.5 system, I find that the AutoReply to Requestors scrip isn’t
triggered if the incoming mail comes from a mailing list, whereas it works
fine when the mail was sent directly to RT by the user.

This list is just a forwarder (e.g., not a majordomo list), so there’s not
much that can be configured on the list end. Is there some RT
configuration option that can help (or is at fault) here?

Thanks.

Mike

Mike Friedman IST/System and Network Security
mikef@berkeley.edu 2484 Shattuck Avenue
1-510-642-1410 University of California at Berkeley
http://socrates.berkeley.edu/~mikef http://security.berkeley.edu

-----BEGIN PGP SIGNATURE-----
Version: PGP 6.5.8

iQA/AwUBRODVLa0bf1iNr4mCEQK9SgCfcgohUk2Ydbi2ptgXrFq+BZP3KzEAoLW6
9bVJAsO7leQZnKNPIOyA7Ae3
=FLhs
-----END PGP SIGNATURE-----

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I think I’ve discovered my problem, which leads to a question about RT’s
behavior.

It turns out that the mailing list we’re using to forward mail to RT is
a Majordomo list. And it appears that Majordomo causes a ‘Precedence:
bulk’ header to be inserted into mail it generates.

Now, looking at RT’s code (in Interface/Email.pm), I find that RT won’t
reply to the sender of ‘AutoGenerated’ mail, which includes mail
containing a ‘Precedence: bulk’ header. And I don’t find any RT
configuration option to override this behavior.

So, now I’m wondering if I should mod RT to remove ‘Precedence: bulk’ from
the criteria for ‘AutoGenerated’ mail. Is this a bad idea? If so, what’s
my alternative? Our central campus mail service no longer allows setting
up of ‘simple’ mailing lists (i.e., just forwarders), because of ‘spamming
issues’.

Does Majordomo have an option to keep the ‘Precedence: bulk’ header from
being inserted?

(Questions, questions …).

Suggestions appreciated.

Thanks.

Mike
Mike Friedman IST/System and Network Security
mikef@berkeley.edu 2484 Shattuck Avenue
1-510-642-1410 University of California at Berkeley
http://socrates.berkeley.edu/~mikef http://security.berkeley.edu

On my RT 3.4.5 system, I find that the AutoReply to Requestors scrip isn’t
triggered if the incoming mail comes from a mailing list, whereas it works fine
when the mail was sent directly to RT by the user.

This list is just a forwarder (e.g., not a majordomo list), so there’s not much
that can be configured on the list end. Is there some RT configuration option
that can help (or is at fault) here?

Thanks.

Mike

-----BEGIN PGP SIGNATURE-----
Version: PGP 6.5.8

iQA/AwUBROHvQq0bf1iNr4mCEQLaGgCdGsJR5SoBVU/cHyYm/ARBZ3LWgoAAn3Od
GDVCvtN2fwammc5OKP9OnD1T
=Ikqq
-----END PGP SIGNATURE-----