Reply mail seems never to be send out

Hi,
I just installed RT 2.0.8 on a RedHat 7.2 system. I configured it to use
sendmail (with a symlink of /opt/rt2/bin/rt-mailgate to
/etc/smrsh/rt-mailgate). I am able to create tickets via e-mail, and if a
user tries to create a ticket without having permissions to do so, he (and
me as the admin) gets an e-mail telling him so.
So e-mail in general seems to work, but when I try to do a reply to a
ticket, the reply is never actually send out. RT appends everything nicely
to the ticket history, when I look into the maillog of the system nothing
has bee send (i.e. no entry in maillog, /var/spool/mqueue untouched) and
also no new entry under /var/log/rt .
I tried the different given configurations in config.pm (with or without
sendmailpipe, with a simple ‘-oi’ option or the long version), but no
changes.
The fact that no errors are reported, makes it hard to track it down.
I have given my “outgoing mail config” below.

Any ideas ?

Frank

{{{ Outgoing mail configuration

#$MailAlias is a generic alias to send mail to for any request
#already in a queue.

#RT is designed such that any mail which already has a ticket-id
associated
#with it will get to the right place automatically.

#This is the default address that will be listed in
#From: and Reply-To: headers of mail tracked by RT unless overridden
#by a queue specific address

$CorrespondAddress=‘666@zurich.ibm.com’;

$CommentAddress=‘666@zurich.ibm.com’;

#Sendmail Configuration

$MailCommand defines which method RT will use to try to send mail

We know that ‘sendmail’ works fairly well.

If ‘sendmail’ doesn’t work well for you, try ‘sendmailpipe’

But note that you have to configure $SendmailPath and add a -t

to $SendmailArguments

$MailCommand = ‘sendmail’;

$SendmailArguments defines what flags to pass to $Sendmail

assuming you picked ‘sendmail’ or ‘sendmailpipe’ as the $MailCommand

above.

If you picked ‘sendmailpipe’, you MUST add a -t flag to

$SendmailArguments

These options are good for most sendmail wrappers and workalikes

#$SendmailArguments="-oi";

These arguments are good for sendmail brand sendmail 8 and newer

$SendmailArguments="-oi -ODeliveryMode=b -OErrorMode=m";

If you selected ‘sendmailpipe’ above, you MUST specify the path

to your sendmail binary in $SendmailPath.

!! If you did not # select ‘sendmailpipe’ above, this has no effect!!

$SendmailPath = “/usr/sbin/sendmail”;

RT can optionally set a “Friendly” ‘To:’ header when sending messages to

Ccs or AdminCcs (rather than having a blank ‘To:’ header.

This feature DOES NOT WORK WITH SENDMAIL[tm] BRAND SENDMAIL

If you are using sendmail, rather than postfix, qmail, exim or some

other MTA,

you must disable this option.

$UseFriendlyToLine = 0;

}}}

Dr. Frank Bagehorn
IBM Zurich Research Lab.
Saeumerstr. 4
CH-8803 Rueschlikon
Switzerland
SMTP: fba@zurich.ibm.com
Notes: Frank Bagehorn/Zurich/IBM@IBMCH
phone: ++41 (01) 724 83 23 fax: ++41 (01) 724 89 59

Have you set up scrips to send mail, per the advice in the installation
and configuration guide?On Tue, Nov 13, 2001 at 05:45:27PM +0100, Frank Bagehorn wrote:

Hi,
I just installed RT 2.0.8 on a RedHat 7.2 system. I configured it to use
sendmail (with a symlink of /opt/rt2/bin/rt-mailgate to
/etc/smrsh/rt-mailgate). I am able to create tickets via e-mail, and if a
user tries to create a ticket without having permissions to do so, he (and
me as the admin) gets an e-mail telling him so.
So e-mail in general seems to work, but when I try to do a reply to a
ticket, the reply is never actually send out. RT appends everything nicely
to the ticket history, when I look into the maillog of the system nothing
has bee send (i.e. no entry in maillog, /var/spool/mqueue untouched) and
also no new entry under /var/log/rt .
I tried the different given configurations in config.pm (with or without
sendmailpipe, with a simple ‘-oi’ option or the long version), but no
changes.
The fact that no errors are reported, makes it hard to track it down.
I have given my “outgoing mail config” below.

Any ideas ?

Frank

{{{ Outgoing mail configuration

#$MailAlias is a generic alias to send mail to for any request
#already in a queue.

#RT is designed such that any mail which already has a ticket-id
associated
#with it will get to the right place automatically.

#This is the default address that will be listed in
#From: and Reply-To: headers of mail tracked by RT unless overridden
#by a queue specific address

$CorrespondAddress=‘666@zurich.ibm.com’;

$CommentAddress=‘666@zurich.ibm.com’;

#Sendmail Configuration

$MailCommand defines which method RT will use to try to send mail

We know that ‘sendmail’ works fairly well.

If ‘sendmail’ doesn’t work well for you, try ‘sendmailpipe’

But note that you have to configure $SendmailPath and add a -t

to $SendmailArguments

$MailCommand = ‘sendmail’;

$SendmailArguments defines what flags to pass to $Sendmail

assuming you picked ‘sendmail’ or ‘sendmailpipe’ as the $MailCommand

above.

If you picked ‘sendmailpipe’, you MUST add a -t flag to

$SendmailArguments

These options are good for most sendmail wrappers and workalikes

#$SendmailArguments="-oi";

These arguments are good for sendmail brand sendmail 8 and newer

$SendmailArguments="-oi -ODeliveryMode=b -OErrorMode=m";

If you selected ‘sendmailpipe’ above, you MUST specify the path

to your sendmail binary in $SendmailPath.

!! If you did not # select ‘sendmailpipe’ above, this has no effect!!

$SendmailPath = “/usr/sbin/sendmail”;

RT can optionally set a “Friendly” ‘To:’ header when sending messages to

Ccs or AdminCcs (rather than having a blank ‘To:’ header.

This feature DOES NOT WORK WITH SENDMAIL[tm] BRAND SENDMAIL

If you are using sendmail, rather than postfix, qmail, exim or some

other MTA,

you must disable this option.

$UseFriendlyToLine = 0;

}}}


Dr. Frank Bagehorn
IBM Zurich Research Lab.
Saeumerstr. 4
CH-8803 Rueschlikon
Switzerland

SMTP: fba@zurich.ibm.com
Notes: Frank Bagehorn/Zurich/IBM@IBMCH
phone: ++41 (01) 724 83 23 fax: ++41 (01) 724 89 59


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.

Yes, I have and e.g. autoreply works and sends out an e-mail to the
requestor.
However a reply “by hand” doesn’t work and this should work independently
of a scrips configuration, shouldn’t it ?

Frank

Dr. Frank Bagehorn
IBM Zurich Research Lab.
Saeumerstr. 4
CH-8803 Rueschlikon
Switzerland
SMTP: fba@zurich.ibm.com
Notes: Frank Bagehorn/Zurich/IBM@IBMCH
phone: ++41 (01) 724 83 23 fax: ++41 (01) 724 89 59

Have you set up scrips to send mail, per the advice in the installation
and configuration guide?

Hi,
I just installed RT 2.0.8 on a RedHat 7.2 system. I configured it to use

sendmail (with a symlink of /opt/rt2/bin/rt-mailgate to
/etc/smrsh/rt-mailgate). I am able to create tickets via e-mail, and if
a
user tries to create a ticket without having permissions to do so, he
(and
me as the admin) gets an e-mail telling him so.
So e-mail in general seems to work, but when I try to do a reply to a
ticket, the reply is never actually send out. RT appends everything
nicely
to the ticket history, when I look into the maillog of the system
nothing
has bee send (i.e. no entry in maillog, /var/spool/mqueue untouched) and

also no new entry under /var/log/rt .
I tried the different given configurations in config.pm (with or without

sendmailpipe, with a simple ‘-oi’ option or the long version), but no
changes.
The fact that no errors are reported, makes it hard to track it down.
I have given my “outgoing mail config” below.

Any ideas ?

Frank

{{{ Outgoing mail configuration

#$MailAlias is a generic alias to send mail to for any request
#already in a queue.

#RT is designed such that any mail which already has a ticket-id
associated
#with it will get to the right place automatically.

#This is the default address that will be listed in
#From: and Reply-To: headers of mail tracked by RT unless overridden
#by a queue specific address

$CorrespondAddress=‘666@zurich.ibm.com’;

$CommentAddress=‘666@zurich.ibm.com’;

#Sendmail Configuration

$MailCommand defines which method RT will use to try to send mail

We know that ‘sendmail’ works fairly well.

If ‘sendmail’ doesn’t work well for you, try ‘sendmailpipe’

But note that you have to configure $SendmailPath and add a -t

to $SendmailArguments

$MailCommand = ‘sendmail’;

$SendmailArguments defines what flags to pass to $Sendmail

assuming you picked ‘sendmail’ or ‘sendmailpipe’ as the $MailCommand

above.

If you picked ‘sendmailpipe’, you MUST add a -t flag to

$SendmailArguments

These options are good for most sendmail wrappers and workalikes

#$SendmailArguments="-oi";

These arguments are good for sendmail brand sendmail 8 and newer

$SendmailArguments="-oi -ODeliveryMode=b -OErrorMode=m";

If you selected ‘sendmailpipe’ above, you MUST specify the path

to your sendmail binary in $SendmailPath.

!! If you did not # select ‘sendmailpipe’ above, this has no effect!!

$SendmailPath = “/usr/sbin/sendmail”;

RT can optionally set a “Friendly” ‘To:’ header when sending messages

to

Ccs or AdminCcs (rather than having a blank ‘To:’ header.

This feature DOES NOT WORK WITH SENDMAIL[tm] BRAND SENDMAIL

If you are using sendmail, rather than postfix, qmail, exim or some

other MTA,

you must disable this option.

$UseFriendlyToLine = 0;

}}}


Dr. Frank Bagehorn
IBM Zurich Research Lab.
Saeumerstr. 4
CH-8803 Rueschlikon
Switzerland

SMTP: fba@zurich.ibm.com
Notes: Frank Bagehorn/Zurich/IBM@IBMCH
phone: ++41 (01) 724 83 23 fax: ++41 (01) 724 89 59


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.

Are you having problems with the fact that RT never CCs the Sender of a
message when it sends it out to requestors/ccs/adminccs?On Tue, Nov 13, 2001 at 06:32:45PM +0100, Frank Bagehorn wrote:

Yes, I have and e.g. autoreply works and sends out an e-mail to the
requestor.
However a reply “by hand” doesn’t work and this should work independently
of a scrips configuration, shouldn’t it ?

Frank


Dr. Frank Bagehorn
IBM Zurich Research Lab.
Saeumerstr. 4
CH-8803 Rueschlikon
Switzerland

SMTP: fba@zurich.ibm.com
Notes: Frank Bagehorn/Zurich/IBM@IBMCH
phone: ++41 (01) 724 83 23 fax: ++41 (01) 724 89 59

Have you set up scrips to send mail, per the advice in the installation
and configuration guide?

On Tue, Nov 13, 2001 at 05:45:27PM +0100, Frank Bagehorn wrote:

Hi,
I just installed RT 2.0.8 on a RedHat 7.2 system. I configured it to use

sendmail (with a symlink of /opt/rt2/bin/rt-mailgate to
/etc/smrsh/rt-mailgate). I am able to create tickets via e-mail, and if
a
user tries to create a ticket without having permissions to do so, he
(and
me as the admin) gets an e-mail telling him so.
So e-mail in general seems to work, but when I try to do a reply to a
ticket, the reply is never actually send out. RT appends everything
nicely
to the ticket history, when I look into the maillog of the system
nothing
has bee send (i.e. no entry in maillog, /var/spool/mqueue untouched) and

also no new entry under /var/log/rt .
I tried the different given configurations in config.pm (with or without

sendmailpipe, with a simple ‘-oi’ option or the long version), but no
changes.
The fact that no errors are reported, makes it hard to track it down.
I have given my “outgoing mail config” below.

Any ideas ?

Frank

{{{ Outgoing mail configuration

#$MailAlias is a generic alias to send mail to for any request
#already in a queue.

#RT is designed such that any mail which already has a ticket-id
associated
#with it will get to the right place automatically.

#This is the default address that will be listed in
#From: and Reply-To: headers of mail tracked by RT unless overridden
#by a queue specific address

$CorrespondAddress=‘666@zurich.ibm.com’;

$CommentAddress=‘666@zurich.ibm.com’;

#Sendmail Configuration

$MailCommand defines which method RT will use to try to send mail

We know that ‘sendmail’ works fairly well.

If ‘sendmail’ doesn’t work well for you, try ‘sendmailpipe’

But note that you have to configure $SendmailPath and add a -t

to $SendmailArguments

$MailCommand = ‘sendmail’;

$SendmailArguments defines what flags to pass to $Sendmail

assuming you picked ‘sendmail’ or ‘sendmailpipe’ as the $MailCommand

above.

If you picked ‘sendmailpipe’, you MUST add a -t flag to

$SendmailArguments

These options are good for most sendmail wrappers and workalikes

#$SendmailArguments="-oi";

These arguments are good for sendmail brand sendmail 8 and newer

$SendmailArguments="-oi -ODeliveryMode=b -OErrorMode=m";

If you selected ‘sendmailpipe’ above, you MUST specify the path

to your sendmail binary in $SendmailPath.

!! If you did not # select ‘sendmailpipe’ above, this has no effect!!

$SendmailPath = “/usr/sbin/sendmail”;

RT can optionally set a “Friendly” ‘To:’ header when sending messages

to

Ccs or AdminCcs (rather than having a blank ‘To:’ header.

This feature DOES NOT WORK WITH SENDMAIL[tm] BRAND SENDMAIL

If you are using sendmail, rather than postfix, qmail, exim or some

other MTA,

you must disable this option.

$UseFriendlyToLine = 0;

}}}


Dr. Frank Bagehorn
IBM Zurich Research Lab.
Saeumerstr. 4
CH-8803 Rueschlikon
Switzerland

SMTP: fba@zurich.ibm.com
Notes: Frank Bagehorn/Zurich/IBM@IBMCH
phone: ++41 (01) 724 83 23 fax: ++41 (01) 724 89 59


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.

No, its much simpler. I’m having problems with the fact that RT doesn’t
send out the reply to the requestors/ccs/adminccs … :frowning:
(Which is curious since autoreplies and error messages are sent out.)

Frank

Dr. Frank Bagehorn
IBM Zurich Research Lab.
Saeumerstr. 4
CH-8803 Rueschlikon
Switzerland
SMTP: fba@zurich.ibm.com
Notes: Frank Bagehorn/Zurich/IBM@IBMCH
phone: ++41 (01) 724 83 23 fax: ++41 (01) 724 89 59

Are you having problems with the fact that RT never CCs the Sender of a
message when it sends it out to requestors/ccs/adminccs?

Yes, I have and e.g. autoreply works and sends out an e-mail to the
requestor.
However a reply “by hand” doesn’t work and this should work
independently
of a scrips configuration, shouldn’t it ?

Frank


Dr. Frank Bagehorn
IBM Zurich Research Lab.
Saeumerstr. 4
CH-8803 Rueschlikon
Switzerland

SMTP: fba@zurich.ibm.com
Notes: Frank Bagehorn/Zurich/IBM@IBMCH
phone: ++41 (01) 724 83 23 fax: ++41 (01) 724 89 59

Have you set up scrips to send mail, per the advice in the
installation

and configuration guide?

Hi,
I just installed RT 2.0.8 on a RedHat 7.2 system. I configured it to
use

sendmail (with a symlink of /opt/rt2/bin/rt-mailgate to
/etc/smrsh/rt-mailgate). I am able to create tickets via e-mail, and
if
a

user tries to create a ticket without having permissions to do so, he
(and
me as the admin) gets an e-mail telling him so.
So e-mail in general seems to work, but when I try to do a reply to a
ticket, the reply is never actually send out. RT appends everything
nicely
to the ticket history, when I look into the maillog of the system
nothing
has bee send (i.e. no entry in maillog, /var/spool/mqueue untouched)
and

also no new entry under /var/log/rt .
I tried the different given configurations in config.pm (with or
without

sendmailpipe, with a simple ‘-oi’ option or the long version), but no
changes.
The fact that no errors are reported, makes it hard to track it down.
I have given my “outgoing mail config” below.

Any ideas ?

Frank

{{{ Outgoing mail configuration

#$MailAlias is a generic alias to send mail to for any request
#already in a queue.

#RT is designed such that any mail which already has a ticket-id
associated
#with it will get to the right place automatically.

#This is the default address that will be listed in
#From: and Reply-To: headers of mail tracked by RT unless overridden
#by a queue specific address

$CorrespondAddress=‘666@zurich.ibm.com’;

$CommentAddress=‘666@zurich.ibm.com’;

#Sendmail Configuration

$MailCommand defines which method RT will use to try to send mail

We know that ‘sendmail’ works fairly well.

If ‘sendmail’ doesn’t work well for you, try ‘sendmailpipe’

But note that you have to configure $SendmailPath and add a -t

to $SendmailArguments

$MailCommand = ‘sendmail’;

$SendmailArguments defines what flags to pass to $Sendmail

assuming you picked ‘sendmail’ or ‘sendmailpipe’ as the $MailCommand

above.

If you picked ‘sendmailpipe’, you MUST add a -t flag to

$SendmailArguments

These options are good for most sendmail wrappers and workalikes

#$SendmailArguments="-oi";

These arguments are good for sendmail brand sendmail 8 and newer

$SendmailArguments="-oi -ODeliveryMode=b -OErrorMode=m";

If you selected ‘sendmailpipe’ above, you MUST specify the path

to your sendmail binary in $SendmailPath.

!! If you did not # select ‘sendmailpipe’ above, this has no

effect!!

$SendmailPath = “/usr/sbin/sendmail”;

RT can optionally set a “Friendly” ‘To:’ header when sending

messages

to

Ccs or AdminCcs (rather than having a blank ‘To:’ header.

This feature DOES NOT WORK WITH SENDMAIL[tm] BRAND SENDMAIL

If you are using sendmail, rather than postfix, qmail, exim or some

other MTA,

you must disable this option.

$UseFriendlyToLine = 0;

}}}


Dr. Frank Bagehorn
IBM Zurich Research Lab.
Saeumerstr. 4
CH-8803 Rueschlikon
Switzerland

SMTP: fba@zurich.ibm.com
Notes: Frank Bagehorn/Zurich/IBM@IBMCH
phone: ++41 (01) 724 83 23 fax: ++41 (01) 724 89 59


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.