Regular Authentication and ExternalAuth RT 3.8.1

Hello,

It appears that after I got Apache/MySql working previously, I am unable to login with the default username/password (root/password) to the web interface. I started a new topic for this. I also tried adding settings in for ExternalAuth to the RT_SiteConfig.pm. I am getting an @INC error in Apache when I try restarting the service. Even before I added the “External Authentication” variables, “LDAP” variables and the “ExternalAuth” Plugin setting, I still could not login using root and password.

/opt/rt3/etc/RT_SiteConfig.pm settings:

Set( $rtname, ‘example.com’);

Set(@Plugins,(qw(Extension::QuickDelete)));

Set($WebPath, “/rt3”);

Set($rtname, “broadvox.local”);
Set($Orginization, ‘broadvox.local’);
Set($CorrespondAddress, ‘echatham@broadvox.net’);
Set($CommentAddress, ‘echatham@infotelecom.us’);
Set($Timezone, ‘US/Eastern’);

Set($WebBaseURL, ‘http://rt.broadvox.local/’);

Set(@Plugins, qw(RT::Authen::ExternalAuth));

Database

Set($DatabaseType, ‘mysql’);
Set($DatabaseUser, ‘rt_user’);
Set($DatabasePassword, ‘rt_pass’);
Set($DatabaseRTHost, ‘localhost’);

External Authentication

Set($ExternalAuthPriority, [‘My_LDAP’]);
Set($ExternalInfoPriority, [‘My_LDAP’]);
Set($AutoCreateNonExternalUsers, 1);
Set($ExternalAuthPriority, [‘My_LDAP’, ‘My_MySQL’, ‘My_Oracle’, ‘SecondaryLDAP’, ‘Other-DB’]);

LDAP

Set($AuthMethods, [‘LDAP’, ‘Internal’]);
Set($LdapExternalAuth, 0);
Set($LdapExternalInfo, 0);
Set($LdapAutoCreateNonLdapUsers, 1);
Set($LdapAttrMap, {‘Name’ => ‘sAMAccountName’,
‘EmailAddress’ => ‘mail’,
‘Orginization’ => ‘o’,
‘RealName’ => ‘cn’,
‘ExternalContactInfoId’ => ‘dn’,
‘ExternalAuthId’ => ‘sAMAccountName’,
‘Gecos’, => ‘sAMAccountName’,
‘WorkPhone’, => ‘telephoneNumber’,
‘Address1’ => ‘streetAddress’,
‘City’ => ‘l’,
‘State’ => ‘st’,
‘Zip’ => ‘postalCode’,
‘Country’ => ‘co’});
Set($LdapRTAttrMatchList, [‘ExternalContactInfoId’, ‘Name’,
‘EmailAddress’, ‘RealName’,
‘WorkPhone’, ‘Address2’]);
Set($LdapEmailAttrMatchList, [‘mail’, ‘mailRoutingAddress’,
‘mailAlternateAddress’]);
Set($LdapEmailAttrMatchPrefix, [’’, ‘smtp’, ‘SMTP:’]);
Set($LdapServer, ‘clehbdc01.broadvox.local’);
Set($LdapBase, ‘OU=USA,DC=broadvox,DC=local’);
Set($LdapFilter, ‘(objectClass=*)’);
1;

APACHE ERROR_LOG:

[Tue May 19 12:54:25 2009] [error] Can’t load Perl file: /opt/rt3/bin/webmux.pl for server clehbrtsrv01.broadvox.local:0, exiting…
[Tue May 19 12:55:17 2009] [error] Can’t locate RT/Authen/ExternalAuth.pm in @INC (@INC contains: /opt/rt3/bin/…/local/lib /opt/rt3/bin/…/lib /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 . /etc/httpd) at /opt/rt3/bin/…/lib/RT.pm line 625.\nCompilation failed in require at (eval 2) line 1.\n
[Tue May 19 12:55:17 2009] [error] Can’t load Perl file: /opt/rt3/bin/webmux.pl for server clehbrtsrv01.broadvox.local:0, exiting…

Eric Chatham
MIS Department
Phone: (216) 373-4683
Fax: (216) 373-4669
echatham@broadvox.net
[cid:image001.gif@01C9D882.351CFC90]

CONFIDENTIAL. This e-mail and any attached files are confidential and should be destroyed and/or returned if you are not the intended and proper recipient.

Hello,

I forgot to add the error_log example, when I comment out all the LDAP and ExternalAuth Settings in RT_SiteConfig.pm. I’ve tried using root and password to logon to the web interface with no avail. What could be happening? There’s got to be somewhere this program retrieves root name and password password.

APACHE ERROR_LOG:

[Tue May 19 17:12:33 2009] [notice] caught SIGTERM, shutting down
[Tue May 19 17:12:36 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue May 19 17:12:38 2009] [notice] Digest: generating secret for digest authentication …
[Tue May 19 17:12:38 2009] [notice] Digest: done
[Tue May 19 17:12:39 2009] [notice] Apache/2.2.3 (CentOS) configured – resuming normal operations
[Tue May 19 21:12:48 2009] [error]: FAILED LOGIN for root from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Tue May 19 21:12:53 2009] [error]: FAILED LOGIN for root from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Tue May 19 21:13:36 2009] [error]: FAILED LOGIN for root from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Tue May 19 21:13:37 2009] [error]: FAILED LOGIN for root from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Tue May 19 21:13:38 2009] [error]: FAILED LOGIN for root from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Tue May 19 21:13:39 2009] [error]: FAILED LOGIN for root from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Tue May 19 21:20:59 2009] [error]: FAILED LOGIN for from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Tue May 19 21:21:00 2009] [error]: FAILED LOGIN for from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Tue May 19 21:21:01 2009] [error]: FAILED LOGIN for from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Tue May 19 21:21:18 2009] [error]: FAILED LOGIN for from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Tue May 19 17:24:54 2009] [notice] caught SIGTERM, shutting down
[Tue May 19 17:24:57 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue May 19 17:24:59 2009] [notice] Digest: generating secret for digest authentication …
[Tue May 19 17:24:59 2009] [notice] Digest: done
[Tue May 19 17:25:00 2009] [notice] Apache/2.2.3 (CentOS) configured – resuming normal operations
[Tue May 19 21:25:09 2009] [error]: FAILED LOGIN for root from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Tue May 19 21:25:14 2009] [error]: FAILED LOGIN for root from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Tue May 19 21:30:47 2009] [error]: FAILED LOGIN for root from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Tue May 19 21:30:52 2009] [error]: FAILED LOGIN for root from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)

RT_SITECONFIG SETTINGS:

Set( $rtname, ‘example.com’);

Set(@Plugins,(qw(Extension::QuickDelete)));

Set($WebPath, “/rt3”);

Set($rtname, “broadvox.local”);
Set($Orginization, ‘broadvox.local’);
Set($CorrespondAddress, ‘echatham@broadvox.net’);
Set($CommentAddress, ‘echatham@infotelecom.us’);
Set($Timezone, ‘US/Eastern’);

Set($WebBaseURL, ‘http://rt.broadvox.local/’);

Set(@Plugins, qw(RT::Authen::ExternalAuth));

Database

Set($DatabaseType, ‘mysql’);

Set($DatabaseUser, ‘rt_user’);

Set($DatabasePassword, ‘rt_pass’);

Set($DatabaseRTHost, ‘localhost’);

External Authentication

Set($ExternalAuthPriority, [‘My_LDAP’]);

Set($ExternalInfoPriority, [‘My_LDAP’]);

Set($AutoCreateNonExternalUsers, 1);

Set($ExternalAuthPriority, [‘My_LDAP’, ‘My_MySQL’, ‘My_Oracle’, ‘SecondaryLDAP’, ‘Other-DB’]);

LDAP

Set($AuthMethods, [‘My_LDAP’, ‘Internal’]);

Set($LdapExternalAuth, 0);

Set($LdapExternalInfo, 0);

Set($LdapAutoCreateNonLdapUsers, 1);

Set($LdapAttrMap, {‘Name’ => ‘sAMAccountName’,

‘EmailAddress’ => ‘mail’,

‘Orginization’ => ‘o’,

‘RealName’ => ‘cn’,

‘ExternalContactInfoId’ => ‘dn’,

‘ExternalAuthId’ => ‘sAMAccountName’,

‘Gecos’, => ‘sAMAccountName’,

‘WorkPhone’, => ‘telephoneNumber’,

‘Address1’ => ‘streetAddress’,

‘City’ => ‘l’,

‘State’ => ‘st’,

‘Zip’ => ‘postalCode’,

‘Country’ => ‘co’});

Set($LdapRTAttrMatchList, [‘ExternalContactInfoId’, ‘Name’,

‘EmailAddress’, ‘RealName’,

‘WorkPhone’, ‘Address2’]);

Set($LdapEmailAttrMatchList, [‘mail’, ‘mailRoutingAddress’,

‘mailAlternateAddress’]);

Set($LdapEmailAttrMatchPrefix, [’’, ‘smtp’, ‘SMTP:’]);

Set($LdapServer, ‘clehbdc01.broadvox.local’);

Set($LdapBase, ‘OU=USA,DC=broadvox,DC=local’);

Set($LdapFilter, ‘(objectClass=*)’);

1;From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Eric Chatham
Sent: Tuesday, May 19, 2009 13:10
To: RT-Users@lists.bestpractical.com
Subject: [rt-users] Regular Authentication and ExternalAuth RT 3.8.1

Hello,

It appears that after I got Apache/MySql working previously, I am unable to login with the default username/password (root/password) to the web interface. I started a new topic for this. I also tried adding settings in for ExternalAuth to the RT_SiteConfig.pm. I am getting an @INC error in Apache when I try restarting the service. Even before I added the “External Authentication” variables, “LDAP” variables and the “ExternalAuth” Plugin setting, I still could not login using root and password.

/opt/rt3/etc/RT_SiteConfig.pm settings:

Set( $rtname, ‘example.com’);

Set(@Plugins,(qw(Extension::QuickDelete)));

Set($WebPath, “/rt3”);

Set($rtname, “broadvox.local”);
Set($Orginization, ‘broadvox.local’);
Set($CorrespondAddress, ‘echatham@broadvox.net’);
Set($CommentAddress, ‘echatham@infotelecom.us’);
Set($Timezone, ‘US/Eastern’);

Set($WebBaseURL, ‘http://rt.broadvox.local/’);

Set(@Plugins, qw(RT::Authen::ExternalAuth));

Database

Set($DatabaseType, ‘mysql’);
Set($DatabaseUser, ‘rt_user’);
Set($DatabasePassword, ‘rt_pass’);
Set($DatabaseRTHost, ‘localhost’);

External Authentication

Set($ExternalAuthPriority, [‘My_LDAP’]);
Set($ExternalInfoPriority, [‘My_LDAP’]);
Set($AutoCreateNonExternalUsers, 1);
Set($ExternalAuthPriority, [‘My_LDAP’, ‘My_MySQL’, ‘My_Oracle’, ‘SecondaryLDAP’, ‘Other-DB’]);

LDAP

Set($AuthMethods, [‘LDAP’, ‘Internal’]);
Set($LdapExternalAuth, 0);
Set($LdapExternalInfo, 0);
Set($LdapAutoCreateNonLdapUsers, 1);
Set($LdapAttrMap, {‘Name’ => ‘sAMAccountName’,
‘EmailAddress’ => ‘mail’,
‘Orginization’ => ‘o’,
‘RealName’ => ‘cn’,
‘ExternalContactInfoId’ => ‘dn’,
‘ExternalAuthId’ => ‘sAMAccountName’,
‘Gecos’, => ‘sAMAccountName’,
‘WorkPhone’, => ‘telephoneNumber’,
‘Address1’ => ‘streetAddress’,
‘City’ => ‘l’,
‘State’ => ‘st’,
‘Zip’ => ‘postalCode’,
‘Country’ => ‘co’});
Set($LdapRTAttrMatchList, [‘ExternalContactInfoId’, ‘Name’,
‘EmailAddress’, ‘RealName’,
‘WorkPhone’, ‘Address2’]);
Set($LdapEmailAttrMatchList, [‘mail’, ‘mailRoutingAddress’,
‘mailAlternateAddress’]);
Set($LdapEmailAttrMatchPrefix, [’’, ‘smtp’, ‘SMTP:’]);
Set($LdapServer, ‘clehbdc01.broadvox.local’);
Set($LdapBase, ‘OU=USA,DC=broadvox,DC=local’);
Set($LdapFilter, ‘(objectClass=*)’);
1;

APACHE ERROR_LOG:

[Tue May 19 12:54:25 2009] [error] Can’t load Perl file: /opt/rt3/bin/webmux.pl for server clehbrtsrv01.broadvox.local:0, exiting…
[Tue May 19 12:55:17 2009] [error] Can’t locate RT/Authen/ExternalAuth.pm in @INC (@INC contains: /opt/rt3/bin/…/local/lib /opt/rt3/bin/…/lib /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 . /etc/httpd) at /opt/rt3/bin/…/lib/RT.pm line 625.\nCompilation failed in require at (eval 2) line 1.\n
[Tue May 19 12:55:17 2009] [error] Can’t load Perl file: /opt/rt3/bin/webmux.pl for server clehbrtsrv01.broadvox.local:0, exiting…

Eric Chatham
MIS Department
Phone: (216) 373-4683
Fax: (216) 373-4669
echatham@broadvox.net
[cid:image001.gif@01C9D8A9.37AF5580]

CONFIDENTIAL. This e-mail and any attached files are confidential and should be destroyed and/or returned if you are not the intended and proper recipient.

CONFIDENTIAL. This e-mail and any attached files are confidential and should be destroyed and/or returned if you are not the intended and proper recipient.

Hello Eric:

I’ve got the same problem. After compiling and installing
RT::Authen::ExternalAuth I was able to authenticate using my OpenLDAP but
any other user that is missing from LDAP will not work.

Even new users that send an email in order to request a ticket isn’t
working.

I am using rt3-3.6.5-3.el5.rpm on a CentOS Machine and
RT-Authen-ExternalAuth-0.05.

The logs are:

[Thu May 7 21:32:44 2009] [error]: RT could not load a valid user, and RT’s
configuration does not allow
[Thu May 7 21:32:44 2009] [error]: RT could not load a valid user, and RT’s
configuration does not allow
[Thu May 7 21:32:44 2009] [error]: Could not record email: Could not load a
valid user (/usr/share/rt3/html/REST/1.0/NoAuth/mail-gateway:75)

And my configuration is:

Set ldap settings

Set( @Plugins, qw(RT::Authen::ExternalAuth) );

The order in which the services defined in ExternalSettings

should be used to authenticate users. User is authenticated

if successfully confirmed by any service - no more services

are checked.

Set($ExternalAuthPriority, [ ‘My_LDAP’ ]);

The order in which the services defined in ExternalSettings

should be used to get information about users. This includes

RealName, Tel numbers etc, but also whether or not the user

should be considered disabled.

Once user info is found, no more services are checked.

Set($ExternalInfoPriority, [‘My_LDAP’ ]);

If this is set to true, then the relevant packages will

be loaded to use SSL/TLS connections. At the moment,

this just means “use Net::SSLeay;”

Set($ExternalServiceUsesSSLorTLS, 0);

If this is set to 1, then users should be autocreated by RT

as internal users if they fail to authenticate from an

external service.

Set($AutoCreateNonExternalUsers, 1);

These are the full settings for each external service as a HashOfHashes

Note that you may have as many external services as you wish. They will

be checked in the order specified in the Priority directives above.

e.g.

Set(ExternalAuthPriority,[‘My_LDAP’,‘My_MySQL’,‘My_Oracle’,‘SecondaryLDAP’,‘Other-DB’]);
Set($ExternalSettings, {
# AN EXAMPLE LDAP SERVICE
’My_LDAP’ => { ## GENERIC SECTION
# The type of
service (db/ldap/cookie)

‘type’ => ‘ldap’,
# Should the service
be used for authentication?

‘auth’ => 1,
# Should the service
be used for information?

‘info’ => 1,
# The server hosting
the service

‘server’ => ‘neptuno.ufcspa.edu.br’,

                                                    ## SERVICE-SPECIFIC

SECTION
# If you can bind to
your LDAP server anonymously you should
# remove the user
and pass config lines, otherwise specify them here:
# The username RT
should use to connect to the LDAP server

‘user’ => ‘cn=admin,dc=ufcspa,dc=edu,dc=br’,
# The password RT
should use to connect to the LDAP server

‘pass’ => ‘xxxx’,
# The LDAP search
base

‘base’ => ‘ou=Users,dc=ufcspa,dc=edu,dc=br’,
# The filter to use
to match RT-Users

‘filter’ => ‘(objectClass=posixAccount)’,
# The filter that
will only match disabled users

‘d_filter’ => ‘(accountStatus=disabled)’,
# Should we try to
use TLS to encrypt connections?

‘tls’ => 0,
# What other args
should I pass to Net::LDAP->new($host,@args)?

‘net_ldap_args’ => [ version => 3 ],
## RT ATTRIBUTE
MATCHING SECTION
# The list of RT
attributes that uniquely identify a user

‘attr_match_list’ => [ ‘Name’,

‘EmailAddress’,

‘RealName’

],
# The mapping of RT
attributes on to LDAP attributes

‘attr_map’ => { ‘Name’ => ‘uid’,

‘EmailAddress’ => ‘mail’,

‘RealName’ => ‘displayName’

}
}
}
);

Klaus Engelmann
CCNA CCDA - CSCO10971632

It appears that after I got Apache/MySql working previously, I am unable to login with the default username/password (root/password) to the web > interface. I started a new topic for this. I also tried adding settings in for ExternalAuth to the RT_SiteConfig.pm. I am getting an @INC
error in Apache when I try restarting the service. Even before I added the “External Authentication” variables, “LDAP” variables and the
"ExternalAuth" Plugin setting, I still could not login using root and password.

/opt/rt3/etc/RT_SiteConfig.pm settings:

I fixed some of my problems. I did two things to fix them, but I’m still stuck.

  1. I copied my RT_SiteConfig.pm and Apache Config and re-ran the installation (./configure -> make testdeps -> make install). I copied my saved RT_SiteConfig.pm and Apache config back to their original location. I ran “make dropdb” to redo the database installation. There wasn’t anything in there before so I was aware of the warning of all data being lost.

This fixed the problem I was having trying to log onto the web interface with the defaults (root and password). I would like to change this password, can anyone tell me how this is changed? The README file didn’t say how or where.

APACHE ERROR_LOG:

[Tue May 19 12:54:25 2009] [error] Can’t load Perl file: /opt/rt3/bin/webmux.pl for server clehbrtsrv01.broadvox.local:0, exiting…
[Tue May 19 12:55:17 2009] [error] Can’t locate RT/Authen/ExternalAuth.pm in @INC (@INC contains: /opt/rt3/bin/…/local/lib /opt/rt3/bin/…/lib > /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8
/usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 . /etc/httpd) at /opt/rt3/bin/…/lib/RT.pm line
625.\nCompilation failed in require at (eval 2) line 1.\n
[Tue May 19 12:55:17 2009] [error] Can’t load Perl file: /opt/rt3/bin/webmux.pl for server clehbrtsrv01.broadvox.local:0, exiting…

  1. I partly fixed the problem I was having with LDAP. First, I looked for the ./RT/Authen/ directory and copied it recursively over to /opt/rt3/bin. This fixed the problem as far as the Module being included, but it did not fix the problem I’m having trying to use LDAP.

So, here are examples of my problems after the fixings. Could someone double check them for me? Thank you once again for your assistance.

RT_SiteConfig.pm settings:

Set( $rtname, ‘example.com’);

Set(@Plugins,(qw(Extension::QuickDelete)));

Set($WebPath, “/rt3”);

Set($rtname, “broadvox.local”);
Set($Orginization, ‘broadvox.local’);
Set($CorrespondAddress, ‘echatham@broadvox.net’);
Set($CommentAddress, ‘echatham@infotelecom.us’);
Set($Timezone, ‘US/Eastern’);

Set($WebBaseURL, ‘http://rt.broadvox.local/’);

Set(@Plugins, qw(RT::Authen::ExternalAuth));

Database

Set($DatabaseType, ‘mysql’);

Set($DatabaseUser, ‘rt_user’);

Set($DatabasePassword, ‘rt_pass’);

Set($DatabaseRTHost, ‘localhost’);

External Authentication

Set($ExternalAuthPriority, [‘My_LDAP’]);
Set($ExternalInfoPriority, [‘My_LDAP’]);
Set($AutoCreateNonExternalUsers, 1);
Set($ExternalAuthPriority, [‘My_LDAP’, ‘My_MySQL’, ‘My_Oracle’, ‘SecondaryLDAP’, ‘Other-DB’]);

LDAP

Set($AuthMethods, [‘My_LDAP’, ‘Internal’]);
Set($LdapExternalAuth, 0);
Set($LdapExternalInfo, 0);
Set($LdapAutoCreateNonLdapUsers, 1);
Set($LdapAttrMap, {‘Name’ => ‘sAMAccountName’,
‘EmailAddress’ => ‘mail’,
‘Orginization’ => ‘o’,
‘RealName’ => ‘cn’,
‘ExternalContactInfoId’ => ‘dn’,
‘ExternalAuthId’ => ‘sAMAccountName’,
‘Gecos’, => ‘sAMAccountName’,
‘WorkPhone’, => ‘telephoneNumber’,
‘Address1’ => ‘streetAddress’,
‘City’ => ‘l’,
‘State’ => ‘st’,
‘Zip’ => ‘postalCode’,
‘Country’ => ‘co’});
Set($LdapRTAttrMatchList, [‘ExternalContactInfoId’, ‘Name’,
‘EmailAddress’, ‘RealName’,
‘WorkPhone’, ‘Address2’]);
Set($LdapEmailAttrMatchList, [‘mail’, ‘mailRoutingAddress’,
‘mailAlternateAddress’]);
Set($LdapEmailAttrMatchPrefix, [’’, ‘smtp’, ‘SMTP:’]);
Set($LdapServer, ‘clehbdc01.broadvox.local’);
Set($LdapBase, ‘OU=USA,DC=broadvox,DC=local’);
Set($LdapFilter, ‘(objectClass=*)’);
1;

Here are my APACHE ERROR_LOG listings:

[Wed May 20 14:07:07 2009] [notice] Apache/2.2.3 (CentOS) configured – resuming normal operations
[Wed May 20 18:08:04 2009] [error]: FAILED LOGIN for echatham from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Wed May 20 18:08:09 2009] [error]: FAILED LOGIN for echatham from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Wed May 20 18:08:13 2009] [error]: FAILED LOGIN for echathamAuxal9op from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Wed May 20 18:08:19 2009] [error]: FAILED LOGIN for echatham from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Wed May 20 18:08:28 2009] [info]: Successful login for root from 172.16.3.38 (/opt/rt3/share/html/autohandler:276)
[Wed May 20 18:08:43 2009] [error]: FAILED LOGIN for echatham@broadvox.local from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Wed May 20 18:08:55 2009] [error]: FAILED LOGIN for echatham@broadvox.local from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Wed May 20 18:09:21 2009] [info]: Successful login for root from 172.16.3.38 (/opt/rt3/share/html/autohandler:276)
[Wed May 20 18:11:05 2009] [error]: FAILED LOGIN for echatham from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)
[Wed May 20 18:11:12 2009] [error]: FAILED LOGIN for echatham from 172.16.3.38 (/opt/rt3/share/html/autohandler:268)

Eric Chatham

CONFIDENTIAL. This e-mail and any attached files are confidential and should be destroyed and/or returned if you are not the intended and proper recipient.