Recommendation on RT 3.4.1 Installation Packages?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I’m finally getting ready to do a fresh install of RT 3.4.1. Reading the
various sources of documentation about which ‘required packages’ to use
has me a bit confused. So, here are my questions:

o Is it true that I can go with Apache and FastCGI as an alternative to
using mod_perl at all?

o If so, which versions of Apache and FastCGI should I use? At the fastcgi
download site, there is a mod_fastcgi-2.4.2 source distribution; would
this be OK?

o I’d like to use the most current version of Apache that is feasible, on
the assumption that is more likely to have recent security patches
incorporated. But I also want a combination of Apache and FastCGI that
will work with RT 3.4.1.

o Is it true that I don’t need mod_perl at all, especially if I go with
Apache 2.x and FastCGI? A confusing statement in the docs is this:

mod_perl 2.0 isn’t quite ready for prime time just yet;
Best Practical Solutions strongly recommends that sites
use Apache 1.3 or FastCGI.

Does this mean I could use Apache 2.x + FastCGI and forget mod_perl? Or
must I use Apache 1.3 anyway in order to avoid mod_perl 2.0?

Could someone please clarify? I’ve not got much experience installing or
supporting web servers, so I’m not very familiar with the relationship
among the various associated components.

For what it’s worth, my initial environment will be FreeBSD 5.3-RELEASE
and a current version of Postgres for the RT db. Later, though, we may be
moving to a Linux platform.

Thanks for any help on this.

BTW, is there an archive for this list?

Mike

Mike Friedman System and Network Security
mikef@ack.Berkeley.EDU 2484 Shattuck Avenue
1-510-642-1410 University of California at Berkeley
http://ack.Berkeley.EDU/~mikef http://security.berkeley.edu

-----BEGIN PGP SIGNATURE-----
Version: PGP 6.5.8

iQA/AwUBQkIIgK0bf1iNr4mCEQLxCgCfYG92+btW4EKwo/S/k56chuDkhbIAoIE8
/lWmT2u2x/uh60wPAkewKTkx
=JyXM
-----END PGP SIGNATURE-----

Hi Mike,

Mike Friedman wrote:

o Is it true that I can go with Apache and FastCGI as an alternative to
using mod_perl at all?

Yes.

o If so, which versions of Apache and FastCGI should I use? At the fastcgi
download site, there is a mod_fastcgi-2.4.2 source distribution; would
this be OK?

Yes this works fine and is what I use on my test system, but I would use
the FreeBSD ports for Apache and Mod_Perl rather than using the raw source.

o Is it true that I don’t need mod_perl at all, especially if I go with
Apache 2.x and FastCGI? A confusing statement in the docs is this:

mod_perl 2.0 isn’t quite ready for prime time just yet;
Best Practical Solutions strongly recommends that sites
use Apache 1.3 or FastCGI.

I’m actually using Apache 2.0.50 and Mod_Perl 1.99r14 under FreeBSD
4.10-STABLE on a dual CPU Dell box as our production system and it is
working very well.

For what it’s worth, my initial environment will be FreeBSD 5.3-RELEASE
and a current version of Postgres for the RT db. Later, though, we may be
moving to a Linux platform.

I would recommend moving to a reasonably recent 5.3-STABLE or
5.4-RELEASE when it comes out as it has a number of worthwhile improvements.

I’d also recommend satisfying as many of the perl dependancies via
FreeBSD ports as you can rather than using the fixdeps makefile target
as it makes upgrades (especially of perl) much easier later.

Carl.

o Is it true that I can go with Apache and FastCGI as an alternative to
using mod_perl at all?

You need to use either fastcgi or modperl. A single rt instance uses
one, and only one of them.

o If so, which versions of Apache and FastCGI should I use? At the fastcgi
download site, there is a mod_fastcgi-2.4.2 source distribution; would
this be OK?

I run the current apache2 and current fastcgi at several sites. It
works fine.

mod_perl 2.0 isn’t quite ready for prime time just yet;
Best Practical Solutions strongly recommends that sites
use Apache 1.3 or FastCGI.

Does this mean I could use Apache 2.x + FastCGI and forget mod_perl? Or
must I use Apache 1.3 anyway in order to avoid mod_perl 2.0?

This says “modperl2 isn’t ready for prime time. If you want modperl,
use apache1.” apache2 and fastcgi is fine.

BTW, is there an archive for this list?

yes, several. I expect them to be linked off the wiki, I usually just
use google.

seph

seph said:

BTW, is there an archive for this list?

yes, several. I expect them to be linked off the wiki, I usually just
use google.

Here you go:
http://wiki.bestpractical.com/index.cgi?MailingListArchives

I like this one: http://gossamer-threads.com/lists/rt/

Sam

o Is it true that I don’t need mod_perl at all, especially if I go with
Apache 2.x and FastCGI? A confusing statement in the docs is this:

mod_perl 2.0 isn’t quite ready for prime time just yet;
Best Practical Solutions strongly recommends that sites
use Apache 1.3 or FastCGI.

Does this mean I could use Apache 2.x + FastCGI and forget mod_perl? Or
must I use Apache 1.3 anyway in order to avoid mod_perl 2.0?

I believe I’m responsible for that specific language; I was expanding
what I found there when I showed up on the wiki. Since then, as I’ve
also noted, the situation has changes; the other gent is running ok,
and I too am installed using 2.0.50 and MP2.0.0-rc4. I wouldn’t say my
installation is running perfectly; my page return time seems 4 or 5
seconds longer than the response times I see on the footers, so I might
have a config problem, and it might be MP2, but I can’t testify to it.

Cheers,
– jra
Jay R. Ashworth jra@baylink.com
Designer Baylink RFC 2100
Ashworth & Associates The Things I Think '87 e24
St Petersburg FL USA http://baylink.pitas.com +1 727 647 1274

  If you can read this... thank a system adminstrator.  Or two.  --me

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1On Thu, 24 Mar 2005 at 00:05 (-0500), seph wrote:

o If so, which versions of Apache and FastCGI should I use? At the
fastcgi download site, there is a mod_fastcgi-2.4.2 source
distribution; would this be OK?

I run the current apache2 and current fastcgi at several sites. It works
fine.

seph,

Thanks. That’s what I wanted to know.

Mike

Mike Friedman System and Network Security
mikef@ack.Berkeley.EDU 2484 Shattuck Avenue
1-510-642-1410 University of California at Berkeley
http://ack.Berkeley.EDU/~mikef http://security.berkeley.edu

-----BEGIN PGP SIGNATURE-----
Version: PGP 6.5.8

iQA/AwUBQkhBdK0bf1iNr4mCEQJV/QCeMLKpbs+wcSfPi9NVfNPD7/+CVLAAnRab
FLLf7h8y+m5DQHXN3ue+Dlm7
=E0r4
-----END PGP SIGNATURE-----