Question about Encode::Compat

Hi,

I have a question regarding Encode::Compat. I am running the following:

RedHat-7.3
Apache 1.3.27 from RedHat
mod_perl 1.26 from RedHat
RT 3.0.8
perl 5.6.1 from RedHat
mysql 3.23.56 from RedHat
Encode::Compat 0.05

I have all of the necessary modules loaded and everything has been
working wonderfully for some time. During this month of February,
which is during a leap year, I get following error every know and again
when I load a page in RT:

error: Unsupported conversion: Invalid argument at
/usr/lib/perl5/site_perl/5.6.1/Encode/compat/common.pm line 115.

From everything I’ve read up to now I know I should be running perl
5.8, but I was wondering if the Encode error is due to this being a
leap year month? Does anyone think the problem will go away on March
1, 2004?

According to http://rt.cpan.org/NoAuth/Bug.html?id=3657 this is a known
problem.

I would like to avoid upgrading perl for a little while, since this
system is in production; I know I will have to upgrade soon. I was
wondering if this is something that I should expect will be broken from
here on out with my configuration.

Thanks!

–Randy

Encode::Compat 0.05

0.06 is now on PAUSE and available from
http://aut.dyndns.org/dist/Encode-compat-0.06.tar.gz

I think it addresses the problem reported, but testing is appreciated.
It’s my bedtime now, so I won’t be able to process feedback until 11
hours later. :slight_smile:

Thanks,
/Autrijus/

Thank you so much! I installed the new module and reloading selected
RT pages 50 times has failed to produce the UTF error. I think we’re
good!

–RandyOn Feb 13, 2004, at 4:48 PM, Autrijus Tang wrote:

On Fri, Feb 13, 2004 at 04:13:41PM -0500, Randy Franklin wrote:

Encode::Compat 0.05

0.06 is now on PAUSE and available from
http://aut.dyndns.org/dist/Encode-compat-0.06.tar.gz

I think it addresses the problem reported, but testing is
appreciated.
It’s my bedtime now, so I won’t be able to process feedback until 11
hours later. :slight_smile:

Thanks,
/Autrijus/