Question about changing the look and feel of RT

RT 3.8.5 on FreeBSD-6.2 using Apache 2.2.6 using mason_handler.fcgi

I can not figure out how to change the color scheme of RT to be red
instead of blue.

I’ve Googled the hell out of the issue and have yet to come to a solution.

I’ve found and replaced:
/opt/rt3/share/html/NoAuth/css/web2/images/source/background-gradient.png

…with my own, which results in the top menu bar “RT at a glance” + “New
ticket in” toolbar is now red.

The rest of the page remains blue.

I’ve tried changing multiple color entries in multiple .css files, but
have yet to find the one that works.

My HTML source refers to:

…but I have no main-squished.css anywhere. I’ve tried changing settings
in /opt/rt3/share/html/NoAuth/css/web2/main.css, but have yet to find the
right one.

The worst part about this is that I know I’ve found the answer to this
years ago in what was probably RT 3.0.x ro 3.1.x…and I know the answer
must be out there somewhere, but just can’t find it…

If anyone can provide me guidance here, I would greatly appreciate it.

-Jake

elsif wrote:

RT 3.8.5 on FreeBSD-6.2 using Apache 2.2.6 using mason_handler.fcgi

I can not figure out how to change the color scheme of RT to be red
instead of blue.

I’ve Googled the hell out of the issue and have yet to come to a solution.

I’ve found and replaced:
/opt/rt3/share/html/NoAuth/css/web2/images/source/background-gradient.png

Not using the FreeBSD ports then…

…with my own, which results in the top menu bar “RT at a glance” + “New
ticket in” toolbar is now red.

The rest of the page remains blue.

I’ve tried changing multiple color entries in multiple .css files, but
have yet to find the one that works.

My HTML source refers to:

…but I have no main-squished.css anywhere. I’ve tried changing settings
in /opt/rt3/share/html/NoAuth/css/web2/main.css, but have yet to find the
right one.

The worst part about this is that I know I’ve found the answer to this
years ago in what was probably RT 3.0.x ro 3.1.x…and I know the answer
must be out there somewhere, but just can’t find it…

If anyone can provide me guidance here, I would greatly appreciate it.

You should follow the ‘cleanly customize’ concepts, which means creating
a parallel directory tree under /opt/rt3/local/html (I think. It might be just /opt/rt3/local) [It’s /usr/local/www/rt38 if you use the ports layout.]

Under there create a directory tree like so:

mkdir -p NoAuth/css/web2/images/source

Your replacement background gradient (an 800x2 pixel PNG image) goes into:

NoAuth/css/web2/images/source/background-gradient.png

Then you need to copy the original layout.css from /opt/rt3/html/NoAuth/css/web2
into your new locally modified tree:

NoAuth/css/web2/layout.css

Edit this file to change the background colour to match the bottom end of your
gradient file – look for this section close to the top of the file and change as
indicated:

body {

padding:0;
margin:0;

background: #a2a2a2 url(<%RT->Config->Get('WebPath')%>/NoAuth/css/web2/images/background-gradient.png) top left repeat-x ;
            ^^^^^^^^
font-family: arial, helvetica, sans-serif;

}

Here I’ve changed the original blue colour (#547CCC) to a fairly light grey (#a2a2a2)

Finally you need to copy …/NoAuth/css/web2/images/dhandler unchanged into the
equivalent position in your new local tree. Clear the mason cache and restart apache. You should now have a customized background gradient.

Cheers,

Matthew

Dr Matthew Seaman The Bunker, Ash Radar Station
PGP: 0x60AE908C on servers Marshborough Rd
Tel: +44 1304 814890 Sandwich
Fax: +44 1304 814899 Kent, CT13 0PL, UK

signature.asc (259 Bytes)

I’ve found web2/layout.css…

 background: #547CCC 

url(<%RT->Config->Get(‘WebPath’)%>/NoAuth/css/web2/images/background-gradient.png)
top left repeat-x ;

…that line should be what’s making the background blue.

Changing it to #FFFFFF doesn’t change anything.

Commenting out the line doesn’t change anything.

What am I missing here?On Mon, 16 Nov 2009, elsif wrote:

RT 3.8.5 on FreeBSD-6.2 using Apache 2.2.6 using mason_handler.fcgi

I can not figure out how to change the color scheme of RT to be red
instead of blue.

I’ve Googled the hell out of the issue and have yet to come to a solution.

I’ve found and replaced:
/opt/rt3/share/html/NoAuth/css/web2/images/source/background-gradient.png

…with my own, which results in the top menu bar “RT at a glance” + “New
ticket in” toolbar is now red.

The rest of the page remains blue.

I’ve tried changing multiple color entries in multiple .css files, but
have yet to find the one that works.

My HTML source refers to:

…but I have no main-squished.css anywhere. I’ve tried changing settings
in /opt/rt3/share/html/NoAuth/css/web2/main.css, but have yet to find the
right one.

The worst part about this is that I know I’ve found the answer to this
years ago in what was probably RT 3.0.x ro 3.1.x…and I know the answer
must be out there somewhere, but just can’t find it…

If anyone can provide me guidance here, I would greatly appreciate it.

-Jake


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

This works perfectly.

You da man.

Funny, I would’ve assumed the cache info was removed upon Apache
restart…

Thanks,
-jakeOn Mon, 16 Nov 2009, Matthew Seaman wrote:

elsif wrote:

RT 3.8.5 on FreeBSD-6.2 using Apache 2.2.6 using mason_handler.fcgi

I can not figure out how to change the color scheme of RT to be red instead
of blue.

I’ve Googled the hell out of the issue and have yet to come to a solution.

I’ve found and replaced:
/opt/rt3/share/html/NoAuth/css/web2/images/source/background-gradient.png

Not using the FreeBSD ports then…

…with my own, which results in the top menu bar “RT at a glance” + “New
ticket in” toolbar is now red.

The rest of the page remains blue.

I’ve tried changing multiple color entries in multiple .css files, but have
yet to find the one that works.

My HTML source refers to:

…but I have no main-squished.css anywhere. I’ve tried changing settings
in /opt/rt3/share/html/NoAuth/css/web2/main.css, but have yet to find the
right one.

The worst part about this is that I know I’ve found the answer to this
years ago in what was probably RT 3.0.x ro 3.1.x…and I know the answer
must be out there somewhere, but just can’t find it…

If anyone can provide me guidance here, I would greatly appreciate it.

You should follow the ‘cleanly customize’ concepts, which means creating
a parallel directory tree under /opt/rt3/local/html (I think. It might be
just /opt/rt3/local) [It’s /usr/local/www/rt38 if you use the ports layout.]

Under there create a directory tree like so:

mkdir -p NoAuth/css/web2/images/source

Your replacement background gradient (an 800x2 pixel PNG image) goes into:

NoAuth/css/web2/images/source/background-gradient.png

Then you need to copy the original layout.css from
/opt/rt3/html/NoAuth/css/web2
into your new locally modified tree:

NoAuth/css/web2/layout.css

Edit this file to change the background colour to match the bottom end of
your
gradient file – look for this section close to the top of the file and
change as
indicated:

body {

padding:0;
margin:0;

background: #a2a2a2
url(<%RT->Config->Get(‘WebPath’)%>/NoAuth/css/web2/images/background-gradient.png)
top left repeat-x ;
^^^^^^^^
font-family: arial, helvetica, sans-serif;

}

Here I’ve changed the original blue colour (#547CCC) to a fairly light grey
(#a2a2a2)

Finally you need to copy …/NoAuth/css/web2/images/dhandler unchanged into
the
equivalent position in your new local tree. Clear the mason cache and
restart apache. You should now have a customized background gradient.

Cheers,

Matthew


Dr Matthew Seaman The Bunker, Ash Radar Station
PGP: 0x60AE908C on servers Marshborough Rd
Tel: +44 1304 814890 Sandwich
Fax: +44 1304 814899 Kent, CT13 0PL, UK

Jake,

Here’s how I’ve changed the background:

I copied /usr/local/rt3/share/html/NoAuth/css/web2/layout.css to
/usr/local/rt3/local/html/NoAuth/css/web2/layout.css, commented out
"background:" under “body” and created a new background entry:
“background: #8B0000;”

Chris

elsif jake@elsif.net
Sent by: rt-users-bounces@lists.bestpractical.com
11/16/2009 10:59 AM

To
rt-users@lists.bestpractical.com
cc

Subject
[rt-users] Question about changing the look and feel of RT

RT 3.8.5 on FreeBSD-6.2 using Apache 2.2.6 using mason_handler.fcgi

I can not figure out how to change the color scheme of RT to be red
instead of blue.

I’ve Googled the hell out of the issue and have yet to come to a solution.

I’ve found and replaced:
/opt/rt3/share/html/NoAuth/css/web2/images/source/background-gradient.png

…with my own, which results in the top menu bar “RT at a glance” + “New
ticket in” toolbar is now red.

The rest of the page remains blue.

I’ve tried changing multiple color entries in multiple .css files, but
have yet to find the one that works.

My HTML source refers to:

…but I have no main-squished.css anywhere. I’ve tried changing settings

in /opt/rt3/share/html/NoAuth/css/web2/main.css, but have yet to find the
right one.

The worst part about this is that I know I’ve found the answer to this
years ago in what was probably RT 3.0.x ro 3.1.x…and I know the answer
must be out there somewhere, but just can’t find it…

If anyone can provide me guidance here, I would greatly appreciate it.

-Jake
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com