Problems with Fetchmail/RT Mailgate

I add an account on our 2007 Exchange server to receive e-mails for RT. I
configured fetchmail for the exchange pop account but it fails to
authenticate. I’ve tested the credentials and connection settings by setting
up the pop account in Outlook. It works without fail. The exchange server
does require a secure login method. If I wanted to have the e-mails
delivered directly to the RT server can I create the accounts in Postfix on
the RT server so that I can use to get tickets via email into the queue’s?
Can someone show me what the fetchmail config should look like in that
scenario?

fetchmail: Query status=3 (AUTHFAIL)
The logs are also telling me that there was an error exchanging credentials.
View this message in context: http://old.nabble.com/Problems-with-Fetchmail-RT-Mailgate-tp32503857p32503857.html

I add an account on our 2007 Exchange server to receive e-mails for RT. I
configured fetchmail for the exchange pop account but it fails to
authenticate. I’ve tested the credentials and connection settings by setting
up the pop account in Outlook. It works without fail. The exchange server
does require a secure login method. If I wanted to have the e-mails
delivered directly to the RT server can I create the accounts in Postfix on
the RT server so that I can use to get tickets via email into the queue’s?
Can someone show me what the fetchmail config should look like in that
scenario?

fetchmail: Query status=3 (AUTHFAIL)
The logs are also telling me that there was an error exchanging credentials.
|poll
proto pop3
user “user” pass "password"
to localuser here
ssl

The jist of how mine is set.

-Matt
|

Am Fri, 23 Sep 2011 00:32:52 -0700 (PDT)
schrieb “josh.cole” josh.cole@fresno.edu:

I add an account on our 2007 Exchange server to receive e-mails for
RT. I configured fetchmail for the exchange pop account but it fails
to authenticate. I’ve tested the credentials and connection settings
by setting up the pop account in Outlook. It works without fail. The
exchange server does require a secure login method. If I wanted to
have the e-mails delivered directly to the RT server can I create the
accounts in Postfix on the RT server so that I can use to get tickets
via email into the queue’s? Can someone show me what the fetchmail
config should look like in that scenario?

fetchmail: Query status=3 (AUTHFAIL)
The logs are also telling me that there was an error exchanging
credentials.

Try verbose mode.
IIRC, fetchmail is picky about the certificate.

To simplify, I enabled pop on another one of our exchange servers. I changed
the login method on it so that it is not secure. I configured the pop
account on my machine and was able to authenticate from my email client. I
am receiving the same error with fetchmail which is really frustrating.

New fetchmail config:

set daemon 60
set invisible
set no bouncemail
set no syslog
set logfile /var/log/fetchmail.log
poll exchange3 protocol pop3 username “user” password “password” mda
“/usr/bin/rt-mailgate --queue general --action correspond --url
http://localhost/rt/” no keep

Rainer Duffner wrote:

Am Fri, 23 Sep 2011 00:32:52 -0700 (PDT)
schrieb “josh.cole” josh.cole@fresno.edu:

I add an account on our 2007 Exchange server to receive e-mails for
RT. I configured fetchmail for the exchange pop account but it fails
to authenticate. I’ve tested the credentials and connection settings
by setting up the pop account in Outlook. It works without fail. The
exchange server does require a secure login method. If I wanted to
have the e-mails delivered directly to the RT server can I create the
accounts in Postfix on the RT server so that I can use to get tickets
via email into the queue’s? Can someone show me what the fetchmail
config should look like in that scenario?

fetchmail: Query status=3 (AUTHFAIL)
The logs are also telling me that there was an error exchanging
credentials.

Try verbose mode.
IIRC, fetchmail is picky about the certificate.


RT Training Sessions (http://bestpractical.com/services/training.html)

  • Chicago, IL, USA September 26 & 27, 2011
  • San Francisco, CA, USA October 18 & 19, 2011
  • Washington DC, USA October 31 & November 1, 2011
  • Melbourne VIC, Australia November 28 & 29, 2011
  • Barcelona, Spain November 28 & 29, 2011

View this message in context: http://old.nabble.com/Problems-with-Fetchmail-RT-Mailgate-tp32503857p32544661.html

I tried adding auth ntlm to the config as well. It doesn’t seem to have
helped me much.

josh.cole wrote:

To simplify, I enabled pop on another one of our exchange servers. I
changed the login method on it so that it is not secure. I configured the
pop account on my machine and was able to authenticate from my email
client. I am receiving the same error with fetchmail which is really
frustrating.

New fetchmail config:

set daemon 60
set invisible
set no bouncemail
set no syslog
set logfile /var/log/fetchmail.log
poll exchange3 protocol pop3 username “user” password “password” mda
“/usr/bin/rt-mailgate --queue general --action correspond --url
http://localhost/rt/” no keep

Error:
etchmail: Error exchanging credentials
fetchmail: Authorization failure on user@exchange3.mydomain.local
fetchmail: Query status=3 (AUTHFAIL)
fetchmail: sleeping at Tue 27 Sep 2011 02:47:23 PM PDT for 60 seconds

Rainer Duffner wrote:

Am Fri, 23 Sep 2011 00:32:52 -0700 (PDT)
schrieb “josh.cole” josh.cole@fresno.edu:

I add an account on our 2007 Exchange server to receive e-mails for
RT. I configured fetchmail for the exchange pop account but it fails
to authenticate. I’ve tested the credentials and connection settings
by setting up the pop account in Outlook. It works without fail. The
exchange server does require a secure login method. If I wanted to
have the e-mails delivered directly to the RT server can I create the
accounts in Postfix on the RT server so that I can use to get tickets
via email into the queue’s? Can someone show me what the fetchmail
config should look like in that scenario?

fetchmail: Query status=3 (AUTHFAIL)
The logs are also telling me that there was an error exchanging
credentials.

Try verbose mode.
IIRC, fetchmail is picky about the certificate.


RT Training Sessions (http://bestpractical.com/services/training.html)

  • Chicago, IL, USA September 26 & 27, 2011
  • San Francisco, CA, USA October 18 & 19, 2011
  • Washington DC, USA October 31 & November 1, 2011
  • Melbourne VIC, Australia November 28 & 29, 2011
  • Barcelona, Spain November 28 & 29, 2011

View this message in context: http://old.nabble.com/Problems-with-Fetchmail-RT-Mailgate-tp32503857p32549908.html

I tried adding auth ntlm to the config as well. It doesn’t seem to have
helped me much.

Can you provide the output of the following commands (as covered in
Fetchmail’s FAQ - Fetchmail - Kostenloser Open Source Mail Daemon):

env LC_ALL=C fetchmail -V
env LC_ALL=C fetchmail --nodetach -vvv --nosyslog

Note that is 3 ‘v’ characters, there are no ‘w’ characters there.

             Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche

I actually did get it working last night after reinstalling postfix and
fetchmail!

Rob MacGregor wrote:

I tried adding auth ntlm to the config as well. It doesn’t seem to have
helped me much.

Can you provide the output of the following commands (as covered in
Fetchmail’s FAQ - Fetchmail - Kostenloser Open Source Mail Daemon):

env LC_ALL=C fetchmail -V
env LC_ALL=C fetchmail --nodetach -vvv --nosyslog

Note that is 3 ‘v’ characters, there are no ‘w’ characters there.


Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche

RT Training Sessions (http://bestpractical.com/services/training.html)

  • Chicago, IL, USA September 26 & 27, 2011
  • San Francisco, CA, USA October 18 & 19, 2011
  • Washington DC, USA October 31 & November 1, 2011
  • Melbourne VIC, Australia November 28 & 29, 2011
  • Barcelona, Spain November 28 & 29, 2011

View this message in context: http://old.nabble.com/Re%3A-Problems-with-Fetchmail-RT-Mailgate-tp32557593p32569792.html

Is there a command that can be entered into the fetchmail config that can
assign an owner when placing ticket’s into specific queue’s?

josh.cole wrote:

I actually did get it working last night after reinstalling postfix and
fetchmail!

Rob MacGregor wrote:

I tried adding auth ntlm to the config as well. It doesn’t seem to have
helped me much.

Can you provide the output of the following commands (as covered in
Fetchmail’s FAQ - Fetchmail - Kostenloser Open Source Mail Daemon):

env LC_ALL=C fetchmail -V
env LC_ALL=C fetchmail --nodetach -vvv --nosyslog

Note that is 3 ‘v’ characters, there are no ‘w’ characters there.


Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche

RT Training Sessions (http://bestpractical.com/services/training.html)

  • Chicago, IL, USA September 26 & 27, 2011
  • San Francisco, CA, USA October 18 & 19, 2011
  • Washington DC, USA October 31 & November 1, 2011
  • Melbourne VIC, Australia November 28 & 29, 2011
  • Barcelona, Spain November 28 & 29, 2011

View this message in context: http://old.nabble.com/Re%3A-Problems-with-Fetchmail-RT-Mailgate-tp32557593p32570133.html

Is there a command that can be entered into the fetchmail config that can
assign an owner when placing ticket’s into specific queue’s?

josh.cole wrote:

I actually did get it working last night after reinstalling postfix and
fetchmail!

Rob MacGregor wrote:

I tried adding auth ntlm to the config as well. It doesn’t seem to have
helped me much.
Can you provide the output of the following commands (as covered in
Fetchmail’s FAQ - Fetchmail - Kostenloser Open Source Mail Daemon):

env LC_ALL=C fetchmail -V
env LC_ALL=C fetchmail --nodetach -vvv --nosyslog

Note that is 3 ‘v’ characters, there are no ‘w’ characters there.


Please keep list traffic on the list.

Rob MacGregor
Whoever fights monsters should see to it that in the process he
doesn’t become a monster. Friedrich Nietzsche

RT Training Sessions (http://bestpractical.com/services/training.html)

  • Chicago, IL, USA September 26& 27, 2011
  • San Francisco, CA, USA October 18& 19, 2011
  • Washington DC, USA October 31& November 1, 2011
  • Melbourne VIC, Australia November 28& 29, 2011
  • Barcelona, Spain November 28& 29, 2011

Not as far as I know. You might look into the CommandByMail extension
for something like that.