Problems installing rt

Hi,

I’ve followed the installation guide but cannot seem to overcome the
following problem:

"You haven’t yet configured your webserver to configure to run RT…"
Somehow Apache still looks in the htdoc directory for rt3… I’ve even
tried moving it but the same problem occurs.

Please post httpd.confOn Fri, Nov 18, 2005 at 07:56:50AM +0200, Rekha Varghese wrote:

Hi,

I’ve followed the installation guide but cannot seem to overcome the
following problem:

"You haven’t yet configured your webserver to configure to run RT…"
Somehow Apache still looks in the htdoc directory for rt3… I’ve even
tried moving it but the same problem occurs.

I’m using Apache2 on a Fedora 4.

Any help is appreciated.

Rekha
Development
Med-e-Mass (Pty) Ltd
PO Box 7045, Halfway House, 1685
Tel: n/a
Fax: n/a
Cell: 0832391913
E-mail: rekha@medemass.com
Web: www.medemass.com

This e-mail is subject to an e-mail disclaimer.
To read our e-mail disclaimer notice go to:
http://www.dhsolutions.co.za/disclaimer/email/
Alternatively please contact us on +27 11 265 5400


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Download a free sample chapter of RT Essentials from O’Reilly Media at http://rtbook.bestpractical.com

WE’RE COMING TO YOUR TOWN SOON - RT Training in Amsterdam, Boston and
San Francisco - Find out more at http://bestpractical.com/services/training.html

When I used the apache that came with Fedora 4 I had to upgrade to
mod_perl2 since it gave an error. I could find apxs so I installed
Apache2 on the box, but I cant seem to uninstall the original. I don’t
know whether this will cause a problem since I go to the relevant
directory to execute Apache2. But since I am clueless I have sent the
two conf files.

The first is taken from the orignal httpd.conf:
ServerName rekha99
UseCanonicalName on
DocumentRoot “/var/www/html”

Virtual hosts

Virtual host Virtual Host 0

DocumentRoot /opt/rt3/share/html
ServerName rekha99
 	
DirectoryIndex index.html index.htm index.shtml 

#Alias /rt3 /opt/rt3/share/html

#Applies to Apache2
#PerlModule Apache2 Apache::compat

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Directory /opt/rt3/share/html>
	AllowOverride All
	Options ExecCGI FollowSymLinks
	<IfModule mod_access.c>
		Order allow,deny
		Allow from all
	</IfModule>
</Directory>


DirectoryIndex index.html 

 
<Location />
	RewriteEngine On
	RedirectMatch permanent (.*)/$ $1/index.html
	AddDefaultCharset UTF-8
	SetHandler perl-script
	PerlHandler RT::Mason
</Location>
 	
LogLevel debug

The second is from the reinstalled Apache2 httpd.conf:
ServerRoot "/usr/local/apache2"
NameVirtualHost 127.0.0.1
NameVirtualHost 198.168.155.5:80

VirtualHost example:

Almost any Apache directive may go into a VirtualHost container.

The first VirtualHost section is used for requests without a known

server name.

#<VirtualHost *:80>

ServerAdmin webmaster@dummy-host.example.com

DocumentRoot /www/docs/dummy-host.example.com

ServerName dummy-host.example.com

ErrorLog logs/dummy-host.example.com-error_log

CustomLog logs/dummy-host.example.com-access_log common

#

<VirtualHost 127.0.0.1>
ServerName localhost
DocumentRoot “/usr/local/apache2/htdocs”
<Directory “/usr/local/apache2/htdocs”>
Options Indexes FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all

<VirtualHost 198.168.155.5:80>
DocumentRoot "/opt/rt3/share/html"
ServerName lekker

<VirtualHost 198.168.155.5>
ServerName lekker
#DocumentRoot "/opt/rt3/share/html"
Alias /rt3 “/opt/rt3/share/html”

PerlModule Apache2 Apache::compat
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl
<Directory /opt/rt3/share/html>
	AllowOverride All
	Options ExecCGI FollowSymLinks
	<IfModule mod_access.c>
		Order allow,deny
		Allow from all
	</IfModule>
</Directory>
<Location /rt3>
	RewriteEngine On
	RedirectMatch permanent (.*)/$ $1/index.html
	AddDefaultCharset UTF-8
	SetHandler perl-script
	PerlHandler RT::Mason
</Location>

From: Todd Chapman [mailto:todd@chaka.net]
Sent: 18 November 2005 08:51 AM
To: Rekha Varghese
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Problems installing rt

Please post httpd.conf

Hi,

I’ve followed the installation guide but cannot seem to overcome the

following problem:

"You haven’t yet configured your webserver to configure to run
RT…"
Somehow Apache still looks in the htdoc directory for rt3… I’ve even

tried moving it but the same problem occurs.

I’m using Apache2 on a Fedora 4.

Any help is appreciated.

Rekha
Development
Med-e-Mass (Pty) Ltd
PO Box 7045, Halfway House, 1685
Tel: n/a
Fax: n/a
Cell: 0832391913
E-mail: rekha@medemass.com
Web: www.medemass.com

This e-mail is subject to an e-mail disclaimer.
To read our e-mail disclaimer notice go to:
http://www.dhsolutions.co.za/disclaimer/email/
Alternatively please contact us on +27 11 265 5400


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Download a free sample chapter of RT Essentials from O’Reilly Media at

http://rtbook.bestpractical.com

WE’RE COMING TO YOUR TOWN SOON - RT Training in Amsterdam, Boston and
San Francisco - Find out more at
http://bestpractical.com/services/training.html

I’ve started from scratch and now I get the following problem in the
apache error log:
[Wed Dec 07 08:45:39 2005] [error] Can’t locate Apache2/Response.pm in
@INC (@INC contains:
/usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi/usr/lib/perl5/sit
e_perl/5.8.5/i386-
linux-thread-multi
/usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/
site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6
/usr/lib/perl5/
site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4
/usr/lib/perl5/site_perl/5.8.3 /usr/lib/
perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/
vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.4/i386-linux-
thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/
vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl/5.8.4
/usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl
/usr/lib/perl5/5.8.6/
i386-linux-thread-multi /usr/lib/perl5/5.8.6 . /usr/local/apache2) at
/usr/lib/
perl5/5.8.6/CGI.pm line 184.\nCompilation failed in require at
/usr/local/apache2
/htdocs/rt/bin/webmux.pl line 56.\nBEGIN failed–compilation aborted at
/usr/local
/apache2/htdocs/rt/bin/webmux.pl line 56.\nCompilation failed in require
at (eval 2) line 1.\n

Can’t load Perl file: /usr/local/apache2/htdocs/rt/bin/webmux.pl for
server rekha99.local.com:0, exiting…

My httpd.conf file is as follows:

<VirtualHost *:80>

Alias /rt /usr/local/apache2/htdocs/rt/share/html

ServerName rekha99.local.com

ErrorLog logs/rekha.local-error_log

CustomLog logs/rekha.local-access_log common

PerlModule Apache2::compat

PerlModule Apache2::DBI

PerlRequire /usr/local/apache2/htdocs/rt/bin/webmux.pl

<Directory /usr/local/apache2/htdocs/rt/share/html>

AllowOverride All

Options ExecCGI FollowSymLinks

Order allow,deny

Allow from all

<Location /rt>

RewriteEngine On

RedirectMatch permanent (.*)/$ http://rekha99.local.com$1/index.html

AddDefaultCharset UTF-8

SetHandler perl-script

PerlHandler RT::Mason

Rekha
Development
Med-e-Mass (Pty) Ltd
PO Box 7045, Halfway House, 1685
Tel: n/a
Fax: n/a
Cell: 0832391913
E-mail: rekha@medemass.com
Web: www.medemass.com

This e-mail is subject to an e-mail disclaimer.
To read our e-mail disclaimer notice go to:
http://www.dhsolutions.co.za/disclaimer/email/
Alternatively please contact us on +27 11 265 5400From: Rekha Varghese
Sent: 18 November 2005 08:47 AM
To: rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Problems installing rt

When I used the apache that came with Fedora 4 I had to upgrade to
mod_perl2 since it gave an error. I could find apxs so I installed
Apache2 on the box, but I cant seem to uninstall the original. I don’t
know whether this will cause a problem since I go to the relevant
directory to execute Apache2. But since I am clueless I have sent the
two conf files.

The first is taken from the orignal httpd.conf:
ServerName rekha99
UseCanonicalName on
DocumentRoot “/var/www/html”

Virtual hosts

Virtual host Virtual Host 0

DocumentRoot /opt/rt3/share/html
    ServerName rekha99
          
    DirectoryIndex index.html index.htm index.shtml
  
    #Alias /rt3 /opt/rt3/share/html
  
    #Applies to Apache2
    #PerlModule Apache2 Apache::compat
  
    PerlModule Apache::DBI
    PerlRequire /opt/rt3/bin/webmux.pl

    <Directory /opt/rt3/share/html>
            AllowOverride All
            Options ExecCGI FollowSymLinks
            <IfModule mod_access.c>
                    Order allow,deny
                    Allow from all
            </IfModule>
    </Directory>
  

    DirectoryIndex index.html
  
   
    <Location />
            RewriteEngine On
            RedirectMatch permanent (.*)/$ $1/index.html
            AddDefaultCharset UTF-8
            SetHandler perl-script
            PerlHandler RT::Mason
    </Location>
          
    LogLevel debug

The second is from the reinstalled Apache2 httpd.conf:
ServerRoot "/usr/local/apache2"
NameVirtualHost 127.0.0.1
NameVirtualHost 198.168.155.5:80

VirtualHost example:

Almost any Apache directive may go into a VirtualHost container.

The first VirtualHost section is used for requests without a known

server name.
#<VirtualHost *:80>

ServerAdmin webmaster@dummy-host.example.com

DocumentRoot /www/docs/dummy-host.example.com

ServerName dummy-host.example.com

ErrorLog logs/dummy-host.example.com-error_log

CustomLog logs/dummy-host.example.com-access_log common

#

<VirtualHost 127.0.0.1>
ServerName localhost
DocumentRoot “/usr/local/apache2/htdocs”
<Directory “/usr/local/apache2/htdocs”>
Options Indexes FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all

<VirtualHost 198.168.155.5:80>
DocumentRoot "/opt/rt3/share/html"
ServerName lekker

<VirtualHost 198.168.155.5>
ServerName lekker
#DocumentRoot "/opt/rt3/share/html"
Alias /rt3 “/opt/rt3/share/html”

    PerlModule Apache2 Apache::compat
    PerlModule Apache::DBI
    PerlRequire /opt/rt3/bin/webmux.pl
    <Directory /opt/rt3/share/html>
            AllowOverride All
            Options ExecCGI FollowSymLinks
            <IfModule mod_access.c>
                    Order allow,deny
                    Allow from all
            </IfModule>
    </Directory>
    <Location /rt3>
            RewriteEngine On
            RedirectMatch permanent (.*)/$ $1/index.html
            AddDefaultCharset UTF-8
            SetHandler perl-script
            PerlHandler RT::Mason
    </Location>

From: Todd Chapman [mailto:todd@chaka.net]
Sent: 18 November 2005 08:51 AM
To: Rekha Varghese
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Problems installing rt

Please post httpd.conf

Hi,

I’ve followed the installation guide but cannot seem to overcome the
following problem:

"You haven’t yet configured your webserver to configure to run
RT…"
Somehow Apache still looks in the htdoc directory for rt3… I’ve even
tried moving it but the same problem occurs.

I’m using Apache2 on a Fedora 4.

Any help is appreciated.

Rekha
Development
Med-e-Mass (Pty) Ltd
PO Box 7045, Halfway House, 1685
Tel: n/a
Fax: n/a
Cell: 0832391913
E-mail: rekha@medemass.com
Web: www.medemass.com

This e-mail is subject to an e-mail disclaimer.
To read our e-mail disclaimer notice go to:
http://www.dhsolutions.co.za/disclaimer/email/
Alternatively please contact us on +27 11 265 5400


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Download a free sample chapter of RT Essentials from O’Reilly Media at
http://rtbook.bestpractical.com

WE’RE COMING TO YOUR TOWN SOON - RT Training in Amsterdam, Boston and
San Francisco - Find out more at
http://bestpractical.com/services/training.html

Hello!On Tue, 2005-12-06 at 22:59, Rekha Varghese wrote:

I’ve started from scratch and now I get the following problem in the
apache error log:
[Wed Dec 07 08:45:39 2005] [error] Can’t locate Apache2/Response.pm in
@INC

Looks like some module or another depends on Apache2::Response and it’s
not installed on your webserver. cpan install Apache2::Response should
probably take care of it, but be ready for more.

Perhaps running make testdeps or make fixdeps in your RT source
directory would help identify (and fix) others, but you’ve likely
already done that.

Cheers!

–j
Jim Meyer, Geek at Large purp@acm.org

Hi, I’ve seem to have corrected the problem. I uninstalled httpd and
installed the latest apache package. Well at least I can see a login
page, though when looking at the log files there were some errors…

Rekha
Development
Med-e-Mass (Pty) Ltd
PO Box 7045, Halfway House, 1685
Tel: n/a
Fax: n/a
Cell: 0832391913
E-mail: rekha@medemass.com
Web: www.medemass.com

This e-mail is subject to an e-mail disclaimer.
To read our e-mail disclaimer notice go to:
http://www.dhsolutions.co.za/disclaimer/email/
Alternatively please contact us on +27 11 265 5400From: Jim Meyer [mailto:purp@acm.org]
Sent: 07 December 2005 20:22 PM
To: Rekha Varghese
Cc: rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Problems installing rt

Hello!