Problems installing RT 4.0.5 with mod_fcgid

Hi to all.

Im trying to install http://www.linuxquestions.org/questions/# a CentOS
6.2 machine with the Request Tracker Software (RT).
Its a web-perl app to manage support tickets.

I see that is recomended use mod_fcgid and install the server with centos
6.2, mysql http://www.linuxquestions.org/questions/#, apache and the
requeriments to run RT.

I installed http://www.linuxquestions.org/questions/# all (mod_fcgid from
rpm from last tar.gz sources).

The server works fibne. I can get running the Apache test page, and
myphpadmin.

Code:

yum install httpd-devel
Download source mod_fcgid.
wget http://www.apache.org/dist/httpd/mod_fcgid/mod_fcgid-2.3.6.tar.gz

Install mod_fcgid.
tar -zxvf src/mod_fcgid-2.3.6.tar.gz
cd mod_fcgid-2.3.6
./configure.apxs
make
make install
Configure FCGID populating the conf file.
nano -w /etc/httpd/conf.d/php-fcgid.conf

<IfModule mod_fcgid.c>
DefaultInitEnv PHPRC=/etc
AddHandler php-fcgi .php
FcgidConnectTimeout 20
MaxRequestLen 2100000
Action php-fcgi /fcgi-bin/php-fcgi-wrapper
AddType application/x-httpd-php .php
Alias /fcgi-bin/ /var/www/fcgi-bin.d/default/
<Location /fcgi-bin/>
SetHandler fcgid-script
Options +ExecCGI
</Location>
</IfModule>
FcgidIOTimeout 2000
IdleScanInterval 5
BusyScanInterval 5
DefaultMinClassProcessCount 0
DefaultMaxClassProcessCount 10
IPCCommTimeout 60
IPCConnectTimeout 60
IdleTimeout 5

Nex try to restart httpd and get this.

[root@rt2 conf.d]# /etc/init.d/httpd restart
Stopping httpd: [FAILED]
Starting httpd: Syntax error on line 19 of /etc/httpd/conf.d/php-fcgid.conf:
Invalid command ‘IdleScanInterval’, perhaps misspelled or defined by a
module not included in the server
configurationhttp://www.linuxquestions.org/questions/#
[FAILED]

doesn´t accept any line under “” in the
/etc/httpd/conf.d/php-fcgid.conf file.

Any help, please??

Thanks.
Kindest regards.

Solved.

The error are mod_fcgid. I installed it manually but doesn´t works. Y use
the EPEL respository and install it with YUM. Now works, i have another
problems, but works.

Kindest regards.El 14 de marzo de 2012 09:56, Juanjo juanjillo@gmail.com escribió:

Hi to all.

Im trying to install http://www.linuxquestions.org/questions/# a CentOS
6.2 machine with the Request Tracker Software (RT).
Its a web-perl app to manage support tickets.

I see that is recomended use mod_fcgid and install the server with centos
6.2, mysql http://www.linuxquestions.org/questions/#, apache and the
requeriments to run RT.

I installed http://www.linuxquestions.org/questions/# all (mod_fcgid
from rpm from last tar.gz sources).

The server works fibne. I can get running the Apache test page, and
myphpadmin.

Code:

yum install httpd-devel
Download source mod_fcgid.
wget http://www.apache.org/dist/httpd/mod_fcgid/mod_fcgid-2.3.6.tar.gz

Install mod_fcgid.
tar -zxvf src/mod_fcgid-2.3.6.tar.gz
cd mod_fcgid-2.3.6
./configure.apxs
make
make install
Configure FCGID populating the conf file.
nano -w /etc/httpd/conf.d/php-fcgid.conf

DefaultInitEnv PHPRC=/etc AddHandler php-fcgi .php FcgidConnectTimeout 20 MaxRequestLen 2100000 Action php-fcgi /fcgi-bin/php-fcgi-wrapper AddType application/x-httpd-php .php Alias /fcgi-bin/ /var/www/fcgi-bin.d/default/ SetHandler fcgid-script Options +ExecCGI FcgidIOTimeout 2000 IdleScanInterval 5 BusyScanInterval 5 DefaultMinClassProcessCount 0 DefaultMaxClassProcessCount 10 IPCCommTimeout 60 IPCConnectTimeout 60 IdleTimeout 5

Nex try to restart httpd and get this.

[root@rt2 conf.d]# /etc/init.d/httpd restart
Stopping httpd: [FAILED]
Starting httpd: Syntax error on line 19 of
/etc/httpd/conf.d/php-fcgid.conf:
Invalid command ‘IdleScanInterval’, perhaps misspelled or defined by a
module not included in the server configurationhttp://www.linuxquestions.org/questions/#
[FAILED]

doesn´t accept any line under “” in the
/etc/httpd/conf.d/php-fcgid.conf file.

Any help, please??

Thanks.
Kindest regards.

Un saludo.
Juanjo Corral