Problems finding index.html


I installed and configured RT 2.0.8 and it looks like it works almost
correct. I can login as root and create a new ticket. The ticket is
shown in the list. So I would assume, that the general functionality is
doing alright and even the connection to the DB is working.

But there are still 2 issues left, that are really annoying and I don’t
know how to get rid of them.

  1. Everytime an action leads to loading a directory name (which of
    course means to load the index.html located in the specified directory),
    all I get is the directory structure itself. A click on the index.html
    contained in it, brings me to the designated page. How do I configure
    Apache (?) to load the index.html immediately. This is how it is
    configured now (just the RT related part);

    DirectoryIndex index.cgi index.html Alias /icons/ /var/www/icons/ Alias /rt2/ /opt/rt2/WebRT/html/ PerlModule Apache::DBI PerlFreshRestart On PerlRequire /opt/rt2/bin/ SetHandler perl-script PerlHandler RT::Mason

I also tried to use the DirectoryIndex command without being wrapped in
that if statement (I remember from somewhere that this should be the
command telling apache to load one of the specified files). But all this
has no effect. Be assured that I always stop and start my apache. Any

  1. I tried to add a new user. This seems to work fine. But using the
    search option, I always get an error message telling me, that there is
    no directory rt2/Admin/User/ ([error] [client] File does not
    exist: /opt/rt2/WebRT/html/Admin/Users//). But when I try click on
    "Users" in the configuration section, I get the directory structure of
    it (see above). What’s going wrong here?

Maybe my configuration is part of the problem. I installed RT 2.0.8 on a
Mandrake 7.2 machine. MySQL is working fine on it.

Any help would be appreciated.