Problems apache 2.0.47, perl 5.8.1, rt 3-0-6

Hello!

I couldn’t start the apache server since upgrading my system.

I get following errors from the Apache:
server1:~# /usr/local/apache2047/bin/apachectl start
[Mon Oct 06 20:10:13 2003] [error] Can’t locate loadable object for
module Apache::Constants in @INC (@INC contains: /opt/rt3/local/lib
/opt/rt3/lib /etc/perl /usr/local/lib/perl/5.8.1
/usr/local/share/perl/5.8.1 /usr/lib/perl5 /usr/share/perl5
/usr/lib/perl/5.8.1 /usr/share/perl/5.8.1 /usr/local/lib/site_perl
/usr/local/lib/perl/5.8.0 /usr/local/share/perl/5.8.0 .
/usr/local/apache2047/ /usr/local/apache2047/lib/perl) at
/usr/lib/perl5/mod_perl.pm line 14
Compilation failed in require at /usr/lib/perl5/Apache.pm line 6.
BEGIN failed–compilation aborted at /usr/lib/perl5/Apache.pm line 6.
Compilation failed in require at /usr/share/perl/5.8.1/CGI.pm line 189.
Compilation failed in require at /opt/rt3/bin/webmux.pl line 54.
BEGIN failed–compilation aborted at /opt/rt3/bin/webmux.pl line 54.
Compilation failed in require at (eval 1) line 1.

[Mon Oct 06 20:10:13 2003] [error] Can’t load Perl file:
/opt/rt3/bin/webmux.pl for server rt.intra.kornhuber.com:0, exiting…

Thx for your help.

Steve

Hi Ruslan!

I use debian unstable.
I have installed all perl modules with the MCPAN according to the test
script of the rt system.

I’m a little bit confused about the testing script of rt, because rt
found perl 5.8.0 and if I use perl --version, I will get 5.8.1.

I updated the perl_mod2 of apache to 1.99.10.

BTW. I found the Constants.pm in following directories:
/usr/share/perl/5.8.1/Locale/Constants.pm
/usr/lib/perl5/Apache/Constants.pm
But these directories are also in the @INC.

thanks
Steve

Ruslan U. Zakirov wrote: