Problem with taking ticket under RT 3.6.3 (WebURL or WebPort issue ?)

I am running into a strange issue.

I have Set($WebBaseURL , “https://ceert3.ce.gatech.edu”);
in my RT_SiteConfig.pm

Everything is working great except when a user click to take a ticket.
He is being redirected to the following URL for some reason ->

https://ceert3.ce.gatech.edu:80/Ticket/Display.html?id=4
^^^^^
This seems to happen only when someone try to take a ticket.
Everything other actions work just fine.

I have tried to modify the WebPort value to 443
Set($WebPort , 443);
but still no luck.

I must admit I am kind of loss on that one.

The only thing I can see in the apache log are
[15/May/2007:09:49:25 -0400] “GET /Ticket/Display.html?Action=Take&id=4 HTTP/1.1” 302 240

I was wondering if someone as seen this before with 3.6.3

Thanks - Didier

Didier Contis
IT Manager
School of CEE / Georgia Tech

I have tried to modify the WebPort value to 443
Set($WebPort , 443);
but still no luck.

Did you restart your webserver after making this change?

I had tried a full httpd restart before posting to the mailing list.

It seems like the port :80 is coming from one of the module
and added to whatever WebURL is set to.

Didier.----- Original Message -----
From: “Matthew Keller” kellermg@potsdam.edu
To: “Didier Contis” didier.contis@ce.gatech.edu
Cc: rt-users@lists.bestpractical.com
Sent: Tuesday, May 15, 2007 11:09:53 AM (GMT-0500) America/New_York
Subject: Re: [rt-users] Problem with taking ticket under RT 3.6.3 (WebURL or WebPort issue ?)

On Tue, 2007-05-15 at 10:04 -0400, Didier Contis wrote:

I have tried to modify the WebPort value to 443
Set($WebPort , 443);
but still no luck.

Did you restart your webserver after making this change?

Didier Contis
IT Manager
School of CEE / Georgia Tech

I had a similar problem when I first installed 3.6.3. What worked for me
was changing my RT_SiteConfig.pm settings to these:

Set($WebPath , “/rt”);
Set($WebPort , 443);
Set($WebBaseURL , “https://rtserver.sdsu.edu:$WebPort”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);

The only difference I see between what you have and mine is that I add the
port number to the URL.

Gene

At 07:04 AM 5/15/2007, Didier Contis wrote:

I have Set($WebBaseURL , “https://ceert3.ce.gatech.edu”);
in my RT_SiteConfig.pm

Everything is working great except when a user click to take a ticket.
He is being redirected to the following URL for some reason →

https://ceert3.ce.gatech.edu:80/Ticket/Display.html?id=4
^^^^^
This seems to happen only when someone try to take a ticket.
Everything other actions work just fine.

I have tried to modify the WebPort value to 443
Set($WebPort , 443);
but still no luck.

I must admit I am kind of loss on that one.

Gene LeDuc, GSEC
Security Analyst
San Diego State University