Problem with sending emails with polish character in subject

Hello!

I’ve just upgraded to rt 3.8.2 and I’ve got following problem:

If I send email do my RT without Polish characters - everything works
fine.

But if there are some of those chars (ie.: “grzegżółka”), then I’m
unable to replay to ticket - each time I click on “replay” I see im my
logs lines like:

May 5 13:53:08 mercury RT: Scrip Prepare 20 died. - Cannot decode
string with wide characters at /usr/lib/perl/5.8/Encode.pm line 166.
Stack: [/usr/lib/perl/5.8/Encode.pm:166] [/usr/lib/perl/5.8/
Encode.pm:206] [/usr/share/request-tracker3.8/lib/RT/Action/
SendEmail.pm:958] [/usr/share/request-tracker3.8/lib/RT/Action/
SendEmail.pm:575] [/usr/share/request-tracker3.8/lib/RT/Action/
SendEmail.pm:169] [/usr/share/request-tracker3.8/lib/RT/Action/
Notify.pm:69] [/usr/share/request-tracker3.8/lib/RT/
ScripAction_Overlay.pm:230] [/usr/share/request-tracker3.8/lib/RT/
Scrip_Overlay.pm:435] [/usr/share/request-tracker3.8/lib/RT/
Scrips_Overlay.pm:240] [/usr/share/request-tracker3.8/lib/RT/
Transaction_Overlay.pm:169] [/usr/share/request-tracker3.8/lib/RT/
Record.pm:1456] [/usr/share/request-tracker3.8/lib/RT/
Ticket_Overlay.pm:2145] [/usr/share/request-tracker3.8/lib/RT/
Ticket_Overlay.pm:2057] [/usr/share/request-tracker3.8/html/Ticket/
Elements/PreviewScrips:131] [/usr/share/request-tracker3.8/htm

(etc. for each scrips I’ve defined). The same log entries appears when
I fill form and click update. No email is sent.

How to fix this problem?
Grzegorz Marszałek
graf0@post.pl

Do you send it via email or create via WebUI? If it’s first then could
you please send me copy of email as it goes out of your MUA. I don’t
need text, but whole MIME envelope. You can find message in the "sent"
box and use “view source” feature, I hope your MUA has such. Sent it
to me as an attachment. You can hide some deatails, but please try to
avoid breaking formatting.2009/5/5 Grzegorz Marszałek graf0@post.pl:

Hello!

I’ve just upgraded to rt 3.8.2 and I’ve got following problem:

If I send email do my RT without Polish characters - everything works
fine.

But if there are some of those chars (ie.: “grzegżółka”), then I’m
unable to replay to ticket - each time I click on “replay” I see im my
logs lines like:

May 5 13:53:08 mercury RT: Scrip Prepare 20 died. - Cannot decode
string with wide characters at /usr/lib/perl/5.8/Encode.pm line 166.
Stack: [/usr/lib/perl/5.8/Encode.pm:166] [/usr/lib/perl/5.8/
Encode.pm:206] [/usr/share/request-tracker3.8/lib/RT/Action/
SendEmail.pm:958] [/usr/share/request-tracker3.8/lib/RT/Action/
SendEmail.pm:575] [/usr/share/request-tracker3.8/lib/RT/Action/
SendEmail.pm:169] [/usr/share/request-tracker3.8/lib/RT/Action/
Notify.pm:69] [/usr/share/request-tracker3.8/lib/RT/
ScripAction_Overlay.pm:230] [/usr/share/request-tracker3.8/lib/RT/
Scrip_Overlay.pm:435] [/usr/share/request-tracker3.8/lib/RT/
Scrips_Overlay.pm:240] [/usr/share/request-tracker3.8/lib/RT/
Transaction_Overlay.pm:169] [/usr/share/request-tracker3.8/lib/RT/
Record.pm:1456] [/usr/share/request-tracker3.8/lib/RT/
Ticket_Overlay.pm:2145] [/usr/share/request-tracker3.8/lib/RT/
Ticket_Overlay.pm:2057] [/usr/share/request-tracker3.8/html/Ticket/
Elements/PreviewScrips:131] [/usr/share/request-tracker3.8/htm

(etc. for each scrips I’ve defined). The same log entries appears when
I fill form and click update. No email is sent.

How to fix this problem?

Grzegorz Marszałek
graf0@post.pl


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Best regards, Ruslan.