Problem with RT 4.0.10 install

Having some install problems with RT 4.0.10 on Mac osx Mountain Lion
When running make testdeps
RT is looking at perl 5.8.8

error example:
DBI …MISSING
Can’t locate DBI.pm in @INC (@INC contains:
/opt/local/lib/perl5/5.8.8/darwin-2level /opt/local/lib/perl5/5.8.8
/opt/local/lib/perl5/site_perl/5.8.8/darwin-2level
/opt/local/lib/perl5/site_perl/5.8.8 /opt/local/lib/perl5/site_perl
/opt/local/lib/perl5/vendor_perl/5.8.8/darwin-2level
/opt/local/lib/perl5/vendor_perl/5.8.8 /opt/local/lib/perl5/vendor_perl
/Users/rayc/Desktop/rt-4.0.10)

The problem is that I have perl 5.12 and CPAN is installing all modules to
this directory.

How do I tell RT that I am using Perl 5.12 and not Perl 5.8.8

./configure --helpOn Sat, Mar 30, 2013 at 9:09 PM, Ray Corbett racorbb@gmail.com wrote:

Having some install problems with RT 4.0.10 on Mac osx Mountain Lion
When running make testdeps
RT is looking at perl 5.8.8

error example:
DBI …MISSING
Can’t locate DBI.pm in @INC (@INC contains:
/opt/local/lib/perl5/5.8.8/darwin-2level /opt/local/lib/perl5/5.8.8
/opt/local/lib/perl5/site_perl/5.8.8/darwin-2level
/opt/local/lib/perl5/site_perl/5.8.8 /opt/local/lib/perl5/site_perl
/opt/local/lib/perl5/vendor_perl/5.8.8/darwin-2level
/opt/local/lib/perl5/vendor_perl/5.8.8 /opt/local/lib/perl5/vendor_perl
/Users/rayc/Desktop/rt-4.0.10)

The problem is that I have perl 5.12 and CPAN is installing all modules to
this directory.

How do I tell RT that I am using Perl 5.12 and not Perl 5.8.8

Best regards, Ruslan.

Running Mac osx Mountain Lion 10.8

running
make testdeps

returns as one example:

…MISSING
Can’t locate HTML/Entities.pm in @INC (@INC contains:
/opt/local/lib/perl5/5.8.8/darwin-2level /opt/local/lib/perl5/5.8.8
/opt/local/lib/perl5/site_perl/5.8.8/darwin-2level
/opt/local/lib/perl5/site_perl/5.8.8 /opt/local/lib/perl5/site_perl
/opt/local/lib/perl5/vendor_perl/5.8.8/darwin-2level
/opt/local/lib/perl5/vendor_perl/5.8.8 /opt/local/lib/perl5/vendor_perl) at
/opt/local/lib/perl5/site_perl/5.8.8/HTML/Mason/Escapes.pm line 17.

make fixdeps

MASON dependencies:
Storable >= 2.08 …found
CSS::Squish >= 0.06 …found
Apache::Session >= 1.53 …found
Errno …found
Devel::StackTrace >= 1.19 …found
IPC::Run3 …found
CGI::Cookie >= 1.20 …found
Text::WikiFormat >= 0.76 …found
XML::RSS …MISSING
Can’t locate XML/Parser.pm in @INC (@INC contains:
/opt/local/lib/perl5/5.8.8/darwin-2level /opt/local/lib/perl5/5.8.8
/opt/local/lib/perl5/site_perl/5.8.8/darwin-2level
/opt/local/lib/perl5/site_perl/5.8.8 /opt/local/lib/perl5/site_perl
/opt/local/lib/perl5/vendor_perl/5.8.8/darwin-2level
/opt/local/lib/perl5/vendor_perl/5.8.8 /opt/local/lib/perl5/vendor_perl) at
/opt/local/lib/perl5/site_perl/5.8.8/XML/RSS.pm line 7.
HTML::Mason …MISSING
Can’t locate HTML/Entities.pm in @INC (@INC contains:
/opt/local/lib/perl5/5.8.8/darwin-2level /opt/local/lib/perl5/5.8.8
/opt/local/lib/perl5/site_perl/5.8.8/darwin-2level
/opt/local/lib/perl5/site_perl/5.8.8 /opt/local/lib/perl5/site_perl
/opt/local/lib/perl5/vendor_perl/5.8.8/darwin-2level
/opt/local/lib/perl5/vendor_perl/5.8.8 /opt/local/lib/perl5/vendor_perl) at
/opt/local/lib/perl5/site_perl/5.8.8/HTML/Mason/Escapes.pm line 17.

Running cpan

cpan[1]> install HTML::Mason

returns

Reading ‘/Users/rayc/.cpan/Metadata’
Database was generated on Sat, 30 Mar 2013 18:17:03 GMT
HTML::Mason is up to date (1.50).

But clan must be installing somewhere else. Because make testdeps will
say HTML::Mason is missing.

Same for 28 modules

What am I missing?On Sat, Mar 30, 2013 at 3:11 PM, Ruslan Zakirov ruz@bestpractical.comwrote:

./configure --help

On Sat, Mar 30, 2013 at 9:09 PM, Ray Corbett racorbb@gmail.com wrote:

Having some install problems with RT 4.0.10 on Mac osx Mountain Lion
When running make testdeps
RT is looking at perl 5.8.8

error example:
DBI …MISSING
Can’t locate DBI.pm in @INC (@INC contains:
/opt/local/lib/perl5/5.8.8/darwin-2level /opt/local/lib/perl5/5.8.8
/opt/local/lib/perl5/site_perl/5.8.8/darwin-2level
/opt/local/lib/perl5/site_perl/5.8.8 /opt/local/lib/perl5/site_perl
/opt/local/lib/perl5/vendor_perl/5.8.8/darwin-2level
/opt/local/lib/perl5/vendor_perl/5.8.8 /opt/local/lib/perl5/vendor_perl
/Users/rayc/Desktop/rt-4.0.10)

The problem is that I have perl 5.12 and CPAN is installing all modules
to
this directory.

How do I tell RT that I am using Perl 5.12 and not Perl 5.8.8


Best regards, Ruslan.

How do I tell RT that I am using Perl 5.12 and not Perl 5.8.8

Is the new Perl in your PATH? Type “which perl” and “perl -v” to
check. If so, do you have an environment variable “PERL5LIB” and if so
what is it set to?

http://www.linkedin.com/in/paultomblin
http://careers.stackoverflow.com/ptomblin