Problem with Perl RT package

My RT installation saga continues…

I have installed RT on a Mandrake 9.0 box,

The first problem I run into was that for some reason the make install
process did not completely configure my file and I had to
manually fill the information for $MasonComponentRoot,$MasonLocalComponentRoot,$MasonDataDir

When I run make testdeps all is found and there are no errors but my
problem is this:

when I try to access RT I get an ERROR 500 from APACHE and the rt log
file contains the following:

[error] Can’t locate object method “new” via
package “RT::Handle” at /downloads/rt/rt-2-0-15/lib/ line 26.

I thought my problem was with the @INC var and I
tried to add a use lib qw(…) into but to no avail…

Examining the file revealed to me that there is no function “new” in the file, I am by no
means a perl guru so can someone try and help me see the light here?
where have I gone wrong??

(I really need this demo working before Tuesday or I may get this
project shut down and I really want to push the first Linux based
system into my company… mercy mercy me)


Best Regards,
Ron Gidron
Customer Support Manager
Phone: +972 9 7643750
Mobile: +972 54 792469