Problem with Input must match

I created a custom field of the type Enter one value and used the input validation of Digits.

Interestingly, “0” is not a valid input. “1” and “00” are valid input.

“-0” and “-1” obviously do not match the “^[\d.]+$” regular expression.

I have tested this on RT 4.2.2 and IE10 and FF27.

My Regexp packages are 2013031301. Re is 0.09

Keith Schincke

I created a custom field of the type Enter one value and used the input validation of Digits.

Interestingly, “0” is not a valid input. “1” and “00” are valid input.

“-0” and “-1” obviously do not match the “[1]+$” regular expression.

I have tested this on RT 4.2.2 and IE10 and FF27.

I suspect this is related to the other issues with 0 as a CF value and
Date Custom Fields which was resolved in 4.2.3 (and indeed testing on
4.2.3 doesn’t show this bug).

-kevin


  1. \d. ↩︎

Thank you. I will have my admin put the update through before the system goes full production.

Keith-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Kevin Falcone
Sent: Wednesday, March 05, 2014 2:33 PM
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Problem with Input must match [Digits]

On Wed, Mar 05, 2014 at 12:59:06PM -0600, Schincke, Keith wrote:

I created a custom field of the type Enter one value and used the input validation of Digits.

Interestingly, “0” is not a valid input. “1” and “00” are valid input.

“-0” and “-1” obviously do not match the “[1]+$” regular expression.

I have tested this on RT 4.2.2 and IE10 and FF27.

I suspect this is related to the other issues with 0 as a CF value and Date Custom Fields which was resolved in 4.2.3 (and indeed testing on
4.2.3 doesn’t show this bug).

-kevin


  1. \d. ↩︎