Problem with german umlaut

Hello,

I have a problem with german umlauts here. q
Jan Theofel Fon: +49 (7 11) 48 90 83 - 0
ETES - EDV-Systemhaus GbR Fax: +49 (7 11) 48 90 83 - 50
Libanonstrasse 58 A * D-70184 Stuttgart Web: http://www.etes.de

Hello,On Wed, Apr 28, 2004 at 01:30:00PM +0200, Jan Theofel wrote:

I have a problem with german umlauts here.

Sorry, this mail was sent before I completed it. Here’s the problem:

When I recieve tickets including german umlauts bei email the umlauts
are displayed wrong in the webinterface and in the mails to the user.
Even my umlauts in the email template are displayed the wring way. There
is no difference between a mail sent loacally (by mutt) or from other
email clients remote.

If the ticket is entered using the webinterface, the umlauts don’t make
problems. Even these in the mail template are ok.

System: RT 3.0.10, perl 5.8.1, postgres database 7.3.4

Thanks in advance,
Jan

Jan Theofel Fon: +49 (7 11) 48 90 83 - 0
ETES - EDV-Systemhaus GbR Fax: +49 (7 11) 48 90 83 - 50
Libanonstrasse 58 A * D-70184 Stuttgart Web: http://www.etes.de

Have you the following string in your apache configuration file?

AddDefaultCharset UTF-8

What web server do you use by the way? I hope apache 1.3.*

Jan Theofel wrote:

Hello,

I have a problem with german umlauts here.

Sorry, this mail was sent before I completed it. Here’s the problem:

When I recieve tickets including german umlauts bei email the umlauts
are displayed wrong in the webinterface and in the mails to the user.
Even my umlauts in the email template are displayed the wring way. There
is no difference between a mail sent loacally (by mutt) or from other
email clients remote.

If the ticket is entered using the webinterface, the umlauts don’t make
problems. Even these in the mail template are ok.

System: RT 3.0.10, perl 5.8.1, postgres database 7.3.4

Thanks in advance,
Jan

Dmitry Monakhov System Administrator
Open Technologies, tel: +7(095)787-7027
e-mail: monakhv@ot.ru, http://www.ot.ru/

System: RT 3.0.10, perl 5.8.1, postgres database 7.3.4
Upgrade to perl 5.8.3 and compile mod_perl against it (if you are using
mod_perl).

Greetings
Aurel

Hello all,

I have some people that are AdminCC’s in various queues because I want them to
see everything that happens in the queue, but when they either create a ticket
or take a ticket in that queue, they start getting multiple emails every time
something happens on a ticket. I’d like to stop that. So, I’m trying to find a
way to amend this standard scrip:

On Correspond Notify AdminCcs with template Admin Correspondence

With something that essentially does this:

On Correspond Notify all of the AdminCcs that are not also a Requestor, Owner,
or CC. with template Admin Correspondence.

I assume I can do that by adding some kind of custom condition or custom prep
code, any advice?

Thanks,
-Dan

When I recieve tickets including german umlauts bei email the umlauts
are displayed wrong in the webinterface and in the mails to the user.
Even my umlauts in the email template are displayed the wring way. There
is no difference between a mail sent loacally (by mutt) or from other
email clients remote.

If the ticket is entered using the webinterface, the umlauts don’t make
problems. Even these in the mail template are ok.

System: RT 3.0.10, perl 5.8.1, postgres database 7.3.4

Please answer to the following questions:

Which encoding do you use for sending mails (iso-8859-*)?
What are your settings on @EmailInputEncodings, 

$EmailOutputEncoding on RT_SiteConfig.pm?
What apache do you use? Is RT in a VirtualHost or not?
Do you have AddDefaultCharset UTF-8 on apache config?

Paulo Matos

|Sys & Net Admin | Servi�o de Inform�tica |
|Faculdade de Ci�ncias e Tecnologia | Tel: +351-21-2948596 |
|Universidade Nova de Lisboa | Fax: +351-21-2948548 |
|P-2829-516 Caparica | e-Mail: pjsm@fct.unl.pt |