Problem with email FROM/SENDER fields

Hi All.

We’re using QMAIL as our mail server.

In all emails generated by the RT system we receive the following fields:
RT-Ticket: My TroubleTicket #43
X-Mailer: Perl5 Mail::Internet v1.33
Precedence: bulk
RT-Originator: ayali@ayali.com
Sender: nobody nobody@access.mysite.com

Note that there is a “Sender:” field set to be nobody (our apache server
runs in “nobody” user).

When receiving this automatically generated email, the user sees in the
"nobody [nobody@access.mysite.com] on behalf of Support
[support@mysite.com]"

This is very annoying!

We would prefer to see the From field only and ommit the “Sender” field at
all!

Can anyone suggest/help??

Thank you,
Ayal.
ayali@ayali.com

We would prefer to see the From field only and ommit the “Sender” field at
all!

Can anyone suggest/help??

This is such a common question, that it’s answered in the FAQ and
mailing list archives. Why don’t you take a look there?

http://www.fsck.com/rtfm/article.html?id=105

seph

We would prefer to see the From field only and ommit the
"Sender" field at
all!

Can anyone suggest/help??

This is such a common question, that it’s answered in the FAQ and
mailing list archives. Why don’t you take a look there?

http://www.fsck.com/rtfm/article.html?id=105

It doesn’t really help if you’re using Qmail and don’t have sendmailpipe
anywhere.

I sometimes see addresses like queue.domain.com@domain.com, or the
common nobody@domain.com

Can’t find any info on the former email address, probably qmail setup
related. If anyone has seen it and knows how to set it up properly,
please let me know.

TIA,
Andy.

http://www.fsck.com/rtfm/article.html?id=105

It doesn’t really help if you’re using Qmail and don’t have sendmailpipe
anywhere.

I thought this was in the docs, but my quick search doesn’t find it. I
guess it’s only been made clear on the mailing list. sendmailpipe
isn’t a command, it’s a value for RT’s $MailCommand variable. RT pipes
mail directly to $SendmailPath and the right thing happens more
often. read the comment, and make sure $SendmailPath and
$SendmailArguments are set correctly.

and as for qmail, the reason the Sender entry in the faq doesn’t
address qmail specifically, is cause qmail doesn’t insert sender
headers.

seph

PS: I updated the Sender header FAQ entries.

http://www.fsck.com/rtfm/article.html?id=105

It doesn’t really help if you’re using Qmail and don’t have
sendmailpipe
anywhere.

I thought this was in the docs, but my quick search doesn’t find it. I
guess it’s only been made clear on the mailing list. sendmailpipe
isn’t a command, it’s a value for RT’s $MailCommand variable. RT pipes
mail directly to $SendmailPath and the right thing happens more
often. read the comment, and make sure $SendmailPath and
$SendmailArguments are set correctly.

and as for qmail, the reason the Sender entry in the faq doesn’t
address qmail specifically, is cause qmail doesn’t insert sender
headers.

Thanks a lot for the clarification on sendmailpipe - it does indeed
remove the Sender: header with Qmail (which also confirms your second
paragraph).

Cheers,
Andy.

Andy:

It still doesn’t work for me with qmail. Which $SendmailArguments are you
using ??

It seems that my qmail does not add “Sender:” field when I send directly,
but it does add it when sent through the RT system.

my config.pm:
$MailCommand = ‘sendmailpipe’;
$SendmailArguments="-oi -t";
$SendmailPath = “/usr/sbin/sendmail”; (/usr/sbin/sendmail ->
/var/qmail/bin/sendmail)

thanks,
Ayal.

Andy Coates andy@bribed.net
Mon, 11 Nov 2002 10:15:03 -0000

Previous message: [rt-users] Problem with email FROM/SENDER fields
Next message: [rt-users] TimeWorked
Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]

http://www.fsck.com/rtfm/article.html?id=105

It doesn’t really help if you’re using Qmail and don’t have
sendmailpipe
anywhere.

I thought this was in the docs, but my quick search doesn’t find it. I
guess it’s only been made clear on the mailing list. sendmailpipe
isn’t a command, it’s a value for RT’s $MailCommand variable. RT pipes
mail directly to $SendmailPath and the right thing happens more
often. read the comment, and make sure $SendmailPath and
$SendmailArguments are set correctly.

and as for qmail, the reason the Sender entry in the faq doesn’t
address qmail specifically, is cause qmail doesn’t insert sender
headers.

Thanks a lot for the clarification on sendmailpipe - it does indeed
remove the Sender: header with Qmail (which also confirms your second
paragraph).

Cheers,
Andy.

Message: 13From: “Andy Coates” andy@bribed.net
To: “‘seph’” seph@commerceflow.com
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] Problem with email FROM/SENDER fields
Date: Sun, 10 Nov 2002 23:57:52 -0000

We would prefer to see the From field only and ommit the
"Sender" field at
all!

Can anyone suggest/help??

This is such a common question, that it’s answered in the FAQ and
mailing list archives. Why don’t you take a look there?

http://www.fsck.com/rtfm/article.html?id=105

It doesn’t really help if you’re using Qmail and don’t have sendmailpipe
anywhere.

I sometimes see addresses like queue.domain.com@domain.com, or the
common nobody@domain.com

Can’t find any info on the former email address, probably qmail setup
related. If anyone has seen it and knows how to set it up properly,
please let me know.

TIA,
Andy.

Andy:

It still doesn’t work for me with qmail. Which
$SendmailArguments are you
using ??

The same as you state below (except my -t is before -oi, but I doubt
that matters).

It seems that my qmail does not add “Sender:” field when I
send directly,
but it does add it when sent through the RT system.

I’m not sure what you mean by “directly” and “through” the RT system,
can you explain more? If you mean just sending an email from a shell,
then my Qmail never added them either. So it sounds like your changes
haven’t had an effect…

I tested by sending an email to the queue mail address, and waited for
the autoreply to come back (which before had the Sender: but not after
using sendmailpipe).

I doubt it makes a difference, but I did restart RT (had made some WebRT
code changes earlier, unrelated).

Andy.

It still doesn’t work for me with qmail. Which $SendmailArguments are you
using ??

It seems that my qmail does not add “Sender:” field when I send directly,
but it does add it when sent through the RT system.

my config.pm:
$MailCommand = ‘sendmailpipe’;
$SendmailArguments="-oi -t";
$SendmailPath = “/usr/sbin/sendmail”; (/usr/sbin/sendmail ->
/var/qmail/bin/sendmail)

You, ummm, are not using qmail.

Maybe you have a qmail server on the machine, but you also have
a sendmail binary, which is setting Sender:. You need to consult
the FAQ on how to tell RT to use qmail (I suppose there is one).

#include <std_disclaim.h> Lorens Kockum

my config.pm:
$MailCommand = ‘sendmailpipe’;
$SendmailArguments="-oi -t";
$SendmailPath = “/usr/sbin/sendmail”; (/usr/sbin/sendmail ->
/var/qmail/bin/sendmail)

You, ummm, are not using qmail.

why do you say that? most MTA (certainly true for qmail, postfix, and
exim) have binaries named “sendmail” to allow things to send mail
using them.

those configs look fine, I’m not sure where your sender header is
coming from. It’s probably worth restarting rt, but I’m not convinced
that would help.

seph