Problem with Apache 1.3 and RT 3.6.3 on OpenBSD 4.4 Stable

Hello RT users,

I’ve been trying to set up RT on an OpenBSD 4.4 Stable box, but I’m
having trouble configuring Apache to run RT with mod_perl.
What I’ve came up so far is that the web server is up and running, but
when the “PerlHandler RT::Mason” line is present in the
section, the directory is not accessible. And when I comment that line,
I get the page that says “You’re almost there!”. I’ve tried both
configurations ( rt.example.com and example.com/rt3) and the results are
the same.
So I’m looking for some help on this one. I’ll provide any configuration
file and other information needed. Just ask.

Best wishes,
Zhivko

Hello RT users,

I’ve been trying to set up RT on an OpenBSD 4.4 Stable box, but I’m
having trouble configuring Apache to run RT with mod_perl.
What I’ve came up so far is that the web server is up and running, but
when the “PerlHandler RT::Mason” line is present in the
section, the directory is not accessible. And when I comment that line,
I get the page that says “You’re almost there!”. I’ve tried both
configurations ( rt.example.com and example.com/rt3) and the results are
the same.
So I’m looking for some help on this one. I’ll provide any configuration
file and other information needed. Just ask.

What does the apache log say? Check if you have enabled mod_perl. Have
you installed RT from source or from a package? What is the RT version?

Best wishes,
Zhivko


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Thanks and Regards,
Terence Monteiro.

DeepRoot Linux,


Ph: +91 (80) 4089 0000
Getting GNU/Linux to work for you. Faster. Better. Today. Every way

There are no errors in the apache log. I ran the
/usr/local/sbin/mod_perl-enable script once. I installed RT from the
ports and the version is 3.6.3.
I should mention that I’m using mysql-5.0.51 and there are no errors
also. The web server is chrooted to /var/www.

Thanks
Zhivko

Terence Monteiro wrote:> On Thu, Jan 22, 2009 at 11:14:23AM +0200, Zhivko Tashev wrote:

Hello RT users,

I’ve been trying to set up RT on an OpenBSD 4.4 Stable box, but I’m
having trouble configuring Apache to run RT with mod_perl.
What I’ve came up so far is that the web server is up and running, but
when the “PerlHandler RT::Mason” line is present in the
section, the directory is not accessible. And when I comment that line,
I get the page that says “You’re almost there!”. I’ve tried both
configurations ( rt.example.com and example.com/rt3) and the results are
the same.
So I’m looking for some help on this one. I’ll provide any configuration
file and other information needed. Just ask.

What does the apache log say? Check if you have enabled mod_perl. Have
you installed RT from source or from a package? What is the RT version?

Best wishes,
Zhivko


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com