Problem using WebExternalAuth

Hi all.

I have currently installed the latest version of RT and am using it
WebExternalAuth enabled. Via the WebUI I can authenticate with no
problems.

Unfortunately the mailgate portion is no longer working. When you send
an email to the system an error is generated in our log files. The
error is as follows:

Oct 6 14:01:35 wolverine postfix/local[38884]: A414817CAB7: to=rt@wolverine.domain, relay=local, delay=0, status=deferred (temporary failure. Command output: An Error Occurred ================= 401 Authorization Required )

Can anyone help me correct this problem or give some ideas on where to
start looking? Information from RT_SiteConfig.pm ->

Authentication options

Set($WebExternalAuth , 1);
Set($WebFallbackToInternalAuth , undef);
Set($WebExternalAuto , 1);

Robert Hough (rch@acidpit.org)

I have currently installed the latest version of RT and am using it
WebExternalAuth enabled. Via the WebUI I can authenticate with no
problems.

Unfortunately the mailgate portion is no longer working. When you send
an email to the system an error is generated in our log files. The
error is as follows:

This has been covered several time in the list archives, and I’m
pretty sure is in the docs about WebExternalAuth.

the mailgateway posts to the NoAuth part of the site. Tell apache not
to require auth there.

seph

This has been covered several time in the list archives, and I’m
pretty sure is in the docs about WebExternalAuth.

Well, I just ran into this same problem a few days ago and couldn’t find
anything in the wiki about it. As Seph says, it has been covered in the
mailing list so I was able to figure it out with the help of google and a
local apache guru.

I was planning on writing something for the wiki once I’ve finished
experimenting with this new installation and migrated our ancient rt1 system
over to the new one. But if someone can point me to documentation in the
wiki that I missed then I won’t have to.

Thanks,

Duncan

Either make a user in the posting url in the aliases, or add some apache
satisfy to the httpd.conf.

alias: “|/opt/rt3/bin/rt-mailgate --queue Queue --action correspond --url
http://mailspecialuser:pass@your.rt.com/rt/

wg-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Rob Hough
Sent: Wednesday, October 06, 2004 3:18 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Problem using WebExternalAuth

Hi all.

I have currently installed the latest version of RT and am using it
WebExternalAuth enabled. Via the WebUI I can authenticate with no problems.

Unfortunately the mailgate portion is no longer working. When you send an
email to the system an error is generated in our log files. The error is as
follows:

Oct 6 14:01:35 wolverine postfix/local[38884]: A414817CAB7:
to=rt@wolverine.domain, relay=local, delay=0, status=deferred (temporary
failure. Command output: An Error Occurred ================= 401
Authorization Required )

Can anyone help me correct this problem or give some ideas on where to start
looking? Information from RT_SiteConfig.pm ->

Authentication options

Set($WebExternalAuth , 1);
Set($WebFallbackToInternalAuth , undef); Set($WebExternalAuto , 1);

Robert Hough (rch@acidpit.org)
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT wiki at http://wiki.bestpractical.com

This has been covered several time in the list archives, and I’m
pretty sure is in the docs about WebExternalAuth.

The list archives aren’t exactly the most search friendly archives I’ve
come across. I saw very little in regards to this in documentation I
have.

the mailgateway posts to the NoAuth part of the site. Tell apache not
to require auth there.

This helped a ton. Thanks.

Robert Hough (rch@acidpit.org)

The lists archives are very searchable if you know how to use
google. Here is an example google query:

site:lists.bestpractical.com AND ( inurl:2004 OR inurl:2003 )

-ToddOn Wed, Oct 06, 2004 at 06:25:29PM -0400, Rob Hough wrote:

On Wed, Oct 06, 2004, seph wrote:

This has been covered several time in the list archives, and I’m
pretty sure is in the docs about WebExternalAuth.

The list archives aren’t exactly the most search friendly archives I’ve
come across. I saw very little in regards to this in documentation I
have.

the mailgateway posts to the NoAuth part of the site. Tell apache not
to require auth there.

This helped a ton. Thanks.


Robert Hough (rch@acidpit.org)


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT wiki at http://wiki.bestpractical.com

This has been covered several time in the list archives, and I’m
pretty sure is in the docs about WebExternalAuth.

The list archives aren’t exactly the most search friendly archives I’ve
come across. I saw very little in regards to this in documentation I
have.

You are aware that the lists are mirrored through gmane.org, which has
a decent enough search engine?

Regards,
Harald