Problem using squelch_replies in rt 1.0.7

I’ve tried to figure out how to use the squelch_replies variable as best
I can by looking at the perl in:


…but I can’t seem to get it right. If I have an established ticket, and
I send e-mail to my RT mail alias with the correct [identifier #num], a
copy of that e-mail is sent to the “requestor” of the ticket. I don’t want
that to happen.

I’ve made the following changes (sorry these aren’t diffs):

elsif ($in_action eq ‘correspond’) {

  #If we're creating a new ticket
  if (!$serial_num) {
      # no auto-reply on ticket creation.
      $squelch_replies = 1;


#If we’re corresponding on an existing ticket
else {
#If the user isn’t a requestor, notify the requestor
#knock that off!
$squelch_replies = 1;

Am I missing something here, or is there something else I have to do in order
to disable the behavior I described above? The first modification I made
works; the second one has no noticeable effect.

Even if I comment out the following line:

$notify_requestor = (&rt::is_not_a_requestor($current_user,

…the mail still gets sent out.

This is very frustrating for me, as, to all appearances, I’m in the right
area to make this modification. Can anyone help?

Thanks much,