Problem installing RT::Extension::ArticleTemplates

I downloaded the package from and unzipped it to /tmp as root.

Then I tried to execute perl Makefie.PL and got this error:

root@ubuntu:/tmp/RT-Extension-ArticleTemplates-1.02# perl Makefile.PL
Can’t locate inc/Module/ in @INC (you may need to install the inc::Module::Install module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.30.0 /usr/local/share/perl/5.30.0 /usr/lib/x86_64-linux-gnu/perl5/5.30 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.30 /usr/share/perl/5.30 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at Makefile.PL line 1.
BEGIN failed–compilation aborted at Makefile.PL line 1.

Is there an ENV variable or path that needs to be set?

I tried installing (as root) the missing module on the command line:

perl -MCPAN -e install inc::Module::Install

but I still get the same error




I searched online and found I needed to install the following:

sudo apt-get install libmodule-install-perl


I loaded RT::Extension::ArticleTemplates. Then created a test article with this in it:

A test ticket {$Ticket->id}

When I tried a reply message and selected the article in the dropdown, the contents appeared but the interpolation of the {$Ticket->id} did not occur. It appeared as a straight text string.

Can someone tell me what I need to do to get it active?



An update is needed in RT 5 to re-enable ArticleTemplates and this will be fixed in the next release. For now, you can get a patch from here: