Porting over Asset Tracker info to a new instance

Greetings,

We’ve been using RT for several years and have a lot of data inside our old instance
(which is running RT 3.8.4 with the Asset Tracker module). My colleague Will has
done some good work with spinning up a new version (and with the help of the list
getting it integrated with our LDAP) which is running 4.2.8. Both the new and the
old are running off of postgres underneath.

Does anyone have any advice about how we can most efficiently migrate over our custom
asset types and asset information into the new version?

 thanks so much in advance,
       ~c

RT,

Little more info…

I have migrated\updated rt3 database to a fresh install of rt4.2.8. So I
can bounce back and forth between rt3 database and rt4 database with
$DatabaseName in RT_SiteConfig.pm.

rt4 database has “RT::Extension::Assets” plugin working however the
tables (rtxassets, rtxassets_id_seq, rtxcatalogs, rtxcatalogs_id_seq)
aren’t populated due to this being a fresh database.

old rt3 build\database on the other hand had "RTx::AssetTracker"
installed so it has the following tables\sequences that rt4 does not
(at_assets, at_assets_id_seq, at_ips, at_ips_id_seq, at_ports,
at_ports_id_seq, at_types, at_types_id_seq)

Installing AT3.0 has given me some issues with both rt3 and rt4
database. It appears it’s no longer supportd after rt4.0.0. We were
hoping you guys could shed some light on this for us. How can we migrate
our old Asset Tracker data into rt4 database or maybe get rt3 database
fully functional on 4.2.8.

Thanks,
Willie

William Clarke
ITS System Administrator
Bard College at Simon’s Rock
84 Alford Road
Great Barrington, MA 01230
(413) 528-7428 (voice)
(413) 528-7405 (fax)
wclarke@simons-rock.eduOn 10/13/2014 4:29 PM, charlie derr wrote:

Greetings,

We’ve been using RT for several years and have a lot of data inside our old instance
(which is running RT 3.8.4 with the Asset Tracker module). My colleague Will has
done some good work with spinning up a new version (and with the help of the list
getting it integrated with our LDAP) which is running 4.2.8. Both the new and the
old are running off of postgres underneath.

Does anyone have any advice about how we can most efficiently migrate over our custom
asset types and asset information into the new version?

  thanks so much in advance,
        ~c

RT,

Little more info…

I have migrated\updated rt3 database to a fresh install of rt4.2.8. So
I can bounce back and forth between rt3 database and rt4 database with
$DatabaseName in RT_SiteConfig.pm.

rt4 database has “RT::Extension::Assets” plugin working however the
tables (rtxassets, rtxassets_id_seq, rtxcatalogs, rtxcatalogs_id_seq)
aren’t populated due to this being a fresh database.

old rt3 build\database on the other hand had "RTx::AssetTracker"
installed so it has the following tables\sequences that rt4 does not
(at_assets, at_assets_id_seq, at_ips, at_ips_id_seq, at_ports,
at_ports_id_seq, at_types, at_types_id_seq)

My plan of attack:

  • generate for all assettypes a seperate rt_config.pm which maps the
    CustomFields to the right Catalogs
  • generate a search to export each assettype to a csv file
  • import using the RT::Assets import tool to import them maintaining the ids
  • write a small perl script to walk all tickets,articles,old_assets
    looking for links to old_assets and relink them to the new_assets.
  • drop the old tables.

In concept this should work I think but I’m open to better ways todo
this since its error prone and a lot of work.

Installing AT3.0 has given me some issues with both rt3 and rt4
database. It appears it’s no longer supportd after rt4.0.0. We were
hoping you guys could shed some light on this for us. How can we
migrate our old Asset Tracker data into rt4 database or maybe get rt3
database fully functional on 4.2.8.

Had the same problem and ‘fixed’ that in testing by looking at the error
and where it was generated. From memory it was about a CustomField type
of thing.

Joop

Joop,

Thank you very much for your reply. In case it’s of any help, here are
logs when I set database to rt3 and assign Plugin( “RTx::AssetTracker” );

Let me know if there is any other info you might need to give me some
direction on getting AT3.0 up and running. I’m also going to try to get
some usable tables dumped from postgresql just to try another approach…

Oct 15 10:59:15 rt4 RT: [21451] Use of inherited AUTOLOAD for non-method
RT::System::AddRights() is deprecated at
/opt/rt4/local/plugins/RTx-AssetTracker/lib/RTx/AssetTracker/Type.pm
line 114, line 751.

Oct 15 10:59:15 rt4 RT: [21451] Can’t locate object method "_Accessible"
via package “DeleteAsset” (perhaps you forgot to load “DeleteAsset”?) at
/usr/local/share/perl5/DBIx/SearchBuilder/Record.pm line 422,
line 751.
Compilation failed in require at
/opt/rt4/local/plugins/RTx-AssetTracker/lib/RTx/AssetTracker/Types.pm
line 70, line 751.
BEGIN failed–compilation aborted at
/opt/rt4/local/plugins/RTx-AssetTracker/lib/RTx/AssetTracker/Types.pm
line 70, line 751.
Compilation failed in require at
/opt/rt4/local/plugins/RTx-AssetTracker/lib/RTx/AssetTracker.pm line 56,
line 751.
BEGIN failed–compilation aborted at
/opt/rt4/local/plugins/RTx-AssetTracker/lib/RTx/AssetTracker.pm line 56,
line 751.
Compilation failed in require at /opt/rt4/sbin/…/lib/RT.pm line 729,
line 751.

William Clarke
ITS System Administrator
Bard College at Simon’s Rock
84 Alford Road
Great Barrington, MA 01230
(413) 528-7428 (voice)
(413) 528-7405 (fax)
wclarke@simons-rock.eduOn 10/16/2014 7:33 AM, Joop wrote:

On 15-10-2014 20:08, William Clarke wrote:

RT,

Little more info…

I have migrated\updated rt3 database to a fresh install of rt4.2.8.
So I can bounce back and forth between rt3 database and rt4 database
with $DatabaseName in RT_SiteConfig.pm.

rt4 database has “RT::Extension::Assets” plugin working however the
tables (rtxassets, rtxassets_id_seq, rtxcatalogs, rtxcatalogs_id_seq)
aren’t populated due to this being a fresh database.

old rt3 build\database on the other hand had "RTx::AssetTracker"
installed so it has the following tables\sequences that rt4 does not
(at_assets, at_assets_id_seq, at_ips, at_ips_id_seq, at_ports,
at_ports_id_seq, at_types, at_types_id_seq)

My plan of attack:

  • generate for all assettypes a seperate rt_config.pm which maps the
    CustomFields to the right Catalogs
  • generate a search to export each assettype to a csv file
  • import using the RT::Assets import tool to import them maintaining
    the ids
  • write a small perl script to walk all tickets,articles,old_assets
    looking for links to old_assets and relink them to the new_assets.
  • drop the old tables.

In concept this should work I think but I’m open to better ways todo
this since its error prone and a lot of work.

Installing AT3.0 has given me some issues with both rt3 and rt4
database. It appears it’s no longer supportd after rt4.0.0. We were
hoping you guys could shed some light on this for us. How can we
migrate our old Asset Tracker data into rt4 database or maybe get rt3
database fully functional on 4.2.8.

Had the same problem and ‘fixed’ that in testing by looking at the
error and where it was generated. From memory it was about a
CustomField type of thing.

Joop