Oracle XE DB initialize error

Date: Mon, 23 Jan 2006 09:42:14 +0100
From: “Goddard Lee” lee.goddard@easa.eu.int
Subject: RE: [rt-users] Oracle XE DB initialize error.
To: “Jesse Vincent” jesse@bestpractical.com, "Michael Methe"
mmethe@ci.keene.nh.us
Cc: rt-users@lists.bestpractical.com
Message-ID:
5E47282BEBB9CE4D9D2FF205A1E0BB88018467FB@bleriot.easa.local
Content-Type: text/plain; charset=“us-ascii”

I am installing RT on Fedora Core 3 which has Oracle 10g Express on
it. When I run:

make initialize-database

I get:

/usr/bin/perl //usr/local/rt/sbin/rt-setup-database --action init
–dba rt --prompt-for-dba-password Unable to load
DBIx::SearchBuilder
database handle for ‘Oracle’. Perhaps you’ve picked an invalid
database type or spelled it incorrectly.
Can’t load

'/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi/auto/D
BD/Oracle/

Oracle.so’ for module DBD::Oracle: libclntsh.so.10.1:
cannot open shared
object file: No such file or directory at
/usr/lib/perl5/5.8.5/i386-linux-thread-multi/DynaLoader.pm line 230.

Right there, that says you didn’t install DBD::Oracle
correctly. Download a fresh copy from search.cpan.org and run:

Ok, I have, just for the fun of it, installed Oracle XE on a Fedora
Core4 VMware virtual machine, taking a bit more time than I thought it
would take but I hate being beaten by a computer or software so here it
goes :wink:

First of all I installed FC4 selecting the Workstation option which
looked like it came close enough to having all the programs almost ready
to run Rt.
Then I installed Oracle XE which proved to be not so simple as I thought
and had read. Some problems were due to the Vmware stuff others to my
initial experience with FC4.
Then I unpacked RT-3.4.5 and ran ./configure with a bunch of options of
which --with-db-type=Oracle is relevant in this case
Then ran make fixdeps and got problems with DBD::Oracle.
So, tried it manually but no go, this is DBD::Oracle 1.16 btw
Looking at the error and googling a bit a found that 1.16 doesn’t
support XE because of the, again, new layout of the Oracle tree and more
specific the *.mk files that are needed for building DBD::Oracle.
Searching further I found DBD::Oracle-1.17RC5 which said had fixes for
XE. Downloaded and unpacked it and perl Makefile.PL;make;make test;make
install went OK.
Start RT, no go, error is missing Oracle.so’ for module DBD::Oracle: libclntsh.so.10.1:
Aha, this means that the user making DBD::ORACLE does have libclntsh.so
in its path but the Webserver doesn’t ===> LD_LBRARY_PATH
Setting LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$ORACLE_HOME/lib
does the trick and I can start RT. Now I’m getting a problem from
webmux.pl but using standalone_httpd works fine so probably something
about mod_perl/Apache2 and some missing module.

So summarizing Oracle XE and RT
Get DBD::Oracle-1.17rc5 or better and set your LD_LIBRARY_PATH
A succesfull ‘make test’ doesn’t mean that RT will run.

Still question, ask on the list,

Joop

Joop van de Wege JoopvandeWege@mococo.nl