OnCreateAutoReplyException

Hi there,

I am setting up my first RT system, and I ran into the scrip
http://wiki.bestpractical.com/view/OnCreateAutoReplyException . The
script looked like what I was looking for, so I’ve implemented it as
per the instructions on the wiki.

It does not work however. Emails in the @exceptionList array still
receive the auto reply.

I’ve tried to add the scrip both as a global one and to the queue,
both with the same result.

Can anyone provide me with assistance to debugging this?

Best regards

Allan Eising

Hi,

I’ve fixed the problem myself.
Please disregard this mail.

AllanOn Fri, Nov 7, 2008 at 1:40 PM, Allan Eising allan.eising@gmail.com wrote:

Hi there,

I am setting up my first RT system, and I ran into the scrip
http://wiki.bestpractical.com/view/OnCreateAutoReplyException . The
script looked like what I was looking for, so I’ve implemented it as
per the instructions on the wiki.

It does not work however. Emails in the @exceptionList array still
receive the auto reply.

I’ve tried to add the scrip both as a global one and to the queue,
both with the same result.

Can anyone provide me with assistance to debugging this?


Best regards

Allan Eising

Allan Eising wrote:

Hi,

I’ve fixed the problem myself.
Please disregard this mail.

Could you tell us what the problem/fix was for the benefit of others who
may want to use this scrip?
Kind Regards,

Mike Peachey, IT
Tel: +44 114 281 2655
Fax: +44 114 281 2951
Jennic Ltd, Furnival Street, Sheffield, S1 4QT, UK
Comp Reg No: 3191371 - Registered In England
http://www.jennic.com

Sure.

My problem was that I didn’t know that another scrip is taking care of
the auto replies. So I identified the script using the syslog logging

  • it’s quite simple to see, as it it writes the name of the scrip and
    then informs you that it sent out an email. Next I edited the scrip,
    and changed the condition to User Defined. FinalIy I pasted the scrip
    from the wiki in the Custom Condition box.

AllanOn Fri, Nov 7, 2008 at 2:13 PM, Mike Peachey mike.peachey@jennic.com wrote:

Allan Eising wrote:

Hi,

I’ve fixed the problem myself.
Please disregard this mail.

Could you tell us what the problem/fix was for the benefit of others who
may want to use this scrip?

Kind Regards,


Mike Peachey, IT
Tel: +44 114 281 2655
Fax: +44 114 281 2951
Jennic Ltd, Furnival Street, Sheffield, S1 4QT, UK
Comp Reg No: 3191371 - Registered In England
http://www.jennic.com