Norwegian characters in mail (response)

Hi,

I’ve been searching around the archives for an answer to this, but with
no luck.

I’m using RT3, and have a problem with norwegian characters being
encoded (?) wrong in mails to our customers. Both from templates and
from our own response.

One example is this:

–cut–

bare en test æøå

æ

Ã¥

Ø
–cut–

(Supposed to be æøå and ÆØÅ.)

However, in the web-interface, all characters show up like they should.

Also, the From:-header contains a rather strange address:
=?ISO-8859-1?B?IktyaXN0aWFuIFL4bm5pbmdlbiB2aWEgUlQiIDxub3Jka2FwcEBub3Jka2FwcC5uZXQ+?=@sm1.nordkapp.net

I couldn’t find this documentet anywhere either, is it supposed to be a
unique ID for the mail? Is it needed? It’s not very customer-friendly…

Can someone point me to some docs, patches or anything that might be of
help?

Kristian Rønningen krmm@nordkapp.net

Hi,

I’ve the same issue with german encoding in my email templates.

Any suggestions ?

Cheers,
geriOn Friday 25 April 2003 14:33, Kristian Rønningen wrote:

Hi,

I’ve been searching around the archives for an answer to this, but with
no luck.

I’m using RT3, and have a problem with norwegian characters being
encoded (?) wrong in mails to our customers. Both from templates and
from our own response.

One example is this:

–cut–

bare en test æøå

æ

Ã¥

Ø
–cut–

(Supposed to be æøå and ÆØÅ.)

However, in the web-interface, all characters show up like they should.

Also, the From:-header contains a rather strange address:
=?ISO-8859-1?B?IktyaXN0aWFuIFL4bm5pbmdlbiB2aWEgUlQiIDxub3Jka2FwcEBub3Jka2Fw
cC5uZXQ+?=@sm1.nordkapp.net

I couldn’t find this documentet anywhere either, is it supposed to be a
unique ID for the mail? Is it needed? It’s not very customer-friendly…

Can someone point me to some docs, patches or anything that might be of
help?

What is your EmailOutputEncoding setting in etc/RT_SiteConfig.pm?

VAJKÓ Péter Astron Informatikai Kft
Vahot u. 6.
tel: +36 1 481-2146 H-1115 Budapest
fax: +36 1 204-5395 Hungary

What is your EmailOutputEncoding setting in etc/RT_SiteConfig.pm?

@EmailInputEncodings = qw(iso-8859-1 utf-8 us-ascii)
unless(@EmailEncodings);

Set($EmailOutputEncoding , ‘iso-8859-1’);

Kristian R�nningen krmm@nordkapp.net

Kristian R�nningen wrote:

Set($EmailOutputEncoding , ‘iso-8859-1’);
That seems to be ok.

Do you create the tickets via the e-mail gateway? I had serious problems
with international characters, but then it was wrong on the web
interface too.

I think something is really broken in share/html/autohandler, it seems
to decode everything to UTF8 and this somehow prevents I18N to correctly
convert these mails.

I give it up.

VAJK� P�ter Astron Informatikai Kft
Vahot u. 6.
tel: +36 1 481-2146 H-1115 Budapest
fax: +36 1 204-5395 Hungary

Thanks to everyone,

i just found the right answer in the FAQ !

sorry for this newbie bothering
geriOn Friday 25 April 2003 15:29, Remy Chibois wrote:

Quoting Gerald Fehringer gerald.fehringer@openadvice.de:

I had the same issues with french encoding.
This was solved by setting “EmailInputEncodings” and “EmailOuputEncoding"
to “iso-8859-1”. Thus RT converts incoming mails from “iso-8859-1” to
"utf-8” and converts outgoing mails from “utf-8” to “iso-8859-1”.

It’s a known issue. We’re working on it.On Fri, Apr 25, 2003 at 03:25:26PM +0200, Vajk Pter wrote:

Kristian R�nningen wrote:

Set($EmailOutputEncoding , ‘iso-8859-1’);
That seems to be ok.

Do you create the tickets via the e-mail gateway? I had serious problems
with international characters, but then it was wrong on the web
interface too.

I think something is really broken in share/html/autohandler, it seems
to decode everything to UTF8 and this somehow prevents I18N to correctly
convert these mails.

I give it up.

VAJK� P�ter Astron Informatikai Kft
Vahot u. 6.
tel: +36 1 481-2146 H-1115 Budapest
fax: +36 1 204-5395 Hungary


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

i just found the right answer in the FAQ !

Do you have an exact URL for it? It seems we’re looking at two different
FAQ’s - I can’t find anything… :slight_smile:

Kristian R�nningen krmm@nordkapp.net