No root/password - first login problem

Hello.
I have a Fedora 7, Apache 2 and MySQL and RT3-3.6.3.
I installed RT via yum and followed
http://wiki.bestpractical.com/view/FedoraCore7InstallGuide. Then I
configured /etc/rt3/RT_SiteConfig.pm.
When I try http:///rt3 and the browser shows my login page
and I can’t do the first login with root/password.
I did the init-drop-init database command lots of times, but still with
this problem. This is the last try with database comand before I write
to this list:

[root@xxx rt3]# /usr/sbin/rt-setup-database --action init --dba root
–prompt-for-dba-password
In order to create or update your RT database,this script needs to
connect to your mysql instance on localhost as root.
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password:
Now creating a database for RT.
Creating mysql database rt3.
Now populating database schema.
Creating database schema.
readline() on closed filehandle SCHEMA_LOCAL at
/usr/sbin/rt-setup-database line 192.
Done setting up database schema.
Now inserting database ACLs
Done setting up database ACLs.
Now inserting RT core system objects
Checking for existing system user…not found. This appears to be a new
installation.
Creating system user…done.
Now inserting RT data
Creating Superuser ACL…done.
Creating groups…3.4.5.6.7.8.9.done.
Creating users…10.(Error: Password needs to be at least 666666
characters long)0.done.
Creating queues…1.2.done.
Creating ACL…2.[Tue Mar 10 16:11:49 2009] [crit]: 1
(/usr/lib/perl5/vendor_perl/5.8.8/RT/ACE_Overlay.pm:907)
[Tue Mar 10 16:11:49 2009] [crit]: Can’t load a principal for id
(/usr/lib/perl5/vendor_perl/5.8.8/RT/ACE_Overlay.pm:908)
Principal not found…done.
Creating ScripActions…1.2.3.4.5.6.7.8.9.10.11.12.13.14.15.16.17.done.
Creating ScripConditions…1.2.3.4.5.6.7.8.9.10.done.
Creating templates…1.2.3.4.5.6.7.8.9.10.11.12.done.
Creating scrips…1.2.3.4.5.6.7.8.9.10.11.12.13.14.done.
Creating predefined searches…1.2.3.done.
Done setting up database content.

I already tried the MySQL’s root user and password in RT_SiteConfig.pm,
but nothing new happened.

Thanks in advance for any help!

juliano.vcf (385 Bytes)

Hello again.
I updated my system, now it’s Fedora Core 10, Apache 2 and RT 3.8.2.
I tried the root/password in the login page and I still get “wrong user
name or password”.

Here is some issues in the ini command for the database:
[root@jjj ~]# /usr/sbin/rt-setup-database --action init --dba root
–prompt-for-dba-password
In order to create or update your RT database, this script needs to
connect to your mysql instance on localhost as root
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password:
Working with:
Type: mysql
Host: localhost
Name: rt3
User: rt3
DBA: root
Now creating a mysql database rt3 for RT.
Done.
Now populating database schema.
Done.
Now inserting database ACLs
Granting access to rt3@‘localhost’ on rt3.
Done.
Now inserting RT core system objects
Done.
Now inserting data
[Thu Mar 19 11:19:39 2009] [error]: Password needs to be at least 666666
characters long (/usr/lib/perl5/vendor_perl/5.10.0/RT/Handle.pm:796)
[Thu Mar 19 11:19:39 2009] [error]: Couldn’t get principal for not
loaded object (/usr/lib/perl5/vendor_perl/5.10.0/RT/User_Overlay.pm:1154)
[Thu Mar 19 11:19:39 2009] [crit]: Can’t call method “GrantRight” on an
undefined value at /usr/lib/perl5/vendor_perl/5.10.0/RT/Handle.pm line
910. (/usr/lib/perl5/vendor_perl/5.10.0/RT.pm:377)
Can’t call method “GrantRight” on an undefined value at
/usr/lib/perl5/vendor_perl/5.10.0/RT/Handle.pm line 910.

Regards,
Juliano

juliano.vcf (385 Bytes)

Juliano Medeiros Coimbra wrote:

[Thu Mar 19 11:19:39 2009] [error]: Password needs to be at least 666666
characters long (/usr/lib/perl5/vendor_perl/5.10.0/RT/Handle.pm:796)

Password needs to be HOW long?!

Have you checked your MinPasswordLength in RT_SiteConfig.pm and/or
SiteConfig.pm (if you’ve been silly enough to edit that)?

– ============================
Tom Lahti
BIT Statement LLC

(425)251-0833 x 117
http://www.bitstatement.net/
– ============================

I have Ubuntu 8.10 with Request Tracker 3.6. I have installed it with no
errors. When I login with root and the password set in the
RT-Site_Config.pm. I receive the error “Your username or password is
incorrect.” I have verified that I am typing it correctly and that it is
correct in the config file. Thanks in advance for any help.

-Thanks

Tom Swart

Christa Construction, LLC.

O- 585-545-6562

That is the database password, not RT’s. IIRC the root password for the
WebUI is password by default.

Swart, Tom wrote:

I have Ubuntu 8.10 with Request Tracker 3.6. I have installed it with
no errors. When I login with root and the password set in the
RT-Site_Config.pm. I receive the error �Your username or password is
incorrect.� I have verified that I am typing it correctly and that it
is correct in the config file. Thanks in advance for any help.

-Thanks

Tom Swart

Christa Construction, LLC.

O- 585-545-6562



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Drew Barnes
Applications Analyst
Network Resources Department
Raymond Walters College
University of Cincinnati