No replies via email


#1

Hi,

I’m running the latest RT 1.3.79, and when I click to reply to a ticket,
the requestor is not receiving any email. As a matter fact, it looks like
there’s no email going out at all, as my syslog’s that report mail traffic
don’t show anything. So basically RT is not calling sendmail correctly, or
at all. I can’t find any logging for RT that indicates a problem.

Anyone have any ideas what I may have wrong?

Thx
-Robert


#2

You have to set up scrips for the queue.
Try “OnCorrespond” “NotifyRequestor” using template “Correspondance”

-Feargal.

_/_/_/ _/_/_/  _/_/_/  Feargal Reilly,

_/ _/ / / Systems Administrator,
/ / //// The Communications Interactive Agency.
//
/ //
/ _/ _/ Phone: +353-86-8732249.

 Hi,
 
 I'm running the latest RT 1.3.79, and when I click to reply to a ticket,
 the requestor is not receiving any email. As a matter fact, it looks like
 there's no email going out at all, as my syslog's that report mail traffic
 don't show anything. So basically RT is not calling sendmail correctly, or
 at all. I can't find any logging for RT that indicates a problem.
 
 Anyone have any ideas what I may have wrong?
 
 Thx
 -Robert
 
 rt-users mailing list
 rt-users@lists.fsck.com
 http://lists.fsck.com/mailman/listinfo/rt-users

#3

You have to set up scrips for the queue.
Try “OnCorrespond” “NotifyRequestor” using template “Correspondance”

Thanks! That works. However, the reply-to and from address on the email from
WebRT are “rt@localhost” instead of what I have in config.pm:

#This is the default address that will be listed in
#From: and Reply-To: headers of mail tracked by RT unless overridden
#by a queue specific address

#$CorrespondAddress=“RT::CorrespondAddress.not.set”;
$CorrespondAddress="rt@arizona.mxim.com";

#$CommentAddress=“RT::CommentAddress.not.set”;
$CommentAddress="rt-comment@arizona.mxim.com";

Why is this? Does anyone know how to fix that?

Thanks.
-Robert


#4

Apparently the email settings in the config.pm do not affect the from/reply-to
addresses for the queues. They are stored in the database under the "Basic"
settings for each queue. I just updated them to be correct, and all is well.

Sorry for the stupid question.

-Robert

Jesse - Maybe the default email addresses for the queues should default
to what is in the config.pm???On Thu, May 24, 2001 at 09:12:37AM -0700, Robert Shaw wrote:

On Thu, May 24, 2001 at 12:12:15AM +0000, Feargal Reilly wrote:

You have to set up scrips for the queue.
Try “OnCorrespond” “NotifyRequestor” using template “Correspondance”

Thanks! That works. However, the reply-to and from address on the email from
WebRT are “rt@localhost” instead of what I have in config.pm:

#This is the default address that will be listed in
#From: and Reply-To: headers of mail tracked by RT unless overridden
#by a queue specific address

#$CorrespondAddress=“RT::CorrespondAddress.not.set”;
$CorrespondAddress="rt@arizona.mxim.com";

#$CommentAddress=“RT::CommentAddress.not.set”;
$CommentAddress="rt-comment@arizona.mxim.com";

Why is this? Does anyone know how to fix that?