No recipients found and erroneously blank actor fields

When I have a ticket up and hit reply, the ‘update type’ field defaults
to ‘reply to requestors’ which seems right. The section that says ‘This
message will be sent to’ has no addresses in it. That seems wrong.
Shouldn’t that pull from the ticket’s requestors field? How can any
record not have a requestor?

This has serious repercussions. Apart from anything else it means that
no recipients are found for any outgoing messages, hence no emails are
sent.

The Actor has superuser rights, so it can’t be a permissions problem,
can it?

Any suggestions gratefully received.

RT-3.4.1, mod_perl, DBIx::SearchBuilder 1.22, apache 1.3.33, mysql 4.1.7
on SuSE 9.0

Duncan Hutty
System Administrator, ECE
Carnegie Mellon University

Please use informative subject lines

Any suggestions gratefully received.

RT logs a lot of information at various levels (debug, info, critical).
If something is wrong, you will find evidence of it in your system log
files. You might have to look through several log files (maybe
simultaneously), but you should be able to trace your actions in RT.
Error messages are icing on the cake.

Russell Mosemann, Ph.D. * Computing Services * Concordia University, Nebraska
"If you smell an odorless gas, it’s probably carbon monoxide."

  • student answer on a chemistry test

At Friday 3/4/2005 03:21 PM, Duncan Hutty wrote:

When I have a ticket up and hit reply, the ‘update type’ field defaults to
’reply to requestors’ which seems right. The section that says ‘This
message will be sent to’ has no addresses in it. That seems wrong.
Shouldn’t that pull from the ticket’s requestors field? How can any record
not have a requestor?

This has serious repercussions. Apart from anything else it means that
no recipients are found for any outgoing messages, hence no emails are sent.

The Actor has superuser rights, so it can’t be a permissions problem, can it?

Any suggestions gratefully received.

I have a couple of guesses…

  1. The requestor is the same person as the one doing the update and
    $NotifyActor is set to 0 in the config.
  2. There are no scrips configured to send mail to the requestor for a
    correspondence.

Steve

I just solved this problem on my systems; it was a combination of things, any
one of which could have caused this behavior.

I had changed the ‘Requestors’ field in the form to be ‘DISABLED’, so that
users couldn’t put in an invalid address. (I changed it to ‘TYPE=hidden’ to
fix it.)

Using ‘WebExternalAuto’ to create accounts did/does not create their email
address; no email, no requestors.

Perfection is just a word I use occasionally with mustard.

Atom Powers
Systems Administrator
Pyramid Breweries Inc.
206.682.8322 x251-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Duncan Hutty
Sent: Friday, March 04, 2005 12:21 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] No recipients found and erroneously blank actor fields

When I have a ticket up and hit reply, the ‘update type’ field defaults to
’reply to requestors’ which seems right. The section that says ‘This message
will be sent to’ has no addresses in it. That seems wrong.
Shouldn’t that pull from the ticket’s requestors field? How can any record
not have a requestor?

This has serious repercussions. Apart from anything else it means that
no recipients are found for any outgoing messages, hence no emails are
sent.

The Actor has superuser rights, so it can’t be a permissions problem, can it?

Any suggestions gratefully received.

RT-3.4.1, mod_perl, DBIx::SearchBuilder 1.22, apache 1.3.33, mysql 4.1.7 on
SuSE 9.0

Duncan Hutty
System Administrator, ECE
Carnegie Mellon University

Please use informative subject lines
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

RT Administrator and Developer training is coming to your town soon! (Boston,
San Francisco, Austin, Sydney) Contact training@bestpractical.com for
details.

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

  1. The requestor is the same person as the one doing the update and
    $NotifyActor is set to 0 in the config.
    Thought of that. I verified the same behaviour with other users.
  1. There are no scrips configured to send mail to the requestor for a
    correspondence.

Default scrips, including “On Correspond Notify Requestors and Ccs with
template Correspondence”

I have done a little more tracking.
When new accounts are generated as a response to incoming email, the new
username in RT is the email address of the requestor. The email address
of the new account is left blank, even if the new account is generated
from an email.

When I manually completetd the email address field, I found that an
outgoing message was generated. woo!

However this raises 2 questions:

  1. As an actor replies to a ticket’s requestor, should the section ‘This
    message will be sent to’ have usernames or email addresses?

and more importantly:

  1. Is there a config setting to allow the email address field for a new
    account to be generated from the (correctly parsed) email address of the
    requestor’s message? Or should I customise RT using the ordinary overlay
    method? If so, then where should I start?

Duncan Hutty
System Administrator, ECE
Carnegie Mellon University

Please use informative subject lines

  1. As an actor replies to a ticket’s requestor, should the section ‘This
    message will be sent to’ have usernames or email addresses?

Usernames (unless the username is the email address).

  1. Is there a config setting to allow the email address field for a new
    account to be generated from the (correctly parsed) email address of the
    requestor’s message? Or should I customise RT using the ordinary overlay
    method? If so, then where should I start?

Non-privileged (a.k.a., disabled) accounts should automatically be created
from a new email message. It should fill in 3 pieces of information, the
user name, the real name and the email address. All 3 become the email
address if the real name cannot be determined from the email address. I
thought this behavior was the default. I scanned RT_Config.pm, and I
didn’t see anything offhand that seemed to apply.

Russell Mosemann, Ph.D. * Computing Services * Concordia University, Nebraska
"There’s never time to do it once, but there’s always time to do it twice."

I just solved this problem on my systems; it was a combination of things, any
one of which could have caused this behavior.

I had changed the ‘Requestors’ field in the form to be ‘DISABLED’, so that
users couldn’t put in an invalid address. (I changed it to ‘TYPE=hidden’ to
fix it.)

Using ‘WebExternalAuto’ to create accounts did/does not create their email
address; no email, no requestors.

The problem was that a couple of mail generated accounts did not contain
the email address from which they were sent (the EmailAddress was blank)
because there were already RT user accounts that contained their email
addresses.

Therefore the solution was to manually modify the rt3.Users table such
that all accounts have EmailAddress values.

It raises a couple of questions of course (why email uniqueness? and why
couldn’t I see all accounts under Configuration>Users?) but I will
address these in other posts.

Thanks, all, for your suggestions.

Duncan Hutty
System Administrator, ECE
Carnegie Mellon University

Please use informative subject lines