No more confirmation mails, 4.4.2


#1

Hi,

I’ve just successfully (no errors) upgraded rt4 to version 4.4.2, but now the system no longer sends confirmation mails when users create a ticket by sending mail to the support address.

The tickets are properly created, and any further actions are confirmed.

The logs are telling me why no mail is being sent (no recipients), but I can’t find the proper source to figure out why the recipient (the requestor in this case) is not being set.

log:
#93/926 - Scrip 7 On Create Autoreply To Requestors (/usr/local/web/rt4.4.2/sbin/…/lib/RT/Action/SendEmail.pm:285)
No recipients found. Not sending. (/usr/local/web/rt4.4.2/sbin/…/lib/RT/Interface/Email.pm:832)

The template is ok and parsed properly.
Dumping the mime structure, I can confirm that no ‘To’ header is set. But I don’t know why. This should be set with the requestor’s email address (which is known at that time).

As mentioned, this used to work just fine in the earlier versions of rt4 (4.2.8 and 4.4.1).

Any help greatly appreciated!
Robert


#2

Did some more research.

But first, mails are being resent by exchange to the request tracker system (policies forbid direct connections). As we recently had an update of the exchange software (that’s when things broke), I suspect (can no longer prove) that exchange now sends the ‘Auto-Submitted: auto-generated’ header, which in return causes RT4 to not reply. Further more, RT4 now flags the mail for squelching: ‘RT-Squelch-Replies-To: …’ is set.

I’ve set ‘$RedistributeAutoGeneratedMessages’ to 1, but RT4 still flags it for squelching.
Someone mentioned I’d have to customise ‘CheckForAutoGenerated’ - but I’d rather not. Any other solutions?


#3

OK, so it is the forwarding/redirecting by exchange. Unfortunately, I can’t use the Blind Copy trick, as I don’t have that option in the rules settings.