(newbie) Apache::Request --- troubles installing

FreeBSD 4.8 stable
apache 1.3.27
mod_perl 1.27

trying to install rt for the first time. having errors installing the
Apache::Request perl module. any clues please?

command keyed:

perl sbin/rt-test-dependencies --with-mysql --with-modperl1 --install

output:
— snip —

MASON dependencies:
Params::Validate 0.02…found
Cache::Cache …found
Exception::Class …MISSING
CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
Database was generated on Mon, 07 Jul 2003 09:44:36 GMT
Exception::Class is up to date.
HTML::Mason 1.16…MISSING
HTML::Mason is up to date.
MLDBM …found
Errno …found
FreezeThaw …found
Digest::MD5 …found
CGI::Cookie 1.20…found
Storable …found
Apache::Session 1.53…found
MAILGATE dependencies:
HTML::TreeBuilder …found
HTML::FormatText …found
Getopt::Long …found
LWP::UserAgent …found
MODPERL1 dependencies:
CGI …found
Apache::Request …MISSING
Running install for module Apache::Request
Running make for J/JO/JOESUF/libapreq-1.2.tar.gz
Checksum for /root/.cpan/sources/authors/id/J/JO/JOESUF/libapreq-1.2.tar.gz ok
Scanning cache /root/.cpan/build for sizes
libapreq-1.2/
libapreq-1.2/c/
libapreq-1.2/c/apache_request.c
libapreq-1.2/c/apache_request.h
libapreq-1.2/c/Makefile.noperl
libapreq-1.2/c/Makefile.PL
libapreq-1.2/c/Makefile.am
libapreq-1.2/c/Makefile.in
libapreq-1.2/c/apache_cookie.c
libapreq-1.2/c/apache_cookie.h
libapreq-1.2/c/apache_multipart_buffer.c
libapreq-1.2/c/apache_multipart_buffer.h
libapreq-1.2/c/.cvsignore
libapreq-1.2/t/
libapreq-1.2/t/apreq/
libapreq-1.2/t/apreq/inherit.t
libapreq-1.2/t/apreq/big_input.t
libapreq-1.2/t/apreq/cookie.t
libapreq-1.2/t/apreq/request.t
libapreq-1.2/t/response/
libapreq-1.2/t/response/TestApReq/
libapreq-1.2/t/response/TestApReq/cookie.pm
libapreq-1.2/t/response/TestApReq/request.pm
libapreq-1.2/t/response/TestApReq/inherit.pm
libapreq-1.2/t/response/TestApReq/big_input.pm
libapreq-1.2/t/TEST.PL
libapreq-1.2/t/request-inherit.pl
libapreq-1.2/eg/
libapreq-1.2/eg/c/
libapreq-1.2/eg/c/testapreq/
libapreq-1.2/eg/c/testapreq/Makefile.apxs
libapreq-1.2/eg/c/testapreq/Makefile.tmpl
libapreq-1.2/eg/c/testapreq/mod_testapreq.module
libapreq-1.2/eg/c/testapreq/mod_testapreq.c
libapreq-1.2/eg/perl/
libapreq-1.2/eg/perl/cookie.pl
libapreq-1.2/eg/perl/file_upload.pl
libapreq-1.2/lib/
libapreq-1.2/lib/Apache/
libapreq-1.2/lib/Apache/libapreq.pm
libapreq-1.2/autom4te-2.53.cache/
libapreq-1.2/autom4te-2.53.cache/requests
libapreq-1.2/autom4te-2.53.cache/output.0
libapreq-1.2/autom4te-2.53.cache/traces.0
libapreq-1.2/ToDo
libapreq-1.2/Cookie/
libapreq-1.2/Cookie/Cookie.pm
libapreq-1.2/Cookie/Cookie.xs
libapreq-1.2/Cookie/Makefile.PL
libapreq-1.2/Cookie/.cvsignore
libapreq-1.2/depcomp
libapreq-1.2/LICENSE
libapreq-1.2/aclocal.m4
libapreq-1.2/README
libapreq-1.2/ltmain.sh
libapreq-1.2/configure
libapreq-1.2/BUILD.sh
libapreq-1.2/Changes
libapreq-1.2/configure.in
libapreq-1.2/config.guess
libapreq-1.2/install-sh
libapreq-1.2/config.sub
libapreq-1.2/missing
libapreq-1.2/Request/
libapreq-1.2/Request/Request.pm
libapreq-1.2/Request/Request.xs
libapreq-1.2/Request/Makefile.PL
libapreq-1.2/Request/.cvsignore
libapreq-1.2/mkinstalldirs
libapreq-1.2/Makefile.PL
libapreq-1.2/Makefile.am
libapreq-1.2/Makefile.in
libapreq-1.2/typemap
libapreq-1.2/acinclude.m4
libapreq-1.2/libapreq.pod
libapreq-1.2/patches/
libapreq-1.2/patches/README
libapreq-1.2/patches/apache-1.3+apreq.patch
libapreq-1.2/INSTALL
libapreq-1.2/.cvsignore
libapreq-1.2/INSTALL.MacOSX
libapreq-1.2/CREDITS
libapreq-1.2/MANIFEST
Removing previously used /root/.cpan/build/libapreq-1.2

CPAN.pm: Going to build J/JO/JOESUF/libapreq-1.2.tar.gz

Running make test
Make had some problems, maybe interrupted? Won’t test
Running make install
Make had some problems, maybe interrupted? Won’t install
Apache::DBI …found
CLI dependencies:
Getopt::Long 2.24…found
CORE dependencies:
Digest::MD5 …found
DBI 1.18…found
Test::Inline …found
Class::ReturnValue 0.40…MISSING
Class::ReturnValue is up to date.
DBIx::SearchBuilder 0.80…found
Text::Template …found
File::Spec 0.8…found
HTML::Entities …found
Net::Domain …found
Log::Dispatch 2.0…found
Locale::Maketext 1.04…found
Locale::Maketext::Lexicon 0.25…found
Locale::Maketext::Fuzzy …found
MIME::Entity 5.108…found
Mail::Mailer 1.57…found
Net::SMTP …found
Text::Wrapper …found
Time::ParseDate …found
File::Temp …found
Term::ReadKey …found
Text::Autoformat …found
Text::Quoted …found
DEV dependencies:
Regexp::Common …found
Time::HiRes …found
Test::Inline …found
WWW::Mechanize …found
MYSQL dependencies:
DBD::mysql 2.1018…found

— snip ----

  • noah

Hi

upgrade FreeBSD ports /usr/ports

And here is easy help:

http://lukasmaly.net/RT3-install_en.txt

malylOn Mon, 7 Jul 2003, admin wrote:

Date: Mon, 7 Jul 2003 13:02:42 -0800
From: admin admin2@enabled.com
To: rt-users@fsck.com
Subject: [rt-users] (newbie) Apache::Request — troubles installing

FreeBSD 4.8 stable
apache 1.3.27
mod_perl 1.27

trying to install rt for the first time. having errors installing the
Apache::Request perl module. any clues please?

command keyed:

perl sbin/rt-test-dependencies --with-mysql --with-modperl1 --install

output:
— snip —

MASON dependencies:
Params::Validate 0.02…found
Cache::Cache …found
Exception::Class …MISSING
CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
Database was generated on Mon, 07 Jul 2003 09:44:36 GMT
Exception::Class is up to date.
HTML::Mason 1.16…MISSING
HTML::Mason is up to date.
MLDBM …found
Errno …found
FreezeThaw …found
Digest::MD5 …found
CGI::Cookie 1.20…found
Storable …found
Apache::Session 1.53…found
MAILGATE dependencies:
HTML::TreeBuilder …found
HTML::FormatText …found
Getopt::Long …found
LWP::UserAgent …found
MODPERL1 dependencies:
CGI …found
Apache::Request …MISSING
Running install for module Apache::Request
Running make for J/JO/JOESUF/libapreq-1.2.tar.gz
Checksum for /root/.cpan/sources/authors/id/J/JO/JOESUF/libapreq-1.2.tar.gz ok
Scanning cache /root/.cpan/build for sizes
libapreq-1.2/
libapreq-1.2/c/
libapreq-1.2/c/apache_request.c
libapreq-1.2/c/apache_request.h
libapreq-1.2/c/Makefile.noperl
libapreq-1.2/c/Makefile.PL
libapreq-1.2/c/Makefile.am
libapreq-1.2/c/Makefile.in
libapreq-1.2/c/apache_cookie.c
libapreq-1.2/c/apache_cookie.h
libapreq-1.2/c/apache_multipart_buffer.c
libapreq-1.2/c/apache_multipart_buffer.h
libapreq-1.2/c/.cvsignore
libapreq-1.2/t/
libapreq-1.2/t/apreq/
libapreq-1.2/t/apreq/inherit.t
libapreq-1.2/t/apreq/big_input.t
libapreq-1.2/t/apreq/cookie.t
libapreq-1.2/t/apreq/request.t
libapreq-1.2/t/response/
libapreq-1.2/t/response/TestApReq/
libapreq-1.2/t/response/TestApReq/cookie.pm
libapreq-1.2/t/response/TestApReq/request.pm
libapreq-1.2/t/response/TestApReq/inherit.pm
libapreq-1.2/t/response/TestApReq/big_input.pm
libapreq-1.2/t/TEST.PL
libapreq-1.2/t/request-inherit.pl
libapreq-1.2/eg/
libapreq-1.2/eg/c/
libapreq-1.2/eg/c/testapreq/
libapreq-1.2/eg/c/testapreq/Makefile.apxs
libapreq-1.2/eg/c/testapreq/Makefile.tmpl
libapreq-1.2/eg/c/testapreq/mod_testapreq.module
libapreq-1.2/eg/c/testapreq/mod_testapreq.c
libapreq-1.2/eg/perl/
libapreq-1.2/eg/perl/cookie.pl
libapreq-1.2/eg/perl/file_upload.pl
libapreq-1.2/lib/
libapreq-1.2/lib/Apache/
libapreq-1.2/lib/Apache/libapreq.pm
libapreq-1.2/autom4te-2.53.cache/
libapreq-1.2/autom4te-2.53.cache/requests
libapreq-1.2/autom4te-2.53.cache/output.0
libapreq-1.2/autom4te-2.53.cache/traces.0
libapreq-1.2/ToDo
libapreq-1.2/Cookie/
libapreq-1.2/Cookie/Cookie.pm
libapreq-1.2/Cookie/Cookie.xs
libapreq-1.2/Cookie/Makefile.PL
libapreq-1.2/Cookie/.cvsignore
libapreq-1.2/depcomp
libapreq-1.2/LICENSE
libapreq-1.2/aclocal.m4
libapreq-1.2/README
libapreq-1.2/ltmain.sh
libapreq-1.2/configure
libapreq-1.2/BUILD.sh
libapreq-1.2/Changes
libapreq-1.2/configure.in
libapreq-1.2/config.guess
libapreq-1.2/install-sh
libapreq-1.2/config.sub
libapreq-1.2/missing
libapreq-1.2/Request/
libapreq-1.2/Request/Request.pm
libapreq-1.2/Request/Request.xs
libapreq-1.2/Request/Makefile.PL
libapreq-1.2/Request/.cvsignore
libapreq-1.2/mkinstalldirs
libapreq-1.2/Makefile.PL
libapreq-1.2/Makefile.am
libapreq-1.2/Makefile.in
libapreq-1.2/typemap
libapreq-1.2/acinclude.m4
libapreq-1.2/libapreq.pod
libapreq-1.2/patches/
libapreq-1.2/patches/README
libapreq-1.2/patches/apache-1.3+apreq.patch
libapreq-1.2/INSTALL
libapreq-1.2/.cvsignore
libapreq-1.2/INSTALL.MacOSX
libapreq-1.2/CREDITS
libapreq-1.2/MANIFEST
Removing previously used /root/.cpan/build/libapreq-1.2

CPAN.pm: Going to build J/JO/JOESUF/libapreq-1.2.tar.gz

Running make test
Make had some problems, maybe interrupted? Won’t test
Running make install
Make had some problems, maybe interrupted? Won’t install
Apache::DBI …found
CLI dependencies:
Getopt::Long 2.24…found
CORE dependencies:
Digest::MD5 …found
DBI 1.18…found
Test::Inline …found
Class::ReturnValue 0.40…MISSING
Class::ReturnValue is up to date.
DBIx::SearchBuilder 0.80…found
Text::Template …found
File::Spec 0.8…found
HTML::Entities …found
Net::Domain …found
Log::Dispatch 2.0…found
Locale::Maketext 1.04…found
Locale::Maketext::Lexicon 0.25…found
Locale::Maketext::Fuzzy …found
MIME::Entity 5.108…found
Mail::Mailer 1.57…found
Net::SMTP …found
Text::Wrapper …found
Time::ParseDate …found
File::Temp …found
Term::ReadKey …found
Text::Autoformat …found
Text::Quoted …found
DEV dependencies:
Regexp::Common …found
Time::HiRes …found
Test::Inline …found
WWW::Mechanize …found
MYSQL dependencies:
DBD::mysql 2.1018…found

— snip ----

  • noah

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Hi

upgrade FreeBSD ports /usr/ports

And here is easy help:

http://lukasmaly.net/RT3-install_en.txt

okay we are now trying to install from /usr/ports/www and arriving at the
following issue:

root@hurricane# perl -v [/usr/ports/www/rt3]

This is perl, v5.8.0 built for i386-freebsd

Copyright 1987-2002, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using man perl' orperldoc perl’. If you have access to the
Internet, point your browser at http://www.perl.com/, the Perl Home Page.

root@hurricane# make install clean [/usr/ports/www/rt3]
===> rt3-3.0.3 This program only support perl 5.6.1 or above.

Hi

upgrade FreeBSD ports /usr/ports

And here is easy help:

http://lukasmaly.net/RT3-install_en.txt

Anybody explain to me, since I have perl 5.8 loaded, why I cant get rt3
installed from /usr/ports ?

root@hurricane# perl -v [/usr/ports/www/rt3]

This is perl, v5.8.0 built for i386-freebsd

Copyright 1987-2002, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using man perl' orperldoc perl’. If you have access to the
Internet, point your browser at http://www.perl.com/, the Perl Home Page.

root@hurricane# make install clean [/usr/ports/www/rt3]
===> rt3-3.0.3 This program only support perl 5.6.1 or above.

Hi

upgrade FreeBSD ports /usr/ports

And here is easy help:

http://lukasmaly.net/RT3-install_en.txt

Anybody explain to me, since I have perl 5.8 loaded, why I cant get rt3
installed from /usr/ports ?

What is your output from
/usr/ports/www/rt3# make -V PERL_LEVEL

?

Did you run ‘use.perl port’ after installing perl 5.8?

Hi

upgrade FreeBSD ports /usr/ports

And here is easy help:

http://lukasmaly.net/RT3-install_en.txt

Anybody explain to me, since I have perl 5.8 loaded, why I cant get rt3
installed from /usr/ports ?

What is your output from
/usr/ports/www/rt3# make -V PERL_LEVEL

[/usr/ports/www/rt3]
root@hurricane# make -V PERL_LEVEL
0

?

Did you run ‘use.perl port’ after installing perl 5.8?

no how do I do this?

  • Noah

root@hurricane# perl -v
[/usr/ports/www/rt3]

This is perl, v5.8.0 built for i386-freebsd

Copyright 1987-2002, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using man perl' orperldoc perl’. If you have access to the
Internet, point your browser at http://www.perl.com/, the Perl Home Page.

root@hurricane# make install clean
[/usr/ports/www/rt3]

===> rt3-3.0.3 This program only support perl 5.6.1 or above.

malyl

Date: Mon, 7 Jul 2003 13:02:42 -0800
From: admin admin2@enabled.com
To: rt-users@fsck.com
Subject: [rt-users] (newbie) Apache::Request — troubles installing

FreeBSD 4.8 stable
apache 1.3.27
mod_perl 1.27

trying to install rt for the first time. having errors installing the
Apache::Request perl module. any clues please?

command keyed:

perl sbin/rt-test-dependencies --with-mysql --with-modperl1 --install

output:
— snip —

MASON dependencies:
Params::Validate 0.02…found
Cache::Cache …found
Exception::Class …MISSING
CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
Database was generated on Mon, 07 Jul 2003 09:44:36 GMT
Exception::Class is up to date.
HTML::Mason 1.16…MISSING
HTML::Mason is up to date.
MLDBM …found
Errno …found
FreezeThaw …found
Digest::MD5 …found
CGI::Cookie 1.20…found
Storable …found
Apache::Session 1.53…found
MAILGATE dependencies:
HTML::TreeBuilder …found
HTML::FormatText …found
Getopt::Long …found
LWP::UserAgent …found
MODPERL1 dependencies:
CGI …found
Apache::Request …MISSING
Running install for module Apache::Request
Running make for J/JO/JOESUF/libapreq-1.2.tar.gz
Checksum for
/root/.cpan/sources/authors/id/J/JO/JOESUF/libapreq-1.2.tar.gz ok

Hi

upgrade FreeBSD ports /usr/ports

And here is easy help:

http://lukasmaly.net/RT3-install_en.txt

Anybody explain to me, since I have perl 5.8 loaded, why I cant get rt3
installed from /usr/ports ?

What is your output from
/usr/ports/www/rt3# make -V PERL_LEVEL

[/usr/ports/www/rt3]
root@hurricane# make -V PERL_LEVEL
0

?

Did you run ‘use.perl port’ after installing perl 5.8?

no how do I do this?

Read /usr/ports/lang/perl5.8/pkg-message .
I advise you to install perl 5.8 from ports, this message will be
displayed automatically.