New Queue Issue

Hi List,

Trying to create a new Queue by the name of “Support Internal”,
additional to our main “Support” one.

Our Fetchmailrc looks like:
poll 192.168.100.1 with proto POP3:
user support there with password **** mda “/usr/bin/perl
/opt/rt3/bin/rt-mailgate --url http://192.168.100.2/ --queue Support
–action correspond”

user support-internal there with password ***** mda “/usr/bin/perl
/opt/rt3/bin/rt-mailgate --url http://192.168.100.2/ --queue Support
Internal --action correspond”

Issue: When sending emails to support-internal@company.com they are
created on the “Support” queue instead of “Support Internal”

i tryed adding a “Test” queue and Tickets are created as per Queues
just fine, but not with this one.

Ideas?

I suspect it’s the space in the queue name. Try Support-Internal as the
queue name perhaps?

sebsua@gmail.com wrote:

Hi List,

Trying to create a new Queue by the name of “Support Internal”,
additional to our main “Support” one.

Our Fetchmailrc looks like:

poll 192.168.100.1 with proto POP3:
user support there with password **** mda “/usr/bin/perl
/opt/rt3/bin/rt-mailgate --url http://192.168.100.2/ --queue Support
–action correspond”

user support-internal there with password ***** mda “/usr/bin/perl
/opt/rt3/bin/rt-mailgate --url http://192.168.100.2/ --queue Support
Internal --action correspond”

Issue: When sending emails to support-internal@company.com they are
created on the “Support” queue instead of “Support Internal”

i tryed adding a “Test” queue and Tickets are created as per Queues
just fine, but not with this one.

Ideas?


The rt-users Archives

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Drew Barnes
Applications Analyst
Network Resources Department
Raymond Walters College
University of Cincinnati

Drew Barnes wrote:

I suspect it’s the space in the queue name. Try Support-Internal as the
queue name perhaps?

Or adding single quotes around the queue name in the fetchmail config
will probably do the trick:

user support-internal there with password ***** mda “/usr/bin/perl
/opt/rt3/bin/rt-mailgate --url http://192.168.100.2/ --queue ‘Support
Internal’ --action correspond”

Un-quoted whitespace is considered a field separator, so you were
telling mailgate to use the queue ‘Support’ and passing ‘Internal’ as
another option.

.r’