New installation RT 4.4.4 - error: Your password does not satisfy the current policy requirements at /install/rt-4.4.4/sbin/../lib/RT/Handle.pm line 477

Greetings!

I am from Brazil, and I apologize for my English, but I hope to be understood.
We have been using RT version 1.0.7 for many years, and I need to upgrade to 4.4.4.
I set up two separate environments. One from scratch, installing version 4.4.4, and executing make initialize-database, gives the error:
Now inserting database ACLs.
[30038] [Wed Jul 31 15:39:20 2019] [warning]: DBD :: mysql :: st execute failed: Your password does not satisfy the current policy requirements at /install/rt-4.4.4/sbin/. ./lib/RT/Handle.pm line 477. (/install/rt-4.4.4/sbin/…/lib/RT/Handle.pm:477)
[30038] [Wed Jul 31 15:39:20 2019] [critical]: DBD :: mysql :: st execute failed: Your password does not satisfy the current policy requirements at /install/rt-4.4.4/sbin/. ./lib/RT/Handle.pm line 477. (/install/rt-4.4.4/sbin/…/lib/RT.pm:408)
DBD :: mysql :: st execute failed: Your password does not satisfy the current policy requirements at /install/rt-4.4.4/sbin/…/lib/RT/Handle.pm line 477.
make: ** [initialize-database] Error 255

I’ve searched the Handle.pm and RT.pm files but didn’t find out what the problem was.
Could someone help me?

And enjoying it: what better option to upgrade from version 1.0.7 to 4.4.4 or start from scratch with 4.4.4?

Thank you,
Christiane

Wow 1.0.7 that’s crazy! Looking online it seems the error is a MySQL error and not an RT error:

Is the password very simple? It may be the MySQL policy doesn’t allow such a simple password.

And enjoying it: what better option to upgrade from version 1.0.7 to 4.4.4 or start from scratch with 4.4.4?

I know there is documentation on upgrading from version X -> Y on the docs page:

https://docs.bestpractical.com/rt/4.4.4/index.html

But it looks like there aren’t any steps from version 1.0.

1 Like

We had a group that was running a highly customized version of 1.0.X. When we went to ‘bring them into the fold’ we determined that it was going to be too painful and we just re-created their stuff in 4.

The only code I recall seeing for migration from RT 1.x was


and that only goes to an early 3.x version.

1 Like

Hi. Yes, version 1.0.7 is crazy!
I think my MySql password is not simple. I changed to a complex sentence and the error continues.

Did you run SHOW VARIABLES LIKE 'validate_password%'; to confirm your password meets those requirements?

Yes, I did.
And I solved the problem and finished the installation.
Thank you.

Hi Jeff,

Unfortunately the documentation and migration codes from version 1.0.7 to 2.X no longer exist. I had to choose to start from the new version 4.4.4 and I will adapt my environment there.
Thank you.