Need to reset user password in web UI (initial log in trouble)

Hi Brendan,

This sounds a lot like something that came up about a year ago.

http://www.gossamer-threads.com/lists/rt/users/45480

You’ll find Ruslans patch at the bottom of the thread. It cleared things
right up on our system.

Steve

Steve Platt
Bioinformatics
Health Protection Agency
UK-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Brendan
Arnold
Sent: Wednesday,31 May 2006 10:31
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Need to reset user password in web UI (initial login
trouble)

Hi there,

When creating a new user as administrator in the web UI I get the user
to add his/her password and save afterwards and logout. When they try
to login they get ‘Your username or password is incorrect’. After
logging back in as administrator and getting the user to re-enter
their password a second time and logging out again. The user can now
login.

Interestingly I tried this as a test case with the username ‘test’ and
password ‘test’. The user was created without any problems although
login did not work. When I tried to re-enter the password as
administrator I was given an error which claimed four character was
too short for a password.

Is there a blank space being added to my password?

This occurs in IE and Firefox under Windows. My server details are,

Solaris 9
RT 3.4.5
Perl 5.8.5

Regards,

Brendan
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical:
http://bestpractical.com/about/jobs.html

Brendan,

We’re running RT 3.4.2 (new servers = upgraded RT in the near future) on
Redhat 7.x so all I can say is that this patched fixed the problem when it
occurred on our system.

It’s best to reply to the list with questions like this so that even if you
get an answer, everyone else can bask in the shared wisdom. In this case
it’ll hopefully catch the attention of the RT gurus (which I’m definitely
not), especially Ruslan who originally provided the patch.

Sorry I can’t be of more help.

SteveFrom: Brendan Arnold [mailto:brendanarnold@gmail.com]
Sent: Wednesday,31 May 2006 11:58
To: Steven Platt
Subject: Re: [rt-users] Need to reset user password in web UI (initial log
in trouble)

Hi there,

Thanks for the reply. I tried the patch but I think that it is out of
date now, it doesn’t find the files and when I do specify the file
(now in the share dir for example) the lines are not found.

Is there another option?

Regards,

Brendan