MySQL InnoDB

Mrs,

When I have to enter the comand “make initialize-database”, I have a
error in MySQL. See below:

Creating mysql database rt3.
RT requires that MySQL be compiled with InnoDB table support.
See http://dev.mysql.com/doc/mysql/en/InnoDB.html
make: *** [initialize-database] Error 255

I read de DOCS but don’t work. What the configuration needs in “my.cnf”?

Thanks,

Dud.

Mrs,

When I have to enter the comand “make initialize-database”, I have a
error in MySQL. See below:

Creating mysql database rt3.
RT requires that MySQL be compiled with InnoDB table support.
See http://dev.mysql.com/doc/mysql/en/InnoDB.html
make: *** [initialize-database] Error 255

I read de DOCS but don’t work. What the configuration needs in “my.cnf”?
There is shouldn’t be “skip-innodb” option in my.cnf.
Out put of the “show variables like ‘have_%’;” from mysql console must
say you have innodb.

And your my.cnf should look like:

the rest of the innodb config follows:

don’t eat too much memory, we’re trying to be safe on 64Mb boxes.

you might want to bump this up a bit on boxes with more RAM

innodb_buffer_pool_size = 16M

this is the default, increase if you have lots of tables

innodb_additional_mem_pool_size = 2M

i’d like to use /var/lib/mysql/innodb, but that is seen as a database :frowning:

and upstream wants things to be under /var/lib/mysql/, so that’s the route

we have to take for the moment

innodb_data_home_dir = /var/lib/mysql/
innodb_log_arch_dir = /var/lib/mysql/
innodb_log_group_home_dir = /var/lib/mysql/

you may wish to change this size to be more suitable for your system

the max is there to avoid run-away growth on your machine

innodb_data_file_path = ibdata1:10M:autoextend

we keep this at around 25% of of innodb_buffer_pool_size

sensible values range from 1MB to

(1/innodb_log_files_in_group*innodb_buffer_pool_size)
innodb_log_file_size = 5M

this is the default, increase if you have very large transactions.

innodb_log_buffer_size = 8M

this is the default, and won’t hurt you.

you shouldn’t need to tweak it.

innodb_log_files_in_group = 2

see the innodb config docs, the other options are not always safe

innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

Thanks,

Dud.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from http://rtbook.bestpractical.com

Best regards, Ruslan.