Mysql connect fails in DBIx::SearchBuilder rt-3.6pre0

I get this in the error logs,

…failed: Client does not support authentication protocol requested by server;
consider upgrading MySQL client at /usr/local/perl-5.8.8/lib/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 108
[Mon Mar 06 17:17:04 2006] [error] [client 199.67.51.179] Connect Failed Client does not support authentication protocol requested by server;
consider upgrading MySQL client\n at /usr/local/rt-3.6pre0/lib/RT.pm line 176\n

…This is connecting to the localhost using the same server-client 5.0. I can connect to the rt db with
the same Perl & DBI,

/usr/packages/Perl># perl -MDBI -d -e0 5:45PM 03/06 tstest

Loading DB routines from perl5db.pl version 1.28
Editor support available.

Enter h or h h' for help, orman perldebug’ for more help.

main::(-e:1): 0
DB<1> $dbh = DBI->connect(‘dbi:mysql:dbname=rt;host=localhost’, ‘rt-user’, ‘rtpass’);

DB<2> x $dbh->tables;
0 'ACL'
1 'Attachments'
2 'Attributes'
3 'CachedGroupMembers'
4 'CustomFieldValues'
5 'CustomFields'
6 'GroupMembers'
7 'Groups'
8 'Links'
9 'Principals'
10 'Queues'
11 'ScripActions'
12 'ScripConditions'
13 'Scrips'
14 'Templates'
15 'TicketCustomFieldValues'
16 'Tickets'
17 'Transactions'
18 'Users'
19 ‘sessions

… but it fails in DBIx::SearchBuilder.

perl -MDBI -e ‘DBI->installed_versions’

Perl : 5.008008 (i686-linux)
OS : linux (2.6.14.6)
DBI : 1.50
DBD::mysql : 3.0002
DBD::Sponge : 11.10
DBD::SQLite : 1.11
DBD::Proxy : 0.2004
DBD::Oracle : 1.16
DBD::Multiplex : 1.98
DBD::File : 0.33
DBD::ExampleP : 11.12
DBD::DBM : 0.03

perl -MDBIx::SearchBuilder -e ‘print $DBIx::SearchBuilder::VERSION, $/’

1.39

                                                     Any ideas?

                                                              STH

Scott T. Hildreth shildreth@allantgroup.com

Never mind, the hostname was pointing at the wrong IP address.

                            Thanks for listening. :-)On Mon, 2006-03-06 at 17:57 -0600, Scott T. Hildreth wrote:

I get this in the error logs,

…failed: Client does not support authentication protocol requested by server;
consider upgrading MySQL client at /usr/local/perl-5.8.8/lib/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 108
[Mon Mar 06 17:17:04 2006] [error] [client 199.67.51.179] Connect Failed Client does not support authentication protocol requested by server;
consider upgrading MySQL client\n at /usr/local/rt-3.6pre0/lib/RT.pm line 176\n

…This is connecting to the localhost using the same server-client 5.0. I can connect to the rt db with
the same Perl & DBI,

/usr/packages/Perl># perl -MDBI -d -e0 5:45PM 03/06 tstest

Loading DB routines from perl5db.pl version 1.28
Editor support available.

Enter h or h h' for help, orman perldebug’ for more help.

main::(-e:1): 0
DB<1> $dbh = DBI->connect(‘dbi:mysql:dbname=rt;host=localhost’, ‘rt-user’, ‘rtpass’);

DB<2> x $dbh->tables;
0 'ACL'
1 'Attachments'
2 'Attributes'
3 'CachedGroupMembers'
4 'CustomFieldValues'
5 'CustomFields'
6 'GroupMembers'
7 'Groups'
8 'Links'
9 'Principals'
10 'Queues'
11 'ScripActions'
12 'ScripConditions'
13 'Scrips'
14 'Templates'
15 'TicketCustomFieldValues'
16 'Tickets'
17 'Transactions'
18 'Users'
19 ‘sessions

… but it fails in DBIx::SearchBuilder.

=======================================================================

perl -MDBI -e ‘DBI->installed_versions’

Perl : 5.008008 (i686-linux)
OS : linux (2.6.14.6)
DBI : 1.50
DBD::mysql : 3.0002
DBD::Sponge : 11.10
DBD::SQLite : 1.11
DBD::Proxy : 0.2004
DBD::Oracle : 1.16
DBD::Multiplex : 1.98
DBD::File : 0.33
DBD::ExampleP : 11.12
DBD::DBM : 0.03

perl -MDBIx::SearchBuilder -e ‘print $DBIx::SearchBuilder::VERSION, $/’

1.39

                                                     Any ideas?

                                                              STH

Scott T. Hildreth shildret@scotth.emsphone.com

Never mind, the hostname was pointing at the wrong IP address.

                            Thanks for listening. :-)

Well not the case. I can connect with DBIx::SearchBuilder::Handle,

DB<3> use DBIx::SearchBuilder::Handle;

DB<4> $handle = DBIx::SearchBuilder::Handle->new();

DB<5> $handle->Connect( Driver => ‘mysql’, Database => ‘rt’, Host => ‘localhost’, User => ‘rt-user’, Password => ‘rtpas’);

DB<6> x $handle
0 DBIx::SearchBuilder::Handle::mysql=HASH(0x846fb50)
‘DisconnectHandleOnDestroy’ => undef
’StatementLog’ => ARRAY(0x855f4fc)
empty array
’dsn’ => ‘dbi:mysql:dbname=rt3;host=localhost’

…I only get the error message when running in RT.

I get this in the error logs,

…failed: Client does not support authentication protocol requested by server;
consider upgrading MySQL client at /usr/local/perl-5.8.8/lib/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 108
[Mon Mar 06 17:17:04 2006] [error] [client 199.67.51.179] Connect Failed Client does not support authentication protocol requested by server;
consider upgrading MySQL client\n at /usr/local/rt-3.6pre0/lib/RT.pm line 176\n

…This is connecting to the localhost using the same server-client 5.0. I can connect to the rt db with
the same Perl & DBI,

/usr/packages/Perl># perl -MDBI -d -e0 5:45PM 03/06 tstest

Loading DB routines from perl5db.pl version 1.28
Editor support available.

Enter h or h h' for help, orman perldebug’ for more help.

main::(-e:1): 0
DB<1> $dbh = DBI->connect(‘dbi:mysql:dbname=rt;host=localhost’, ‘rt-user’, ‘rtpass’);

DB<2> x $dbh->tables;
0 'ACL'
1 'Attachments'
2 'Attributes'
3 'CachedGroupMembers'
4 'CustomFieldValues'
5 'CustomFields'
6 'GroupMembers'
7 'Groups'
8 'Links'
9 'Principals'
10 'Queues'
11 'ScripActions'
12 'ScripConditions'
13 'Scrips'
14 'Templates'
15 'TicketCustomFieldValues'
16 'Tickets'
17 'Transactions'
18 'Users'
19 ‘sessions

… but it fails in DBIx::SearchBuilder.

=======================================================================

perl -MDBI -e ‘DBI->installed_versions’

Perl : 5.008008 (i686-linux)
OS : linux (2.6.14.6)
DBI : 1.50
DBD::mysql : 3.0002
DBD::Sponge : 11.10
DBD::SQLite : 1.11
DBD::Proxy : 0.2004
DBD::Oracle : 1.16
DBD::Multiplex : 1.98
DBD::File : 0.33
DBD::ExampleP : 11.12
DBD::DBM : 0.03

perl -MDBIx::SearchBuilder -e ‘print $DBIx::SearchBuilder::VERSION, $/’

1.39

                                                     Any ideas?

                                                              STH

Scott T. Hildreth shildret@scotth.emsphone.com

mod_perl?On 3/7/06, Scott T. Hildreth shildret@scotth.emsphone.com wrote:

On Mon, 2006-03-06 at 18:31 -0600, Scott T. Hildreth wrote:

Never mind, the hostname was pointing at the wrong IP address.

                            Thanks for listening. :-)

Well not the case. I can connect with DBIx::SearchBuilder::Handle,

DB<3> use DBIx::SearchBuilder::Handle;

DB<4> $handle = DBIx::SearchBuilder::Handle->new();

DB<5> $handle->Connect( Driver => ‘mysql’, Database => ‘rt’, Host => ‘localhost’, User => ‘rt-user’, Password => ‘rtpas’);

DB<6> x $handle
0 DBIx::SearchBuilder::Handle::mysql=HASH(0x846fb50)
‘DisconnectHandleOnDestroy’ => undef
’StatementLog’ => ARRAY(0x855f4fc)
empty array
’dsn’ => ‘dbi:mysql:dbname=rt3;host=localhost’

…I only get the error message when running in RT.

On Mon, 2006-03-06 at 17:57 -0600, Scott T. Hildreth wrote:

I get this in the error logs,

…failed: Client does not support authentication protocol requested by server;
consider upgrading MySQL client at /usr/local/perl-5.8.8/lib/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 108
[Mon Mar 06 17:17:04 2006] [error] [client 199.67.51.179] Connect Failed Client does not support authentication protocol requested by server;
consider upgrading MySQL client\n at /usr/local/rt-3.6pre0/lib/RT.pm line 176\n

…This is connecting to the localhost using the same server-client 5.0. I can connect to the rt db with
the same Perl & DBI,

/usr/packages/Perl># perl -MDBI -d -e0 5:45PM 03/06 tstest

Loading DB routines from perl5db.pl version 1.28
Editor support available.

Enter h or h h' for help, orman perldebug’ for more help.

main::(-e:1): 0
DB<1> $dbh = DBI->connect(‘dbi:mysql:dbname=rt;host=localhost’, ‘rt-user’, ‘rtpass’);

DB<2> x $dbh->tables;
0 'ACL'
1 'Attachments'
2 'Attributes'
3 'CachedGroupMembers'
4 'CustomFieldValues'
5 'CustomFields'
6 'GroupMembers'
7 'Groups'
8 'Links'
9 'Principals'
10 'Queues'
11 'ScripActions'
12 'ScripConditions'
13 'Scrips'
14 'Templates'
15 'TicketCustomFieldValues'
16 'Tickets'
17 'Transactions'
18 'Users'
19 ‘sessions

… but it fails in DBIx::SearchBuilder.

=======================================================================

perl -MDBI -e ‘DBI->installed_versions’

Perl : 5.008008 (i686-linux)
OS : linux (2.6.14.6)
DBI : 1.50
DBD::mysql : 3.0002
DBD::Sponge : 11.10
DBD::SQLite : 1.11
DBD::Proxy : 0.2004
DBD::Oracle : 1.16
DBD::Multiplex : 1.98
DBD::File : 0.33
DBD::ExampleP : 11.12
DBD::DBM : 0.03

perl -MDBIx::SearchBuilder -e ‘print $DBIx::SearchBuilder::VERSION, $/’

1.39

                                                     Any ideas?

                                                              STH


Scott T. Hildreth shildret@scotth.emsphone.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html

Best regards, Ruslan.

mod_perl?

yes mod_perl 2.02

Never mind, the hostname was pointing at the wrong IP address.

                            Thanks for listening. :-)

Well not the case. I can connect with DBIx::SearchBuilder::Handle,

DB<3> use DBIx::SearchBuilder::Handle;

DB<4> $handle = DBIx::SearchBuilder::Handle->new();

DB<5> $handle->Connect( Driver => ‘mysql’, Database => ‘rt’, Host => ‘localhost’, User => ‘rt-user’, Password => ‘rtpas’);

DB<6> x $handle
0 DBIx::SearchBuilder::Handle::mysql=HASH(0x846fb50)
‘DisconnectHandleOnDestroy’ => undef
’StatementLog’ => ARRAY(0x855f4fc)
empty array
’dsn’ => ‘dbi:mysql:dbname=rt3;host=localhost’

…I only get the error message when running in RT.

I get this in the error logs,

…failed: Client does not support authentication protocol requested by server;
consider upgrading MySQL client at /usr/local/perl-5.8.8/lib/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 108
[Mon Mar 06 17:17:04 2006] [error] [client 199.67.51.179] Connect Failed Client does not support authentication protocol requested by server;
consider upgrading MySQL client\n at /usr/local/rt-3.6pre0/lib/RT.pm line 176\n

…This is connecting to the localhost using the same server-client 5.0. I can connect to the rt db with
the same Perl & DBI,

/usr/packages/Perl># perl -MDBI -d -e0 5:45PM 03/06 tstest

Loading DB routines from perl5db.pl version 1.28
Editor support available.

Enter h or h h' for help, orman perldebug’ for more help.

main::(-e:1): 0
DB<1> $dbh = DBI->connect(‘dbi:mysql:dbname=rt;host=localhost’, ‘rt-user’, ‘rtpass’);

DB<2> x $dbh->tables;
0 'ACL'
1 'Attachments'
2 'Attributes'
3 'CachedGroupMembers'
4 'CustomFieldValues'
5 'CustomFields'
6 'GroupMembers'
7 'Groups'
8 'Links'
9 'Principals'
10 'Queues'
11 'ScripActions'
12 'ScripConditions'
13 'Scrips'
14 'Templates'
15 'TicketCustomFieldValues'
16 'Tickets'
17 'Transactions'
18 'Users'
19 ‘sessions

… but it fails in DBIx::SearchBuilder.

=======================================================================

perl -MDBI -e ‘DBI->installed_versions’

Perl : 5.008008 (i686-linux)
OS : linux (2.6.14.6)
DBI : 1.50
DBD::mysql : 3.0002
DBD::Sponge : 11.10
DBD::SQLite : 1.11
DBD::Proxy : 0.2004
DBD::Oracle : 1.16
DBD::Multiplex : 1.98
DBD::File : 0.33
DBD::ExampleP : 11.12
DBD::DBM : 0.03

perl -MDBIx::SearchBuilder -e ‘print $DBIx::SearchBuilder::VERSION, $/’

1.39

                                                     Any ideas?

                                                              STH


Scott T. Hildreth shildret@scotth.emsphone.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html


Best regards, Ruslan.

Scott T. Hildreth shildreth@allantgroup.com

Check that mod_perl runs with perl you want, may be you run one perl
interpreter from command line, but mod_perl use another(that’s
possible).On 3/7/06, Scott T. Hildreth shildreth@allantgroup.com wrote:

On Tue, 2006-03-07 at 04:04 +0300, Ruslan Zakirov wrote:

mod_perl?

yes mod_perl 2.02

On 3/7/06, Scott T. Hildreth shildret@scotth.emsphone.com wrote:

On Mon, 2006-03-06 at 18:31 -0600, Scott T. Hildreth wrote:

Never mind, the hostname was pointing at the wrong IP address.

                            Thanks for listening. :-)

Well not the case. I can connect with DBIx::SearchBuilder::Handle,

DB<3> use DBIx::SearchBuilder::Handle;

DB<4> $handle = DBIx::SearchBuilder::Handle->new();

DB<5> $handle->Connect( Driver => ‘mysql’, Database => ‘rt’, Host => ‘localhost’, User => ‘rt-user’, Password => ‘rtpas’);

DB<6> x $handle
0 DBIx::SearchBuilder::Handle::mysql=HASH(0x846fb50)
‘DisconnectHandleOnDestroy’ => undef
’StatementLog’ => ARRAY(0x855f4fc)
empty array
’dsn’ => ‘dbi:mysql:dbname=rt3;host=localhost’

…I only get the error message when running in RT.

On Mon, 2006-03-06 at 17:57 -0600, Scott T. Hildreth wrote:

I get this in the error logs,

…failed: Client does not support authentication protocol requested by server;
consider upgrading MySQL client at /usr/local/perl-5.8.8/lib/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 108
[Mon Mar 06 17:17:04 2006] [error] [client 199.67.51.179] Connect Failed Client does not support authentication protocol requested by server;
consider upgrading MySQL client\n at /usr/local/rt-3.6pre0/lib/RT.pm line 176\n

…This is connecting to the localhost using the same server-client 5.0. I can connect to the rt db with
the same Perl & DBI,

/usr/packages/Perl># perl -MDBI -d -e0 5:45PM 03/06 tstest

Loading DB routines from perl5db.pl version 1.28
Editor support available.

Enter h or h h' for help, orman perldebug’ for more help.

main::(-e:1): 0
DB<1> $dbh = DBI->connect(‘dbi:mysql:dbname=rt;host=localhost’, ‘rt-user’, ‘rtpass’);

DB<2> x $dbh->tables;
0 'ACL'
1 'Attachments'
2 'Attributes'
3 'CachedGroupMembers'
4 'CustomFieldValues'
5 'CustomFields'
6 'GroupMembers'
7 'Groups'
8 'Links'
9 'Principals'
10 'Queues'
11 'ScripActions'
12 'ScripConditions'
13 'Scrips'
14 'Templates'
15 'TicketCustomFieldValues'
16 'Tickets'
17 'Transactions'
18 'Users'
19 ‘sessions

… but it fails in DBIx::SearchBuilder.

=======================================================================

perl -MDBI -e ‘DBI->installed_versions’

Perl : 5.008008 (i686-linux)
OS : linux (2.6.14.6)
DBI : 1.50
DBD::mysql : 3.0002
DBD::Sponge : 11.10
DBD::SQLite : 1.11
DBD::Proxy : 0.2004
DBD::Oracle : 1.16
DBD::Multiplex : 1.98
DBD::File : 0.33
DBD::ExampleP : 11.12
DBD::DBM : 0.03

perl -MDBIx::SearchBuilder -e ‘print $DBIx::SearchBuilder::VERSION, $/’

1.39

                                                     Any ideas?

                                                              STH


Scott T. Hildreth shildret@scotth.emsphone.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html


Best regards, Ruslan.


Scott T. Hildreth shildreth@allantgroup.com

Best regards, Ruslan.

Check that mod_perl runs with perl you want, may be you run one perl
interpreter from command line, but mod_perl use another(that’s
possible).

I did a force reinstall of mod_perl2, just to make sure that wasn’t
happening. I will double check though. I am using 5.8.8 and the
vendor Perl is 5.8.3 without DBD::mysql or DBI installed. It does
show 5.8.8 in the error messages.

mod_perl?

yes mod_perl 2.02

Never mind, the hostname was pointing at the wrong IP address.

                            Thanks for listening. :-)

Well not the case. I can connect with DBIx::SearchBuilder::Handle,

DB<3> use DBIx::SearchBuilder::Handle;

DB<4> $handle = DBIx::SearchBuilder::Handle->new();

DB<5> $handle->Connect( Driver => ‘mysql’, Database => ‘rt’, Host => ‘localhost’, User => ‘rt-user’, Password => ‘rtpas’);

DB<6> x $handle
0 DBIx::SearchBuilder::Handle::mysql=HASH(0x846fb50)
‘DisconnectHandleOnDestroy’ => undef
’StatementLog’ => ARRAY(0x855f4fc)
empty array
’dsn’ => ‘dbi:mysql:dbname=rt3;host=localhost’

…I only get the error message when running in RT.

I get this in the error logs,

…failed: Client does not support authentication protocol requested by server;
consider upgrading MySQL client at /usr/local/perl-5.8.8/lib/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 108
[Mon Mar 06 17:17:04 2006] [error] [client 199.67.51.179] Connect Failed Client does not support authentication protocol requested by server;
consider upgrading MySQL client\n at /usr/local/rt-3.6pre0/lib/RT.pm line 176\n

…This is connecting to the localhost using the same server-client 5.0. I can connect to the rt db with
the same Perl & DBI,

/usr/packages/Perl># perl -MDBI -d -e0 5:45PM 03/06 tstest

Loading DB routines from perl5db.pl version 1.28
Editor support available.

Enter h or h h' for help, orman perldebug’ for more help.

main::(-e:1): 0
DB<1> $dbh = DBI->connect(‘dbi:mysql:dbname=rt;host=localhost’, ‘rt-user’, ‘rtpass’);

DB<2> x $dbh->tables;
0 'ACL'
1 'Attachments'
2 'Attributes'
3 'CachedGroupMembers'
4 'CustomFieldValues'
5 'CustomFields'
6 'GroupMembers'
7 'Groups'
8 'Links'
9 'Principals'
10 'Queues'
11 'ScripActions'
12 'ScripConditions'
13 'Scrips'
14 'Templates'
15 'TicketCustomFieldValues'
16 'Tickets'
17 'Transactions'
18 'Users'
19 ‘sessions

… but it fails in DBIx::SearchBuilder.

=======================================================================

perl -MDBI -e ‘DBI->installed_versions’

Perl : 5.008008 (i686-linux)
OS : linux (2.6.14.6)
DBI : 1.50
DBD::mysql : 3.0002
DBD::Sponge : 11.10
DBD::SQLite : 1.11
DBD::Proxy : 0.2004
DBD::Oracle : 1.16
DBD::Multiplex : 1.98
DBD::File : 0.33
DBD::ExampleP : 11.12
DBD::DBM : 0.03

perl -MDBIx::SearchBuilder -e ‘print $DBIx::SearchBuilder::VERSION, $/’

1.39

                                                     Any ideas?

                                                              STH


Scott T. Hildreth shildret@scotth.emsphone.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html


Best regards, Ruslan.


Scott T. Hildreth shildreth@allantgroup.com


Best regards, Ruslan.

Scott T. Hildreth shildreth@allantgroup.com

Check that mod_perl runs with perl you want, may be you run one perl
interpreter from command line, but mod_perl use another(that’s
possible).

[Mon Mar 06 19:02:55 2006] [notice] Apache/2.0.49 (Unix) mod_ssl/2.0.49 OpenSSL/0.9.7d mod_jk/1.2.15 PHP/4.4.2
mod_perl/2.0.2 Perl/v5.8.8 configured – resuming normal operations

I did a force reinstall of mod_perl2, just to make sure that wasn’t
happening. I will double check though. I am using 5.8.8 and the
vendor Perl is 5.8.3 without DBD::mysql or DBI installed. It does
show 5.8.8 in the error messages.

mod_perl?

yes mod_perl 2.02

Never mind, the hostname was pointing at the wrong IP address.

                            Thanks for listening. :-)

Well not the case. I can connect with DBIx::SearchBuilder::Handle,

DB<3> use DBIx::SearchBuilder::Handle;

DB<4> $handle = DBIx::SearchBuilder::Handle->new();

DB<5> $handle->Connect( Driver => ‘mysql’, Database => ‘rt’, Host => ‘localhost’, User => ‘rt-user’, Password => ‘rtpas’);

DB<6> x $handle
0 DBIx::SearchBuilder::Handle::mysql=HASH(0x846fb50)
‘DisconnectHandleOnDestroy’ => undef
’StatementLog’ => ARRAY(0x855f4fc)
empty array
’dsn’ => ‘dbi:mysql:dbname=rt3;host=localhost’

…I only get the error message when running in RT.

I get this in the error logs,

…failed: Client does not support authentication protocol requested by server;
consider upgrading MySQL client at /usr/local/perl-5.8.8/lib/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 108
[Mon Mar 06 17:17:04 2006] [error] [client 199.67.51.179] Connect Failed Client does not support authentication protocol requested by server;
consider upgrading MySQL client\n at /usr/local/rt-3.6pre0/lib/RT.pm line 176\n

…This is connecting to the localhost using the same server-client 5.0. I can connect to the rt db with
the same Perl & DBI,

/usr/packages/Perl># perl -MDBI -d -e0 5:45PM 03/06 tstest

Loading DB routines from perl5db.pl version 1.28
Editor support available.

Enter h or h h' for help, orman perldebug’ for more help.

main::(-e:1): 0
DB<1> $dbh = DBI->connect(‘dbi:mysql:dbname=rt;host=localhost’, ‘rt-user’, ‘rtpass’);

DB<2> x $dbh->tables;
0 'ACL'
1 'Attachments'
2 'Attributes'
3 'CachedGroupMembers'
4 'CustomFieldValues'
5 'CustomFields'
6 'GroupMembers'
7 'Groups'
8 'Links'
9 'Principals'
10 'Queues'
11 'ScripActions'
12 'ScripConditions'
13 'Scrips'
14 'Templates'
15 'TicketCustomFieldValues'
16 'Tickets'
17 'Transactions'
18 'Users'
19 ‘sessions

… but it fails in DBIx::SearchBuilder.

=======================================================================

perl -MDBI -e ‘DBI->installed_versions’

Perl : 5.008008 (i686-linux)
OS : linux (2.6.14.6)
DBI : 1.50
DBD::mysql : 3.0002
DBD::Sponge : 11.10
DBD::SQLite : 1.11
DBD::Proxy : 0.2004
DBD::Oracle : 1.16
DBD::Multiplex : 1.98
DBD::File : 0.33
DBD::ExampleP : 11.12
DBD::DBM : 0.03

perl -MDBIx::SearchBuilder -e ‘print $DBIx::SearchBuilder::VERSION, $/’

1.39

                                                     Any ideas?

                                                              STH


Scott T. Hildreth shildret@scotth.emsphone.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html


Best regards, Ruslan.


Scott T. Hildreth shildreth@allantgroup.com


Best regards, Ruslan.

Scott T. Hildreth shildreth@allantgroup.com

May be you’ve upgraded mysql from 4.0 to 4.1 and didn’t follow upgrade
instructions?

This is a new server, mysql 5.015. If that were the case, wouldn’t the
connect fail from the debugger as well?

Check that mod_perl runs with perl you want, may be you run one perl
interpreter from command line, but mod_perl use another(that’s
possible).

I did a force reinstall of mod_perl2, just to make sure that wasn’t
happening. I will double check though. I am using 5.8.8 and the
vendor Perl is 5.8.3 without DBD::mysql or DBI installed. It does
show 5.8.8 in the error messages.

mod_perl?

yes mod_perl 2.02

Never mind, the hostname was pointing at the wrong IP address.

                            Thanks for listening. :-)

Well not the case. I can connect with DBIx::SearchBuilder::Handle,

DB<3> use DBIx::SearchBuilder::Handle;

DB<4> $handle = DBIx::SearchBuilder::Handle->new();

DB<5> $handle->Connect( Driver => ‘mysql’, Database => ‘rt’, Host => ‘localhost’, User => ‘rt-user’, Password => ‘rtpas’);

DB<6> x $handle
0 DBIx::SearchBuilder::Handle::mysql=HASH(0x846fb50)
‘DisconnectHandleOnDestroy’ => undef
’StatementLog’ => ARRAY(0x855f4fc)
empty array
’dsn’ => ‘dbi:mysql:dbname=rt3;host=localhost’

…I only get the error message when running in RT.

I get this in the error logs,

…failed: Client does not support authentication protocol requested by server;
consider upgrading MySQL client at /usr/local/perl-5.8.8/lib/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 108
[Mon Mar 06 17:17:04 2006] [error] [client 199.67.51.179] Connect Failed Client does not support authentication protocol requested by server;
consider upgrading MySQL client\n at /usr/local/rt-3.6pre0/lib/RT.pm line 176\n

…This is connecting to the localhost using the same server-client 5.0. I can connect to the rt db with
the same Perl & DBI,

/usr/packages/Perl># perl -MDBI -d -e0 5:45PM 03/06 tstest

Loading DB routines from perl5db.pl version 1.28
Editor support available.

Enter h or h h' for help, orman perldebug’ for more help.

main::(-e:1): 0
DB<1> $dbh = DBI->connect(‘dbi:mysql:dbname=rt;host=localhost’, ‘rt-user’, ‘rtpass’);

DB<2> x $dbh->tables;
0 'ACL'
1 'Attachments'
2 'Attributes'
3 'CachedGroupMembers'
4 'CustomFieldValues'
5 'CustomFields'
6 'GroupMembers'
7 'Groups'
8 'Links'
9 'Principals'
10 'Queues'
11 'ScripActions'
12 'ScripConditions'
13 'Scrips'
14 'Templates'
15 'TicketCustomFieldValues'
16 'Tickets'
17 'Transactions'
18 'Users'
19 ‘sessions

… but it fails in DBIx::SearchBuilder.

=======================================================================

perl -MDBI -e ‘DBI->installed_versions’

Perl : 5.008008 (i686-linux)
OS : linux (2.6.14.6)
DBI : 1.50
DBD::mysql : 3.0002
DBD::Sponge : 11.10
DBD::SQLite : 1.11
DBD::Proxy : 0.2004
DBD::Oracle : 1.16
DBD::Multiplex : 1.98
DBD::File : 0.33
DBD::ExampleP : 11.12
DBD::DBM : 0.03

perl -MDBIx::SearchBuilder -e ‘print $DBIx::SearchBuilder::VERSION, $/’

1.39

                                                     Any ideas?

                                                              STH


Scott T. Hildreth shildret@scotth.emsphone.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html


Best regards, Ruslan.


Scott T. Hildreth shildreth@allantgroup.com


Best regards, Ruslan.


Scott T. Hildreth shildreth@allantgroup.com


Best regards, Ruslan.

Scott T. Hildreth shildreth@allantgroup.com

May be you’ve upgraded mysql from 4.0 to 4.1 and didn’t follow upgrade
instructions?

This is a new server, mysql 5.015. If that were the case, wouldn’t the
connect fail from the debugger as well?
heh, you’re right.

I think you can use --old-password mysql option to workaround this
problem for now.

Check that mod_perl runs with perl you want, may be you run one perl
interpreter from command line, but mod_perl use another(that’s
possible).

I did a force reinstall of mod_perl2, just to make sure that wasn’t
happening. I will double check though. I am using 5.8.8 and the
vendor Perl is 5.8.3 without DBD::mysql or DBI installed. It does
show 5.8.8 in the error messages.

mod_perl?

yes mod_perl 2.02

Never mind, the hostname was pointing at the wrong IP address.

                            Thanks for listening. :-)

Well not the case. I can connect with DBIx::SearchBuilder::Handle,

DB<3> use DBIx::SearchBuilder::Handle;

DB<4> $handle = DBIx::SearchBuilder::Handle->new();

DB<5> $handle->Connect( Driver => ‘mysql’, Database => ‘rt’, Host => ‘localhost’, User => ‘rt-user’, Password => ‘rtpas’);

DB<6> x $handle
0 DBIx::SearchBuilder::Handle::mysql=HASH(0x846fb50)
‘DisconnectHandleOnDestroy’ => undef
’StatementLog’ => ARRAY(0x855f4fc)
empty array
’dsn’ => ‘dbi:mysql:dbname=rt3;host=localhost’

…I only get the error message when running in RT.

I get this in the error logs,

…failed: Client does not support authentication protocol requested by server;
consider upgrading MySQL client at /usr/local/perl-5.8.8/lib/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 108
[Mon Mar 06 17:17:04 2006] [error] [client 199.67.51.179] Connect Failed Client does not support authentication protocol requested by server;
consider upgrading MySQL client\n at /usr/local/rt-3.6pre0/lib/RT.pm line 176\n

…This is connecting to the localhost using the same server-client 5.0. I can connect to the rt db with
the same Perl & DBI,

/usr/packages/Perl># perl -MDBI -d -e0 5:45PM 03/06 tstest

Loading DB routines from perl5db.pl version 1.28
Editor support available.

Enter h or h h' for help, orman perldebug’ for more help.

main::(-e:1): 0
DB<1> $dbh = DBI->connect(‘dbi:mysql:dbname=rt;host=localhost’, ‘rt-user’, ‘rtpass’);

DB<2> x $dbh->tables;
0 'ACL'
1 'Attachments'
2 'Attributes'
3 'CachedGroupMembers'
4 'CustomFieldValues'
5 'CustomFields'
6 'GroupMembers'
7 'Groups'
8 'Links'
9 'Principals'
10 'Queues'
11 'ScripActions'
12 'ScripConditions'
13 'Scrips'
14 'Templates'
15 'TicketCustomFieldValues'
16 'Tickets'
17 'Transactions'
18 'Users'
19 ‘sessions

… but it fails in DBIx::SearchBuilder.

=======================================================================

perl -MDBI -e ‘DBI->installed_versions’

Perl : 5.008008 (i686-linux)
OS : linux (2.6.14.6)
DBI : 1.50
DBD::mysql : 3.0002
DBD::Sponge : 11.10
DBD::SQLite : 1.11
DBD::Proxy : 0.2004
DBD::Oracle : 1.16
DBD::Multiplex : 1.98
DBD::File : 0.33
DBD::ExampleP : 11.12
DBD::DBM : 0.03

perl -MDBIx::SearchBuilder -e ‘print $DBIx::SearchBuilder::VERSION, $/’

1.39

                                                     Any ideas?

                                                              STH


Scott T. Hildreth shildret@scotth.emsphone.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html


Best regards, Ruslan.


Scott T. Hildreth shildreth@allantgroup.com


Best regards, Ruslan.


Scott T. Hildreth shildreth@allantgroup.com


Best regards, Ruslan.


Scott T. Hildreth shildreth@allantgroup.com

Best regards, Ruslan.

May be you’ve upgraded mysql from 4.0 to 4.1 and didn’t follow upgrade
instructions?

This is a new server, mysql 5.015. If that were the case, wouldn’t the
connect fail from the debugger as well?

This database is in “Active-Active” mode, these are 2 servers used if
fail-over. Do you think that Apache::DBI is the problem here? Maybe
I should be using or trying FastCGI. I would like to debug this, I
just not sure on how to do this.

Check that mod_perl runs with perl you want, may be you run one perl
interpreter from command line, but mod_perl use another(that’s
possible).

I did a force reinstall of mod_perl2, just to make sure that wasn’t
happening. I will double check though. I am using 5.8.8 and the
vendor Perl is 5.8.3 without DBD::mysql or DBI installed. It does
show 5.8.8 in the error messages.

mod_perl?

yes mod_perl 2.02

Never mind, the hostname was pointing at the wrong IP address.

                            Thanks for listening. :-)

Well not the case. I can connect with DBIx::SearchBuilder::Handle,

DB<3> use DBIx::SearchBuilder::Handle;

DB<4> $handle = DBIx::SearchBuilder::Handle->new();

DB<5> $handle->Connect( Driver => ‘mysql’, Database => ‘rt’, Host => ‘localhost’, User => ‘rt-user’, Password => ‘rtpas’);

DB<6> x $handle
0 DBIx::SearchBuilder::Handle::mysql=HASH(0x846fb50)
‘DisconnectHandleOnDestroy’ => undef
’StatementLog’ => ARRAY(0x855f4fc)
empty array
’dsn’ => ‘dbi:mysql:dbname=rt3;host=localhost’

…I only get the error message when running in RT.

I get this in the error logs,

…failed: Client does not support authentication protocol requested by server;
consider upgrading MySQL client at /usr/local/perl-5.8.8/lib/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 108
[Mon Mar 06 17:17:04 2006] [error] [client 199.67.51.179] Connect Failed Client does not support authentication protocol requested by server;
consider upgrading MySQL client\n at /usr/local/rt-3.6pre0/lib/RT.pm line 176\n

…This is connecting to the localhost using the same server-client 5.0. I can connect to the rt db with
the same Perl & DBI,

/usr/packages/Perl># perl -MDBI -d -e0 5:45PM 03/06 tstest

Loading DB routines from perl5db.pl version 1.28
Editor support available.

Enter h or h h' for help, orman perldebug’ for more help.

main::(-e:1): 0
DB<1> $dbh = DBI->connect(‘dbi:mysql:dbname=rt;host=localhost’, ‘rt-user’, ‘rtpass’);

DB<2> x $dbh->tables;
0 'ACL'
1 'Attachments'
2 'Attributes'
3 'CachedGroupMembers'
4 'CustomFieldValues'
5 'CustomFields'
6 'GroupMembers'
7 'Groups'
8 'Links'
9 'Principals'
10 'Queues'
11 'ScripActions'
12 'ScripConditions'
13 'Scrips'
14 'Templates'
15 'TicketCustomFieldValues'
16 'Tickets'
17 'Transactions'
18 'Users'
19 ‘sessions

… but it fails in DBIx::SearchBuilder.

=======================================================================

perl -MDBI -e ‘DBI->installed_versions’

Perl : 5.008008 (i686-linux)
OS : linux (2.6.14.6)
DBI : 1.50
DBD::mysql : 3.0002
DBD::Sponge : 11.10
DBD::SQLite : 1.11
DBD::Proxy : 0.2004
DBD::Oracle : 1.16
DBD::Multiplex : 1.98
DBD::File : 0.33
DBD::ExampleP : 11.12
DBD::DBM : 0.03

perl -MDBIx::SearchBuilder -e ‘print $DBIx::SearchBuilder::VERSION, $/’

1.39

                                                     Any ideas?

                                                              STH


Scott T. Hildreth shildret@scotth.emsphone.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html


Best regards, Ruslan.


Scott T. Hildreth shildreth@allantgroup.com


Best regards, Ruslan.


Scott T. Hildreth shildreth@allantgroup.com


Best regards, Ruslan.

Scott T. Hildreth shildret@scotth.emsphone.com

May be you’ve upgraded mysql from 4.0 to 4.1 and didn’t follow upgrade
instructions?

This is a new server, mysql 5.015. If that were the case, wouldn’t the
connect fail from the debugger as well?

This database is in “Active-Active” mode, these are 2 servers used if
fail-over. Do you think that Apache::DBI is the problem here? Maybe
I should be using or trying FastCGI. I would like to debug this, I
just not sure on how to do this.

I forgot to mention, I did resolve this. I had copied the RT_SiteConfig
from another server, which had ExtrenalAuth set on already. I hadn’t
setup the CAS authentication on this new server yet. As soon as I
turned the WebExternalAuth off, I was able to login in as root. It is
now working with CAS, no problems. Thanks for the help.

Check that mod_perl runs with perl you want, may be you run one perl
interpreter from command line, but mod_perl use another(that’s
possible).

I did a force reinstall of mod_perl2, just to make sure that wasn’t
happening. I will double check though. I am using 5.8.8 and the
vendor Perl is 5.8.3 without DBD::mysql or DBI installed. It does
show 5.8.8 in the error messages.

mod_perl?

yes mod_perl 2.02

Never mind, the hostname was pointing at the wrong IP address.

                            Thanks for listening. :-)

Well not the case. I can connect with DBIx::SearchBuilder::Handle,

DB<3> use DBIx::SearchBuilder::Handle;

DB<4> $handle = DBIx::SearchBuilder::Handle->new();

DB<5> $handle->Connect( Driver => ‘mysql’, Database => ‘rt’, Host => ‘localhost’, User => ‘rt-user’, Password => ‘rtpas’);

DB<6> x $handle
0 DBIx::SearchBuilder::Handle::mysql=HASH(0x846fb50)
‘DisconnectHandleOnDestroy’ => undef
’StatementLog’ => ARRAY(0x855f4fc)
empty array
’dsn’ => ‘dbi:mysql:dbname=rt3;host=localhost’

…I only get the error message when running in RT.

I get this in the error logs,

…failed: Client does not support authentication protocol requested by server;
consider upgrading MySQL client at /usr/local/perl-5.8.8/lib/site_perl/5.8.8/DBIx/SearchBuilder/Handle.pm line 108
[Mon Mar 06 17:17:04 2006] [error] [client 199.67.51.179] Connect Failed Client does not support authentication protocol requested by server;
consider upgrading MySQL client\n at /usr/local/rt-3.6pre0/lib/RT.pm line 176\n

…This is connecting to the localhost using the same server-client 5.0. I can connect to the rt db with
the same Perl & DBI,

/usr/packages/Perl># perl -MDBI -d -e0 5:45PM 03/06 tstest

Loading DB routines from perl5db.pl version 1.28
Editor support available.

Enter h or h h' for help, orman perldebug’ for more help.

main::(-e:1): 0
DB<1> $dbh = DBI->connect(‘dbi:mysql:dbname=rt;host=localhost’, ‘rt-user’, ‘rtpass’);

DB<2> x $dbh->tables;
0 'ACL'
1 'Attachments'
2 'Attributes'
3 'CachedGroupMembers'
4 'CustomFieldValues'
5 'CustomFields'
6 'GroupMembers'
7 'Groups'
8 'Links'
9 'Principals'
10 'Queues'
11 'ScripActions'
12 'ScripConditions'
13 'Scrips'
14 'Templates'
15 'TicketCustomFieldValues'
16 'Tickets'
17 'Transactions'
18 'Users'
19 ‘sessions

… but it fails in DBIx::SearchBuilder.

=======================================================================

perl -MDBI -e ‘DBI->installed_versions’

Perl : 5.008008 (i686-linux)
OS : linux (2.6.14.6)
DBI : 1.50
DBD::mysql : 3.0002
DBD::Sponge : 11.10
DBD::SQLite : 1.11
DBD::Proxy : 0.2004
DBD::Oracle : 1.16
DBD::Multiplex : 1.98
DBD::File : 0.33
DBD::ExampleP : 11.12
DBD::DBM : 0.03

perl -MDBIx::SearchBuilder -e ‘print $DBIx::SearchBuilder::VERSION, $/’

1.39

                                                     Any ideas?

                                                              STH


Scott T. Hildreth shildret@scotth.emsphone.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

We’re hiring! Come hack Perl for Best Practical: http://bestpractical.com/about/jobs.html


Best regards, Ruslan.


Scott T. Hildreth shildreth@allantgroup.com


Best regards, Ruslan.


Scott T. Hildreth shildreth@allantgroup.com


Best regards, Ruslan.

Scott T. Hildreth shildreth@allantgroup.com