Moving database to new server

I’m having problems moving rt3 database to another machine (both
on the production RT I did:

mysqldump -uroot -ppassword --opt rt3 > dump.sql

on the new machine I did:

make initialize-database

(database rt3 successfully created - RT webinterface works with empty

mysql -uroot -ppassword rt3 < dump.sql

I checked if the data was imported by doing:


mysql> use rt3;
mysql> select * from tickets;

(a list of all tickets is shown - data imported succesfully…)

but… opening webbrowser and surfing to the RT website shows no data -
still an empty database

did I miss something here ?

Any help appreciated,

This E-mail message and any documents which accompany it are intended only for the use of the individual or entity to which addressed, and may contain information that is privileged, confidential or exempt from disclosure under applicable law. If the reader is not the intended recipient, any disclosure, distribution or other use of this E-mail message is prohibited. If you have received this E-mail message in error, please delete and notify the sender immediately. Thank you.

I ran into this recently, but i was upgrading to the latest rt when i
moved to the new server instead of keeping same version. instead of
using make initialize-db i just created an empty db using mysqladmin,
then imported, and then I ran rt-setup-databse as needed to fix the
schemas, acl, and inserts (i upgraded from 3.0.8 to 3.4.4, the README
for 3.4.4 explains how to fix changes using the provided script).
I also had to play around with mysqldump options.
oh, i also had to change the max packet size for mysql on new server,
among other Innodb settings.

what does your mysql log say anyway?