More: RT3 / Redhat 9 / Storable.xs Error

Okay all,

Things that don’t make a difference:

using Perl 5.8.1

using Perl 5.x.x with multithread off

using Storable 2.02 - 2.07

compiling Perl with large (64-bit) integers or floating point

using 8 byte pointers

thats all for nowFrom: “Vincent J. Bono” vbono@vinny.org
To: “Hulsman, MJ (Mike)” M.J.Hulsman01@rf.rabobank.nl;
rt-users@lists.fsck.com
Sent: Wednesday, July 23, 2003 8:06 AM
Subject: Re: [rt-users] RT3 / Redhat 9 / Storable.xs Error

Hi Mike,

Yes, I have tried that. No love.

Things I have tried:

export LANG=C

backing storable down to 2.04

compiling perl-5.8.0-88 for non-multithreaded

now trying perl 5.8.1

-vb

----- Original Message -----
From: “Hulsman, MJ (Mike)” M.J.Hulsman01@rf.rabobank.nl
To: “Vincent J. Bono” vbono@vinny.org; rt-users@lists.fsck.com
Sent: Wednesday, July 23, 2003 7:56 AM
Subject: RE: [rt-users] RT3 / Redhat 9 / Storable.xs Error

Try to stop apache first
Then do an export LANG=C, start apache
That is working for me.
When my LANG=en_US… the Storable gives an error.( not always at the
moment)

-----Oorspronkelijk bericht-----
Van: Vincent J. Bono [mailto:vbono@vinny.org]
Verzonden: woensdag 23 juli 2003 6:53
Aan: rt-users@lists.fsck.com
Onderwerp: [rt-users] RT3 / Redhat 9 / Storable.xs Error

Hello All,

Has anyone yet found a solution to the Storable issue under RedHat 9?

I have noted a few other packages on the web with this same
type of error
but no fixes yet.

-vb

================================
error: Assertion flags == 0 failed: file
"Storable.xs", line 2342 at
blib/lib/Storable.pm (autosplit into
blib/lib/auto/Storable/_freeze.al) line
282.

  Stack:
  [blib/lib/Storable.pm (autosplit into

blib/lib/auto/Storable/_freeze.al):282]
[blib/lib/Storable.pm (autosplit into
blib/lib/auto/Storable/nfreeze.al):270]

[/usr/lib/perl5/site_perl/5.8.0/Apache/Session/Serialize/Stora
ble.pm:21]
[/usr/lib/perl5/site_perl/5.8.0/Apache/Session.pm:507]
[/usr/lib/perl5/site_perl/5.8.0/Apache/Session/File.pm:40]
[/usr/lib/perl5/site_perl/5.8.0/HTML/Mason/Request.pm:1056], at
/usr/lib/perl5/site_perl/5.8.0/Apache/Session/Serialize/Storab
le.pm line 21

  context:  ...
        187:  # whether they should generate a full stack trace

(confess() and cluck())
188: # or simply report the caller’s package (croak() and
carp()), respectively.
189: # confess() and croak() die, carp() and
cluck() warn.
190:
191: sub croak { die shortmess @_ }
192: sub confess { die longmess @_ }
193: sub carp { warn shortmess @_ }
194: sub cluck { warn longmess @_ }
195:

  code stack:  /usr/lib/perl5/5.8.0/Carp.pm:191
  blib/lib/Storable.pm (autosplit into

blib/lib/auto/Storable/logcroak.al):66
blib/lib/Storable.pm (autosplit into
blib/lib/auto/Storable/_freeze.al):283
blib/lib/Storable.pm (autosplit into
blib/lib/auto/Storable/nfreeze.al):270

/usr/lib/perl5/site_perl/5.8.0/Apache/Session/Serialize/Storable.pm:21
/usr/lib/perl5/site_perl/5.8.0/Apache/Session.pm:507
/usr/lib/perl5/site_perl/5.8.0/Apache/Session/File.pm:40
/usr/lib/perl5/site_perl/5.8.0/HTML/Mason/Request.pm:1056


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm

================================================
De informatie opgenomen in dit bericht kan vertrouwelijk zijn en
is uitsluitend bestemd voor de geadresseerde. Indien u dit bericht
onterecht ontvangt, wordt u verzocht de inhoud niet te gebruiken en
de afzender direct te informeren door het bericht te retourneren.

The information contained in this message may be confidential
and is intended to be exclusively for the addressee. Should you
receive this message unintentionally, please do not use the contents
herein and notify the sender immediately by return e-mail.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Hi Vincent,

Had a lot of Problems with AxKit (something different) on Red Hat 9,
which finally showed that the Perl shipping with Red Hat 9 was corrupt.

So I wrote a small installation documentation which includes a clean
installation of Perl. Even though it is not in the documentation I have
HTML::Mason running fine on that system and so far no module
installation was impossible.

You can find the documentation at:

http://www.axkit.org/wiki/view/AxKit/AxKitRedHat9

Maybe your problem can be solved if you just change LANG in
/etc/sysconfig/i18n and relogin before you recompile perl.

I haven’t had the time to test an installation of RT on that system,
but I am quite sure it could be easily done.

If that solves your problem please let me know, if not please let me
know, so that I can do a RT3 test installation on the test-system in
office.

If that goes absolutely the wrong way I am sorry fpr wasting your time.

Regards,

Benne

Am Mittwoch, 23.07.03, um 21:55 Uhr (Europe/Paris) schrieb Vincent J.
Bono: