More exim problems

Trying to install rt-1.0.7 onto RH7.1 which has Mysql 3.23.36 and Exim3.34
The install and the web are both fine…it’s the mail that is doing my noodle in.
I have trawled through the mailing lists on both fsck.com and exim.org. There are loads of items but can i get ANY of the suggestions working???NO

We use an alias file which is located in /usr/local/exim/virtual/source/aliases.tracker.getrealsupport.co.uk
This contains an alias for a queue call getreal and looks like:
getreal: “|/usr/loca/rt/bin/rt-mailgate getreal correspond”

The changes i’ve made to the exim configure file are too many to mention so i guess i’ll just include the actual file. The latest was suggested by a friend who uses a similar setup to me.

The exim log says the following when i send mail to the queue:
[root@melinda source]# tail -f /var/spool/exim/log/mainlog
2002-01-23 16:30:57 16TQIb-0006Co-00 <= slm@getreal.co.uk H=pamela.getrealnet.net (srv1.pamela.getrealnet.net) [212.90.32.71] U=root P=esmtp S=4859 id=025801c1a42b$be725f00$3300a8c0@romford.getrealnet.net
2002-01-23 16:30:57 16TQIb-0006Co-00 getreal@tracker.getrealsupport.co.uk: rt_pipe transport output: Could not send mail :frowning:
2002-01-23 16:30:57 16TQIb-0006Co-00 ** getreal@tracker.getrealsupport.co.uk D=rt T=rt_pipe: Child process of rt_pipe transport returned 9 from command: /usr/bin/perl
2002-01-23 16:30:57 16TQIb-0006Cv-00 <= <> R=16TQIb-0006Co-00 U=exim P=local S=5752
2002-01-23 16:30:57 16TQIb-0006Co-00 Error message sent to slm@getreal.co.uk
2002-01-23 16:30:57 16TQIb-0006Co-00 Completed

Now, this is different to the original failure message which reported:
2002-01-21 11:45:18 16Sct4-0004st-00 <= slm@getreal.co.uk H=pamela.getrealnet.net (srv1.pamela.getrealnet.net) [212.90.32.71] U=root P=esmtp S=4851 id=00e601c1a271$
9af47240$3300a8c0@romford.getrealnet.net
2002-01-21 11:45:18 16Sct4-0004st-00 ** |"/usr/local/rt/bin/rt-mailgate root correspond" rt@tracker.getrealsupport.co.uk D=system_aliases T=address_pipe: Child pr
ocess of address_pipe transport returned 69 (could mean service or program unavailable) from command: "/usr/local/rt/bin/rt-mailgate root correspond"
2002-01-21 11:45:18 16Sct4-0004sy-00 <= <> R=16Sct4-0004st-00 U=exim P=local S=5892

Just at the stage where all my staff are going to get thrown out of the window and high octaine coffee no longer has the desired effect.

Regards

Steve Mansfield
Technical Manager
slm@getreal.co.uk
www.getreal.co.uk

Real Data Services Ltd 117-119 Marlborough Road Romford Essex RM7 8AP
[Office] +44 [0] 1708 704433 [Fax] +44 [0] 1708 748859 [Mobile] +44 [0] 7973 864677

www.be-an-isp.com www.isdn4free.co.uk http://signup.getreal.co.uk

The information contained in this E-mail is confidential and solely for the intended
addressee(s). Unauthorised reproduction, disclosure, modification, and/or distribution
of this email may be unlawful. If you have received this email in error, please notify
the sender immediately and delete it from your system.

Real Data Services does not accept legal responsibility for the contents of this message
if it has reached you via the Internet, as Internet communications are not secure.
Any opinions expressed are those of the author and are not necessarily endorsed by the
Real Data Services.

Recipients are advised to apply their own virus checks to this message on delivery.

“Steve Mansfield” slm@getreal.co.uk writes:

Trying to install rt-1.0.7

Wjy 1.0.7? Why not RT2 or even the CVS version of RT2?

onto RH7.1 which has Mysql 3.23.36 and Exim3.34

The install and the web are both fine…it’s the mail that is doing my noodle in.

I have trawled through the mailing lists on both fsck.com and exim.org. There are loads of
items but can i get ANY of the suggestions working???NO

No need to shout, we know how frustrating it can be not to be able to
get things to work the way you want them to work.

We use an alias file which is located in
/usr/local/exim/virtual/source/aliases.tracker.getrealsupport.co.uk

This contains an alias for a queue call getreal and looks like:

getreal:��� “|/usr/loca/rt/bin/rt-mailgate getreal correspond”

�

The changes i’ve made to the exim configure file are too many to mention so i guess i’ll just
include the actual file. The latest was suggested by a friend who uses a similar setup to me.

�

The exim log says the following when i send mail to the queue:

Does RT work apart from the email queue?
Do you get any error messages from Perl scripts associated with RT?
(If rt-1.0.7 has it), does the “make fixdeps” tell you all necessary
RT packages are installed?

<snip 37 (!) lines of email signature>

regards,
Remco Brink

Remco B. Brink - Blyfri Productions AS Chief Tech Officer - http://blyfri.as
Personal site at http://rc6.org – PGP/GnuPG key at http://rc6.org/rbb.pgp