ModifySelf Privilege Prevents Login

Using ‘root’ I granted “ModifySelf” to another userName, and now I can
no longer login using “root”, neither the other user could login.

The error message that I get is:

Error "Your username or password is incorrect"

Thanks,
Behzad

I also updated the password for User ‘root’ at the MySQL level, and
still I can’t log back in using the new password for ‘root’.

-BehzadOn Sep 24, 2009, at 4:56 PM, Behzad Mahini wrote:

Using ‘root’ I granted “ModifySelf” to another userName, and now I can
no longer login using “root”, neither the other user could login.

The error message that I get is:

Error “Your username or password is incorrect”

Thanks,
Behzad


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Hoping this additional piece of Information from Apache 'error_log"
file would provide more clue for debugging:

[error]: FAILED LOGIN for root from xx.xxx.xx.xxx (/some_dir_xxx/share/
html/autohandler:268)

lines of the code within “autohandler” that the above error message is
pointing to are:

unless( $session{‘CurrentUser’} ) {
# If the user is logging in, let’s authenticate
if( defined $user && defined $pass ) {
my $user_obj = RT::CurrentUser->new;
$user_obj->Load( $user );

     unless ( $user_obj->id && $user_obj->IsPassword( $pass ) ) {
         $RT::Logger->error("FAILED LOGIN for $user from  

$ENV{‘REMOTE_ADDR’}"); <<…line 268, WHERE the complaint is
being made…>>
$m->comp( ‘/Elements/Login’, %ARGS,
Error => loc(‘Your username or password is
incorrect’),
);
$m->callback( %ARGS, CallbackName => ‘FailedLogin’ );
$m->abort;
}
$session{‘CurrentUser’} = $user_obj;
$RT::Logger->info(
“Successful login for $user from $ENV{‘REMOTE_ADDR’}”);
$m->callback( %ARGS, CallbackName => ‘SuccessfulLogin’ );
}
# if no credentials then show him login page
else {
$m->comp( ‘/Elements/Login’, %ARGS );
$m->abort;
}
}

-BehzadOn Sep 24, 2009, at 4:56 PM, Behzad Mahini wrote:

Using ‘root’ I granted “ModifySelf” to another userName, and now I can
no longer login using “root”, neither the other user could login.

The error message that I get is:

Error “Your username or password is incorrect”

Thanks,
Behzad


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Hoping this additional piece of Information from Apache 'error_log"
file would provide more clue for debugging:

Out of curiousity, is there anything interesting in your syslog or
database error log?

  1. Systemlog & MySQL log points:
    system.log file:

RT[350]: FAILED LOGIN for root from xx.xx.xx.xx (/some_dir_xx//share/
html/autohandler:268)
…<>

Mysql log files:
The only log files that I have for MySQL are binary log files and they
are:

mysql-bin.xxx0
mysql-bin.xxx1

and
ib_logfile0
ib_logfile1

…and timestamp associated to these ar as of Aug 30, 2009 (which way
before I started having my password problem of yesterday!)

  1. I rebooted my box, in the hopes of it clearing up some item that I
    am not aware of – that did not do any good

  2. Using the “RecoverRootPassword” Wiki page, I tried to change my
    password at the command/Perl level:

perl -I/opt/rt3/local/lib -I/opt/rt3/lib
-MRT -MRT::User
-e’RT::LoadConfig();RT::Init(); my $u = RT::User-

new($RT::SystemUser); $u->Load(“root”); $u->SetPassword(“secret”)'
that did not help either, and I got the following complaint:

Change of config option ‘MaxInlineBody’ at /ngs/app/rt/oppresso/
rt-3.8.4/local/plugins/RT-IR/etc/RTIR_Config.pm line 13 has been
ignored. It’s may be ok, but we want you to be aware. This option
earlier has been set in /ngs/app/rt/oppresso/rt-3.8.4/etc/
RT_SiteConfig.pm line 152. at /usr/local/src/oppresso/rt-3.8.4/lib/RT/
Config.pm line 738.

Change of config option ‘Active_MakeClicky’ at /ngs/app/rt/oppresso/
rt-3.8.4/local/plugins/RT-IR/etc/RTIR_Config.pm line 263 has been
ignored. It’s may be ok, but we want you to be aware. This option
earlier has been set in /ngs/app/rt/oppresso/rt-3.8.4/etc/
RT_SiteConfig.pm line 186. at /usr/local/src/oppresso/rt-3.8.4/lib/RT/
Config.pm line 738.

[Fri Sep 25 16:59:45 2009] [crit]: Can’t locate RT/FM.pm in @INC (@INC
contains: /usr/local/src/oppresso/rt-3.8.4/lib /ngs/app/rt/oppresso/
rt-3.8.4/lib /Library/Perl/Updates/5.8.8/darwin-thread-multi-2level /
Library/Perl/Updates/5.8.8 /System/Library/Perl/5.8.8/darwin-thread-
multi-2level /System/Library/Perl/5.8.8 /Library/Perl/5.8.8/darwin-
thread-multi-2level /Library/Perl/5.8.8 /Library/Perl /Network/Library/
Perl/5.8.8/darwin-thread-multi-2level /Network/Library/Perl/5.8.8 /
Network/Library/Perl /System/Library/Perl/Extras/5.8.8/darwin-thread-
multi-2level /System/Library/Perl/Extras/5.8.8 /Library/Perl/5.8.6 /
Library/Perl/5.8.1 .) at /usr/local/src/oppresso/rt-3.8.4/lib/RT.pm
line 627. (/usr/local/src/oppresso/rt-3.8.4/lib/RT.pm:377)

Can’t locate RT/FM.pm in @INC (@INC contains: /usr/local/src/oppresso/
rt-3.8.4/lib /ngs/app/rt/oppresso/rt-3.8.4/lib /Library/Perl/Updates/
5.8.8/darwin-thread-multi-2level /Library/Perl/Updates/5.8.8 /System/
Library/Perl/5.8.8/darwin-thread-multi-2level /System/Library/Perl/
5.8.8 /Library/Perl/5.8.8/darwin-thread-multi-2level /Library/Perl/
5.8.8 /Library/Perl /Network/Library/Perl/5.8.8/darwin-thread-
multi-2level /Network/Library/Perl/5.8.8 /Network/Library/Perl /System/
Library/Perl/Extras/5.8.8/darwin-thread-multi-2level /System/Library/
Perl/Extras/5.8.8 /Library/Perl/5.8.6 /Library/Perl/5.8.1 .) at /usr/
local/src/oppresso/rt-3.8.4/lib/RT.pm line 627.

-BehzadOn Sep 25, 2009, at 9:46 AM, Jesse Vincent wrote:

On Fri, Sep 25, 2009 at 09:03:56AM -0700, Behzad Mahini wrote:

Hoping this additional piece of Information from Apache 'error_log"
file would provide more clue for debugging:

Out of curiousity, is there anything interesting in your syslog or
database error log?

====
[error]: FAILED LOGIN for root from xx.xxx.xx.xxx (/some_dir_xxx/
share/
html/autohandler:268)

lines of the code within “autohandler” that the above error message
is
pointing to are:

====
unless( $session{‘CurrentUser’} ) {
# If the user is logging in, let’s authenticate
if( defined $user && defined $pass ) {
my $user_obj = RT::CurrentUser->new;
$user_obj->Load( $user );

    unless ( $user_obj->id && $user_obj->IsPassword( $pass ) ) {
        $RT::Logger->error("FAILED LOGIN for $user from

$ENV{‘REMOTE_ADDR’}"); <<…line 268, WHERE the complaint is
being made…>>
$m->comp( ‘/Elements/Login’, %ARGS,
Error => loc(‘Your username or password is
incorrect’),
);
$m->callback( %ARGS, CallbackName => ‘FailedLogin’ );
$m->abort;
}
$session{‘CurrentUser’} = $user_obj;
$RT::Logger->info(
“Successful login for $user from $ENV{‘REMOTE_ADDR’}”);
$m->callback( %ARGS, CallbackName => ‘SuccessfulLogin’ );
}
# if no credentials then show him login page
else {
$m->comp( ‘/Elements/Login’, %ARGS );
$m->abort;
}
}

====

-Behzad
On Sep 24, 2009, at 4:56 PM, Behzad Mahini wrote:

Using ‘root’ I granted “ModifySelf” to another userName, and now I
can
no longer login using “root”, neither the other user could login.

The error message that I get is:

Error “Your username or password is incorrect”

Thanks,
Behzad


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

…I also looked at the real mysql log file (i.e., “
.err”), and that did not reveal any worthy information,
besides its timestamp was also as of Aug 30th (again way before my
password problem of last night).

-BehzadOn Sep 25, 2009, at 10:25 AM, Behzad Mahini wrote:

  1. Systemlog & MySQL log points:
    ==========================
    system.log file:

RT[350]: FAILED LOGIN for root from xx.xx.xx.xx (/some_dir_xx//share/
html/autohandler:268)
…<>

Mysql log files:
The only log files that I have for MySQL are binary log files and
they are:

mysql-bin.xxx0
mysql-bin.xxx1

and
ib_logfile0
ib_logfile1

…and timestamp associated to these ar as of Aug 30, 2009 (which way
before I started having my password problem of yesterday!)

  1. I rebooted my box, in the hopes of it clearing up some item that
    I am not aware of – that did not do any good
    ===============================================================

  2. Using the “RecoverRootPassword” Wiki page, I tried to change my
    password at the command/Perl level:
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    ======================================================================

perl -I/opt/rt3/local/lib -I/opt/rt3/lib
-MRT -MRT::User
-e’RT::LoadConfig();RT::Init(); my $u = RT::User-

new($RT::SystemUser); $u->Load(“root”); $u->SetPassword(“secret”)'
that did not help either, and I got the following complaint:

Change of config option ‘MaxInlineBody’ at /ngs/app/rt/oppresso/
rt-3.8.4/local/plugins/RT-IR/etc/RTIR_Config.pm line 13 has been
ignored. It’s may be ok, but we want you to be aware. This option
earlier has been set in /ngs/app/rt/oppresso/rt-3.8.4/etc/
RT_SiteConfig.pm line 152. at /usr/local/src/oppresso/rt-3.8.4/lib/
RT/Config.pm line 738.

Change of config option ‘Active_MakeClicky’ at /ngs/app/rt/oppresso/
rt-3.8.4/local/plugins/RT-IR/etc/RTIR_Config.pm line 263 has been
ignored. It’s may be ok, but we want you to be aware. This option
earlier has been set in /ngs/app/rt/oppresso/rt-3.8.4/etc/
RT_SiteConfig.pm line 186. at /usr/local/src/oppresso/rt-3.8.4/lib/
RT/Config.pm line 738.

[Fri Sep 25 16:59:45 2009] [crit]: Can’t locate RT/FM.pm in @INC
(@INC contains: /usr/local/src/oppresso/rt-3.8.4/lib /ngs/app/rt/
oppresso/rt-3.8.4/lib /Library/Perl/Updates/5.8.8/darwin-thread-
multi-2level /Library/Perl/Updates/5.8.8 /System/Library/Perl/5.8.8/
darwin-thread-multi-2level /System/Library/Perl/5.8.8 /Library/Perl/
5.8.8/darwin-thread-multi-2level /Library/Perl/5.8.8 /Library/Perl /
Network/Library/Perl/5.8.8/darwin-thread-multi-2level /Network/
Library/Perl/5.8.8 /Network/Library/Perl /System/Library/Perl/Extras/
5.8.8/darwin-thread-multi-2level /System/Library/Perl/Extras/5.8.8 /
Library/Perl/5.8.6 /Library/Perl/5.8.1 .) at /usr/local/src/oppresso/
rt-3.8.4/lib/RT.pm line 627. (/usr/local/src/oppresso/rt-3.8.4/lib/
RT.pm:377)

Can’t locate RT/FM.pm in @INC (@INC contains: /usr/local/src/
oppresso/rt-3.8.4/lib /ngs/app/rt/oppresso/rt-3.8.4/lib /Library/
Perl/Updates/5.8.8/darwin-thread-multi-2level /Library/Perl/Updates/
5.8.8 /System/Library/Perl/5.8.8/darwin-thread-multi-2level /System/
Library/Perl/5.8.8 /Library/Perl/5.8.8/darwin-thread-multi-2level /
Library/Perl/5.8.8 /Library/Perl /Network/Library/Perl/5.8.8/darwin-
thread-multi-2level /Network/Library/Perl/5.8.8 /Network/Library/
Perl /System/Library/Perl/Extras/5.8.8/darwin-thread-multi-2level /
System/Library/Perl/Extras/5.8.8 /Library/Perl/5.8.6 /Library/Perl/
5.8.1 .) at /usr/local/src/oppresso/rt-3.8.4/lib/RT.pm line 627.

-Behzad
On Sep 25, 2009, at 9:46 AM, Jesse Vincent wrote:

On Fri, Sep 25, 2009 at 09:03:56AM -0700, Behzad Mahini wrote:

Hoping this additional piece of Information from Apache 'error_log"
file would provide more clue for debugging:

Out of curiousity, is there anything interesting in your syslog or
database error log?

====
[error]: FAILED LOGIN for root from xx.xxx.xx.xxx (/some_dir_xxx/
share/
html/autohandler:268)

lines of the code within “autohandler” that the above error
message is
pointing to are:

====
unless( $session{‘CurrentUser’} ) {
# If the user is logging in, let’s authenticate
if( defined $user && defined $pass ) {
my $user_obj = RT::CurrentUser->new;
$user_obj->Load( $user );

    unless ( $user_obj->id && $user_obj->IsPassword( $pass ) ) {
        $RT::Logger->error("FAILED LOGIN for $user from

$ENV{‘REMOTE_ADDR’}"); <<…line 268, WHERE the complaint is
being made…>>
$m->comp( ‘/Elements/Login’, %ARGS,
Error => loc(‘Your username or password is
incorrect’),
);
$m->callback( %ARGS, CallbackName => ‘FailedLogin’ );
$m->abort;
}
$session{‘CurrentUser’} = $user_obj;
$RT::Logger->info(
“Successful login for $user from $ENV{‘REMOTE_ADDR’}”);
$m->callback( %ARGS, CallbackName => ‘SuccessfulLogin’ );
}
# if no credentials then show him login page
else {
$m->comp( ‘/Elements/Login’, %ARGS );
$m->abort;
}
}

====

-Behzad
On Sep 24, 2009, at 4:56 PM, Behzad Mahini wrote:

Using ‘root’ I granted “ModifySelf” to another userName, and now
I can
no longer login using “root”, neither the other user could login.

The error message that I get is:

Error “Your username or password is incorrect”

Thanks,
Behzad


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly
Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Since I had installed RT-FM & RT-IR, …at the command line using the
Perl command I decided to include the paths to RT-FM & RT-IR libraries
(Plugins), and the error message changed (from what I had sent
earlier) to the following:

$sudo perl -I/usr/local/src/oppresso/rt-3.8.4/lib -I/ngs/app/rt/
oppresso/rt-3.8.4/lib -I/ngs/app/rt/oppresso/rt-3.8.4/local/plugins/RT-
FM/lib -I/ngs/app/rt/oppresso/rt-3.8.4/local/plugins/RT-IR/lib -e
’RT::LoadConfig(); RT::Init(); my $u = RT::User->new($RT::SystemUser);
$u->Load(“root”); $u->setPassword("<my_secret_pass>")’

Undefined subroutine &RT::LoadConfig called at -e line 1.

So, without Including the path to Plugins, it complains about “RT/
FM.pm” which was missing in the Included paths I had the first round,
and I addressed it above, but it now complains about
"RT::LoadConfig()", which it should be able to grab from:

/my_above_path_2_RT/lib/RT.pm  ........(<<sub LoadConfig {require  

RT::Config …} >>
& /my_above_path_2_RT/RT/Config.pm

So, why is complaining?

Thanks,
BehzadOn Sep 25, 2009, at 10:47 AM, Behzad Mahini wrote:

…I also looked at the real mysql log file (i.e., “
.err”), and that did not reveal any worthy information,
besides its timestamp was also as of Aug 30th (again way before my
password problem of last night).

-Behzad
On Sep 25, 2009, at 10:25 AM, Behzad Mahini wrote:

  1. Systemlog & MySQL log points:
    ==========================
    system.log file:

RT[350]: FAILED LOGIN for root from xx.xx.xx.xx (/some_dir_xx//
share/html/autohandler:268)
…<>

Mysql log files:
The only log files that I have for MySQL are binary log files and
they are:

mysql-bin.xxx0
mysql-bin.xxx1

and
ib_logfile0
ib_logfile1

…and timestamp associated to these ar as of Aug 30, 2009 (which
way before I started having my password problem of yesterday!)

  1. I rebooted my box, in the hopes of it clearing up some item that
    I am not aware of – that did not do any good
    ===============================================================

  2. Using the “RecoverRootPassword” Wiki page, I tried to change my
    password at the command/Perl level:
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =====================================================================

perl -I/opt/rt3/local/lib -I/opt/rt3/lib
-MRT -MRT::User
-e’RT::LoadConfig();RT::Init(); my $u = RT::User-

new($RT::SystemUser); $u->Load(“root”); $u->SetPassword(“secret”)'
that did not help either, and I got the following complaint:

Change of config option ‘MaxInlineBody’ at /ngs/app/rt/oppresso/
rt-3.8.4/local/plugins/RT-IR/etc/RTIR_Config.pm line 13 has been
ignored. It’s may be ok, but we want you to be aware. This option
earlier has been set in /ngs/app/rt/oppresso/rt-3.8.4/etc/
RT_SiteConfig.pm line 152. at /usr/local/src/oppresso/rt-3.8.4/lib/
RT/Config.pm line 738.

Change of config option ‘Active_MakeClicky’ at /ngs/app/rt/oppresso/
rt-3.8.4/local/plugins/RT-IR/etc/RTIR_Config.pm line 263 has been
ignored. It’s may be ok, but we want you to be aware. This option
earlier has been set in /ngs/app/rt/oppresso/rt-3.8.4/etc/
RT_SiteConfig.pm line 186. at /usr/local/src/oppresso/rt-3.8.4/lib/
RT/Config.pm line 738.

[Fri Sep 25 16:59:45 2009] [crit]: Can’t locate RT/FM.pm in @INC
(@INC contains: /usr/local/src/oppresso/rt-3.8.4/lib /ngs/app/rt/
oppresso/rt-3.8.4/lib /Library/Perl/Updates/5.8.8/darwin-thread-
multi-2level /Library/Perl/Updates/5.8.8 /System/Library/Perl/5.8.8/
darwin-thread-multi-2level /System/Library/Perl/5.8.8 /Library/Perl/
5.8.8/darwin-thread-multi-2level /Library/Perl/5.8.8 /Library/Perl /
Network/Library/Perl/5.8.8/darwin-thread-multi-2level /Network/
Library/Perl/5.8.8 /Network/Library/Perl /System/Library/Perl/
Extras/5.8.8/darwin-thread-multi-2level /System/Library/Perl/Extras/
5.8.8 /Library/Perl/5.8.6 /Library/Perl/5.8.1 .) at /usr/local/src/
oppresso/rt-3.8.4/lib/RT.pm line 627. (/usr/local/src/oppresso/
rt-3.8.4/lib/RT.pm:377)

Can’t locate RT/FM.pm in @INC (@INC contains: /usr/local/src/
oppresso/rt-3.8.4/lib /ngs/app/rt/oppresso/rt-3.8.4/lib /Library/
Perl/Updates/5.8.8/darwin-thread-multi-2level /Library/Perl/Updates/
5.8.8 /System/Library/Perl/5.8.8/darwin-thread-multi-2level /System/
Library/Perl/5.8.8 /Library/Perl/5.8.8/darwin-thread-multi-2level /
Library/Perl/5.8.8 /Library/Perl /Network/Library/Perl/5.8.8/darwin-
thread-multi-2level /Network/Library/Perl/5.8.8 /Network/Library/
Perl /System/Library/Perl/Extras/5.8.8/darwin-thread-multi-2level /
System/Library/Perl/Extras/5.8.8 /Library/Perl/5.8.6 /Library/Perl/
5.8.1 .) at /usr/local/src/oppresso/rt-3.8.4/lib/RT.pm line 627.

-Behzad
On Sep 25, 2009, at 9:46 AM, Jesse Vincent wrote:

Good News & bad News (for me it is still bad News)…I took care of
the complaint about “Undefined subroutine &RT::LoadConfig()”, by
placing all of the following lines in a single file (i.e.,
replace_password.pl), and executing the following code from the
command line (I simply replaced the command-line portion “-MRT -
MRT::User” with a single line of “use RT;” in the following code):

  1. code:
    #!/usr/bin/perl -w

use lib ‘/usr/local/src/oppresso/rt-3.8.4/lib’;
use lib ‘/ngs/app/rt/oppresso/rt-3.8.4/lib’;
use lib ‘/ngs/app/rt/oppresso/rt-3.8.4/local/plugins/RT-FM/lib’; #if
using RTFM
use lib ‘/ngs/app/rt/oppresso/rt-3.8.4/local/plugins/RT-IR/lib’; #if
using RTIR
use RT;

RT::LoadConfig();
RT::Init();

my $u = RT::User->new($RT::SystemUser);
$u->Load(“root”);
$u->setPassword(“secret”);

  1. Executing it:
    $sudo ./replace_password.pl

Change of config option ‘MaxInlineBody’ at /ngs/app/rt/oppresso/
rt-3.8.4/local/plugins/RT-IR/etc/RTIR_Config.pm line 13 has been
ignored. It’s may be ok, but we want you to be aware. This option
earlier has been set in /ngs/app/rt/oppresso/rt-3.8.4/etc/
RT_SiteConfig.pm line 152. at /ngs/app/rt/oppresso/rt-3.8.4/lib/RT/
Config.pm line 738.
Change of config option ‘Active_MakeClicky’ at /ngs/app/rt/oppresso/
rt-3.8.4/local/plugins/RT-IR/etc/RTIR_Config.pm line 263 has been
ignored. It’s may be ok, but we want you to be aware. This option
earlier has been set in /ngs/app/rt/oppresso/rt-3.8.4/etc/
RT_SiteConfig.pm line 186. at /ngs/app/rt/oppresso/rt-3.8.4/lib/RT/
Config.pm line 738.

  1. Assumptions:

I am assuming the above lines (per http://wiki.bestpractical.com/view/RecoverRootPassword)
are sufficient.

4)Results:
I did not get any other warnings (or error messages), which was good.
However, I still can not log back in (using root) from the UI. The
above warnings I received were trivial, so I am ignoring them.

Help please.

-BehzadOn Sep 25, 2009, at 1:58 PM, Behzad Mahini wrote:

Since I had installed RT-FM & RT-IR, …at the command line using
the Perl command I decided to include the paths to RT-FM & RT-IR
libraries (Plugins), and the error message changed (from what I had
sent earlier) to the following:

$sudo perl -I/usr/local/src/oppresso/rt-3.8.4/lib -I/ngs/app/rt/
oppresso/rt-3.8.4/lib -I/ngs/app/rt/oppresso/rt-3.8.4/local/plugins/
RT-FM/lib -I/ngs/app/rt/oppresso/rt-3.8.4/local/plugins/RT-IR/lib -
e 'RT::LoadConfig(); RT::Init(); my $u = RT::User-

new($RT::SystemUser); $u->Load(“root”); $u-
setPassword("<my_secret_pass>")’

Undefined subroutine &RT::LoadConfig called at -e line 1.

So, without Including the path to Plugins, it complains about “RT/
FM.pm” which was missing in the Included paths I had the first
round, and I addressed it above, but it now complains about
"RT::LoadConfig()", which it should be able to grab from:

/my_above_path_2_RT/lib/RT.pm …(<<sub LoadConfig {require
RT::Config …} >>
& /my_above_path_2_RT/RT/Config.pm

So, why is complaining?

Thanks,
Behzad
On Sep 25, 2009, at 10:47 AM, Behzad Mahini wrote:

…I also looked at the real mysql log file (i.e., “
.err”), and that did not reveal any worthy information,
besides its timestamp was also as of Aug 30th (again way before my
password problem of last night).

-Behzad
On Sep 25, 2009, at 10:25 AM, Behzad Mahini wrote:

  1. Systemlog & MySQL log points:
    ==========================
    system.log file:

RT[350]: FAILED LOGIN for root from xx.xx.xx.xx (/some_dir_xx//
share/html/autohandler:268)
…<>

Mysql log files:
The only log files that I have for MySQL are binary log files and
they are:

mysql-bin.xxx0
mysql-bin.xxx1

and
ib_logfile0
ib_logfile1

…and timestamp associated to these ar as of Aug 30, 2009 (which
way before I started having my password problem of yesterday!)

  1. I rebooted my box, in the hopes of it clearing up some item
    that I am not aware of – that did not do any good
    ===============================================================

  2. Using the “RecoverRootPassword” Wiki page, I tried to change my
    password at the command/Perl level:
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    ====================================================================

perl -I/opt/rt3/local/lib -I/opt/rt3/lib
-MRT -MRT::User
-e’RT::LoadConfig();RT::Init(); my $u = RT::User-

new($RT::SystemUser); $u->Load(“root”); $u->SetPassword(“secret”)'
that did not help either, and I got the following complaint:

Change of config option ‘MaxInlineBody’ at /ngs/app/rt/oppresso/
rt-3.8.4/local/plugins/RT-IR/etc/RTIR_Config.pm line 13 has been
ignored. It’s may be ok, but we want you to be aware. This option
earlier has been set in /ngs/app/rt/oppresso/rt-3.8.4/etc/
RT_SiteConfig.pm line 152. at /usr/local/src/oppresso/rt-3.8.4/lib/
RT/Config.pm line 738.

Change of config option ‘Active_MakeClicky’ at /ngs/app/rt/
oppresso/rt-3.8.4/local/plugins/RT-IR/etc/RTIR_Config.pm line 263
has been ignored. It’s may be ok, but we want you to be aware.
This option earlier has been set in /ngs/app/rt/oppresso/rt-3.8.4/
etc/RT_SiteConfig.pm line 186. at /usr/local/src/oppresso/rt-3.8.4/
lib/RT/Config.pm line 738.

[Fri Sep 25 16:59:45 2009] [crit]: Can’t locate RT/FM.pm in @INC
(@INC contains: /usr/local/src/oppresso/rt-3.8.4/lib /ngs/app/rt/
oppresso/rt-3.8.4/lib /Library/Perl/Updates/5.8.8/darwin-thread-
multi-2level /Library/Perl/Updates/5.8.8 /System/Library/Perl/
5.8.8/darwin-thread-multi-2level /System/Library/Perl/5.8.8 /
Library/Perl/5.8.8/darwin-thread-multi-2level /Library/Perl/5.8.8 /
Library/Perl /Network/Library/Perl/5.8.8/darwin-thread-
multi-2level /Network/Library/Perl/5.8.8 /Network/Library/Perl /
System/Library/Perl/Extras/5.8.8/darwin-thread-multi-2level /
System/Library/Perl/Extras/5.8.8 /Library/Perl/5.8.6 /Library/Perl/
5.8.1 .) at /usr/local/src/oppresso/rt-3.8.4/lib/RT.pm line 627. (/
usr/local/src/oppresso/rt-3.8.4/lib/RT.pm:377)

Can’t locate RT/FM.pm in @INC (@INC contains: /usr/local/src/
oppresso/rt-3.8.4/lib /ngs/app/rt/oppresso/rt-3.8.4/lib /Library/
Perl/Updates/5.8.8/darwin-thread-multi-2level /Library/Perl/
Updates/5.8.8 /System/Library/Perl/5.8.8/darwin-thread-
multi-2level /System/Library/Perl/5.8.8 /Library/Perl/5.8.8/darwin-
thread-multi-2level /Library/Perl/5.8.8 /Library/Perl /Network/
Library/Perl/5.8.8/darwin-thread-multi-2level /Network/Library/
Perl/5.8.8 /Network/Library/Perl /System/Library/Perl/Extras/5.8.8/
darwin-thread-multi-2level /System/Library/Perl/Extras/5.8.8 /
Library/Perl/5.8.6 /Library/Perl/5.8.1 .) at /usr/local/src/
oppresso/rt-3.8.4/lib/RT.pm line 627.

-Behzad
On Sep 25, 2009, at 9:46 AM, Jesse Vincent wrote:


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

my $u = RT::User->new($RT::SystemUser);
$u->Load(“root”);

add this line:

warn $u->id;

replace this line

$u->setPassword(“secret”);

with:

my ($val,$msg) = $u->setPassword(“secret”);

warn $val, $msg;

Here is what I received (and 12 matches with the id for my ‘root’)

[Sat Sep 26 01:25:15 2009] [warning]: 12 at ./replace_password.pl line
15. (./replace_password.pl:15)
[Sat Sep 26 01:25:15 2009] [warning]: 0That is already the current
value at ./replace_password.pl line 20. (./replace_password.pl:20)

-BehzadOn Sep 25, 2009, at 4:43 PM, Jesse Vincent wrote:

my $u = RT::User->new($RT::SystemUser);
$u->Load(“root”);

add this line:

warn $u->id;

replace this line

$u->setPassword(“secret”);

with:

my ($val,$msg) = $u->setPassword(“secret”);

warn $val, $msg;

  1. Executing it:
    ============
    $sudo ./replace_password.pl

Change of config option ‘MaxInlineBody’ at /ngs/app/rt/oppresso/
rt-3.8.4/local/plugins/RT-IR/etc/RTIR_Config.pm line 13 has been
ignored. It’s may be ok, but we want you to be aware. This option
earlier has been set in /ngs/app/rt/oppresso/rt-3.8.4/etc/
RT_SiteConfig.pm line 152. at /ngs/app/rt/oppresso/rt-3.8.4/lib/RT/
Config.pm line 738.
Change of config option ‘Active_MakeClicky’ at /ngs/app/rt/oppresso/
rt-3.8.4/local/plugins/RT-IR/etc/RTIR_Config.pm line 263 has been
ignored. It’s may be ok, but we want you to be aware. This option
earlier has been set in /ngs/app/rt/oppresso/rt-3.8.4/etc/
RT_SiteConfig.pm line 186. at /ngs/app/rt/oppresso/rt-3.8.4/lib/RT/
Config.pm line 738.

  1. Assumptions:
    =============

I am assuming the above lines (per
http://wiki.bestpractical.com/view/RecoverRootPassword) are
sufficient.

4)Results:

I did not get any other warnings (or error messages), which was good.
However, I still can not log back in (using root) from the UI. The
above warnings I received were trivial, so I am ignoring them.

Help please.

-Behzad

On Sep 25, 2009, at 1:58 PM, Behzad Mahini wrote:

Since I had installed RT-FM & RT-IR, …at the command line using
the Perl command I decided to include the paths to RT-FM & RT-IR
libraries (Plugins), and the error message changed (from what I had
sent earlier) to the following:

$sudo perl -I/usr/local/src/oppresso/rt-3.8.4/lib -I/ngs/app/rt/
oppresso/rt-3.8.4/lib -I/ngs/app/rt/oppresso/rt-3.8.4/local/plugins/
RT-FM/lib -I/ngs/app/rt/oppresso/rt-3.8.4/local/plugins/RT-IR/
lib -
e 'RT::LoadConfig(); RT::Init(); my $u = RT::User-

new($RT::SystemUser); $u->Load(“root”); $u-
setPassword("<my_secret_pass>")’

Undefined subroutine &RT::LoadConfig called at -e line 1.

So, without Including the path to Plugins, it complains about “RT/
FM.pm” which was missing in the Included paths I had the first
round, and I addressed it above, but it now complains about
"RT::LoadConfig()", which it should be able to grab from:

/my_above_path_2_RT/lib/RT.pm …(<<sub LoadConfig {require
RT::Config …} >>
& /my_above_path_2_RT/RT/Config.pm

So, why is complaining?

Thanks,
Behzad
On Sep 25, 2009, at 10:47 AM, Behzad Mahini wrote:

…I also looked at the real mysql log file (i.e., “
.err”), and that did not reveal any worthy information,
besides its timestamp was also as of Aug 30th (again way before my
password problem of last night).

-Behzad
On Sep 25, 2009, at 10:25 AM, Behzad Mahini wrote:

  1. Systemlog & MySQL log points:
    ==========================
    system.log file:

RT[350]: FAILED LOGIN for root from xx.xx.xx.xx (/some_dir_xx//
share/html/autohandler:268)
…<>

Mysql log files:
The only log files that I have for MySQL are binary log files and
they are:

mysql-bin.xxx0
mysql-bin.xxx1

and
ib_logfile0
ib_logfile1

…and timestamp associated to these ar as of Aug 30, 2009 (which
way before I started having my password problem of yesterday!)

  1. I rebooted my box, in the hopes of it clearing up some item
    that I am not aware of – that did not do any good
    ===============================================================

  2. Using the “RecoverRootPassword” Wiki page, I tried to change my
    password at the command/Perl level:
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    =
    ==================================================================

perl -I/opt/rt3/local/lib -I/opt/rt3/lib
-MRT -MRT::User
-e’RT::LoadConfig();RT::Init(); my $u = RT::User-

new($RT::SystemUser); $u->Load(“root”); $u-

SetPassword(“secret”)'
that did not help either, and I got the following complaint:

Change of config option ‘MaxInlineBody’ at /ngs/app/rt/oppresso/
rt-3.8.4/local/plugins/RT-IR/etc/RTIR_Config.pm line 13 has been
ignored. It’s may be ok, but we want you to be aware. This option
earlier has been set in /ngs/app/rt/oppresso/rt-3.8.4/etc/
RT_SiteConfig.pm line 152. at /usr/local/src/oppresso/rt-3.8.4/
lib/
RT/Config.pm line 738.

Change of config option ‘Active_MakeClicky’ at /ngs/app/rt/
oppresso/rt-3.8.4/local/plugins/RT-IR/etc/RTIR_Config.pm line 263
has been ignored. It’s may be ok, but we want you to be aware.
This option earlier has been set in /ngs/app/rt/oppresso/rt-3.8.4/
etc/RT_SiteConfig.pm line 186. at /usr/local/src/oppresso/
rt-3.8.4/
lib/RT/Config.pm line 738.

[Fri Sep 25 16:59:45 2009] [crit]: Can’t locate RT/FM.pm in @INC
(@INC contains: /usr/local/src/oppresso/rt-3.8.4/lib /ngs/app/rt/
oppresso/rt-3.8.4/lib /Library/Perl/Updates/5.8.8/darwin-thread-
multi-2level /Library/Perl/Updates/5.8.8 /System/Library/Perl/
5.8.8/darwin-thread-multi-2level /System/Library/Perl/5.8.8 /
Library/Perl/5.8.8/darwin-thread-multi-2level /Library/Perl/
5.8.8 /
Library/Perl /Network/Library/Perl/5.8.8/darwin-thread-
multi-2level /Network/Library/Perl/5.8.8 /Network/Library/Perl /
System/Library/Perl/Extras/5.8.8/darwin-thread-multi-2level /
System/Library/Perl/Extras/5.8.8 /Library/Perl/5.8.6 /Library/
Perl/
5.8.1 .) at /usr/local/src/oppresso/rt-3.8.4/lib/RT.pm line 627.
(/
usr/local/src/oppresso/rt-3.8.4/lib/RT.pm:377)

Can’t locate RT/FM.pm in @INC (@INC contains: /usr/local/src/
oppresso/rt-3.8.4/lib /ngs/app/rt/oppresso/rt-3.8.4/lib /Library/
Perl/Updates/5.8.8/darwin-thread-multi-2level /Library/Perl/
Updates/5.8.8 /System/Library/Perl/5.8.8/darwin-thread-
multi-2level /System/Library/Perl/5.8.8 /Library/Perl/5.8.8/
darwin-
thread-multi-2level /Library/Perl/5.8.8 /Library/Perl /Network/
Library/Perl/5.8.8/darwin-thread-multi-2level /Network/Library/
Perl/5.8.8 /Network/Library/Perl /System/Library/Perl/Extras/
5.8.8/
darwin-thread-multi-2level /System/Library/Perl/Extras/5.8.8 /
Library/Perl/5.8.6 /Library/Perl/5.8.1 .) at /usr/local/src/
oppresso/rt-3.8.4/lib/RT.pm line 627.

-Behzad
On Sep 25, 2009, at 9:46 AM, Jesse Vincent wrote:


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Here is what I received (and 12 matches with the id for my ‘root’)

[Sat Sep 26 01:25:15 2009] [warning]: 12 at ./replace_password.pl line
15. (./replace_password.pl:15)
[Sat Sep 26 01:25:15 2009] [warning]: 0That is already the current
value at ./replace_password.pl line 20. (./replace_password.pl:20)

Have you configured any sort of external authentication for RT or made
any other code customizations?

None whatsoever. Everything was working fine prior to the ModifySelf
change of mine, and all I wanted to do was grant my users the
privilege to be able to change their own passwords, using:

Configuration > Global > User Rights > user_xyz was Granted ModifySelf

-BehzadOn Sep 28, 2009, at 8:32 AM, Jesse Vincent wrote:

On Fri, Sep 25, 2009 at 06:28:09PM -0700, Behzad Mahini wrote:

Here is what I received (and 12 matches with the id for my ‘root’)

[Sat Sep 26 01:25:15 2009] [warning]: 12 at ./replace_password.pl
line
15. (./replace_password.pl:15)
[Sat Sep 26 01:25:15 2009] [warning]: 0That is already the current
value at ./replace_password.pl line 20. (./replace_password.pl:20)

Have you configured any sort of external authentication for RT or made
any other code customizations?

None whatsoever. Everything was working fine prior to the ModifySelf
change of mine, and all I wanted to do was grant my users the
privilege to be able to change their own passwords, using:

Configuration > Global > User Rights > user_xyz was Granted
ModifySelf

Can any of your other users log in?

Only the un-privilged ones.

-BehzadOn Sep 28, 2009, at 8:50 AM, Behzad Mahini wrote:

Only the un-privilged ones.

-Behzad
On Sep 28, 2009, at 8:44 AM, Jesse Vincent wrote:

On Mon, Sep 28, 2009 at 08:42:11AM -0700, Behzad Mahini wrote:

None whatsoever. Everything was working fine prior to the ModifySelf
change of mine, and all I wanted to do was grant my users the
privilege to be able to change their own passwords, using:

Configuration > Global > User Rights > user_xyz was Granted
ModifySelf

Can any of your other users log in?

-Behzad

On Sep 28, 2009, at 8:32 AM, Jesse Vincent wrote:

On Fri, Sep 25, 2009 at 06:28:09PM -0700, Behzad Mahini wrote:

Here is what I received (and 12 matches with the id for my ‘root’)

[Sat Sep 26 01:25:15 2009] [warning]: 12 at ./replace_password.pl
line
15. (./replace_password.pl:15)
[Sat Sep 26 01:25:15 2009] [warning]: 0That is already the current
value at ./replace_password.pl line 20. (./replace_password.pl:20)

Have you configured any sort of external authentication for RT or
made
any other code customizations?

Only the un-privilged ones.

I’m stumped. Without looking into your RT, I’m not sure what’s going
wrong.

So in my situation, I have to do a re-installation of 3.8.4 (and RT-FM
& RT-IR). Are the following steps in the sequence listed below
correct (if anything missing, please comment):

  1. back up MySQL (mysqldump…)
  2. backup (copy) my existing RT_SiteConfig.pm – to replace the one
    that gets installed as part of the following steps
    Using Ref: http://wiki.bestpractical.com/view/ManualInstallation
  3. Drop DB:
    make dropdb
  4. No need to do another “make testdeps” & “make fixdeps” – (as they
    were previously done)
  5. Init DB:
    make install
    make initialize-database
  6. Restore the database (backed up per step 1)
    Question:
    If I restore the backedup database (per step 1), will I not again
    cause the same set of problems I had encountered before?
  7. Stop & restart the Webserver (Apache).

Thanks,
BehzadOn Sep 28, 2009, at 12:57 PM, Jesse Vincent wrote:

On Mon, Sep 28, 2009 at 08:52:35AM -0700, Behzad Mahini wrote:

Only the un-privilged ones.

I’m stumped. Without looking into your RT, I’m not sure what’s going
wrong.

-Behzad
On Sep 28, 2009, at 8:50 AM, Behzad Mahini wrote:

Only the un-privilged ones.

-Behzad
On Sep 28, 2009, at 8:44 AM, Jesse Vincent wrote:

On Mon, Sep 28, 2009 at 08:42:11AM -0700, Behzad Mahini wrote:

None whatsoever. Everything was working fine prior to the
ModifySelf
change of mine, and all I wanted to do was grant my users the
privilege to be able to change their own passwords, using:

Configuration > Global > User Rights > user_xyz was Granted
ModifySelf

Can any of your other users log in?

-Behzad

On Sep 28, 2009, at 8:32 AM, Jesse Vincent wrote:

On Fri, Sep 25, 2009 at 06:28:09PM -0700, Behzad Mahini wrote:

Here is what I received (and 12 matches with the id for my
’root’)

[Sat Sep 26 01:25:15 2009] [warning]: 12 at ./
replace_password.pl
line
15. (./replace_password.pl:15)
[Sat Sep 26 01:25:15 2009] [warning]: 0That is already the
current
value at ./replace_password.pl line 20. (./replace_password.pl:
20)

Have you configured any sort of external authentication for RT or
made
any other code customizations?