MISSING dependencies

Hi,

I deleted some perl things, reinstalled perl etc…
Now executing the rt-test-dependencies and i see alot missing
dependencies.
So i install them with CPAN and i get the message that the module is up
to date, or installed but when i re-excute the dependency command i
still get all those MISSINGS…
What could go wrong ?

Grtz,
Philippe

Philippe Dhont (Sea-ro) wrote:

Hi,

I deleted some perl things, reinstalled perl etc…
Now executing the rt-test-dependencies and i see alot missing
dependencies.
So i install them with CPAN and i get the message that the module is up
to date, or installed but when i re-excute the dependency command i
still get all those MISSINGS…
What could go wrong ?
You run CPAN and rt-test-dependencies tools with different versions of
perl interpreter.

Please, send us output of perl -V and result of rt-test-dependencies
script.

Hi,

This is the result:

Perl -V:

Summary of my perl5 (revision 5 version 8 subversion 5) configuration:
Platform:
osname=linux, osvers=2.6.5, archname=i686-linux
uname=‘linux zabbix 2.6.5 #4 tue apr 27 16:02:14 cest 2004 i686
gnulinux ‘
config_args=’-de’
hint=recommended, useposix=true, d_sigaction=define
usethreads=undef use5005threads=undef useithreads=undef
usemultiplicity=undef
useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
use64bitint=undef use64bitall=undef uselongdouble=undef
usemymalloc=n, bincompat5005=undef
Compiler:
cc=‘cc’, ccflags =’-fno-strict-aliasing -pipe -I/usr/local/include
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64’,
optimize=’-O2’,
cppflags=’-fno-strict-aliasing -pipe -I/usr/local/include’
ccversion=’’, gccversion=‘3.3.3 (Debian 20040401)’, gccosandvers=’‘
intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
ivtype=‘long’, ivsize=4, nvtype=‘double’, nvsize=8, Off_t=‘off_t’,
lseeksize=8
alignbytes=4, prototype=define
Linker and Libraries:
ld=‘cc’, ldflags =’ -L/usr/local/lib’
libpth=/usr/local/lib /lib /usr/lib
libs=-lnsl -ldl -lm -lcrypt -lutil -lc
perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc
libc=/lib/libc-2.3.2.so, so=so, useshrplib=false, libperl=libperl.a
gnulibc_version=‘2.3.2’
Dynamic Linking:
dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=’-Wl,-E’
cccdlflags=’-fpic’, lddlflags=’-shared -L/usr/local/lib’

Characteristics of this binary (from libperl):
Compile-time options: USE_LARGE_FILES
Built under linux
Compiled at Aug 31 2004 14:04:04
@INC:
/usr/local/lib/perl5/5.8.5/i686-linux
/usr/local/lib/perl5/5.8.5
/usr/local/lib/perl5/site_perl/5.8.5/i686-linux
/usr/local/lib/perl5/site_perl/5.8.5
/usr/local/lib/perl5/site_perl
.
Summary of my perl5 (revision 5 version 8 subversion 5) configuration:
Platform:
osname=linux, osvers=2.6.5, archname=i686-linux
uname=‘linux zabbix 2.6.5 #4 tue apr 27 16:02:14 cest 2004 i686
gnulinux ‘
config_args=’-de’
hint=recommended, useposix=true, d_sigaction=define
usethreads=undef use5005threads=undef useithreads=undef
usemultiplicity=undef
useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
use64bitint=undef use64bitall=undef uselongdouble=undef
usemymalloc=n, bincompat5005=undef
Compiler:
cc=‘cc’, ccflags =’-fno-strict-aliasing -pipe -I/usr/local/include
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64’,
optimize=’-O2’,
cppflags=’-fno-strict-aliasing -pipe -I/usr/local/include’
ccversion=’’, gccversion=‘3.3.3 (Debian 20040401)’, gccosandvers=’‘
intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
ivtype=‘long’, ivsize=4, nvtype=‘double’, nvsize=8, Off_t=‘off_t’,
lseeksize=8
alignbytes=4, prototype=define
Linker and Libraries:
ld=‘cc’, ldflags =’ -L/usr/local/lib’
libpth=/usr/local/lib /lib /usr/lib
libs=-lnsl -ldl -lm -lcrypt -lutil -lc
perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc
libc=/lib/libc-2.3.2.so, so=so, useshrplib=false, libperl=libperl.a
gnulibc_version=‘2.3.2’
Dynamic Linking:
dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=’-Wl,-E’
cccdlflags=’-fpic’, lddlflags=’-shared -L/usr/local/lib’

Characteristics of this binary (from libperl):
Compile-time options: USE_LARGE_FILES
Built under linux
Compiled at Aug 31 2004 14:04:04
@INC:
/usr/local/lib/perl5/5.8.5/i686-linux
/usr/local/lib/perl5/5.8.5
/usr/local/lib/perl5/site_perl/5.8.5/i686-linux
/usr/local/lib/perl5/site_perl/5.8.5
/usr/local/lib/perl5/site_perl
.

Dependencies result:

    NOTE: mod_perl 2.0 isn't quite ready for prime_time just yet;
    Best Practical Solutions strongly recommends that sites use
    Apache 1.3 or FastCGI. If you MUST use mod_perl 2.0 (or 1.99),
    please read the mailing list archives before asking for help.

perl:
5.8.3users:
rt group (rt)…found
bin owner (root)…found
libs owner (root)…found
libs group (bin)…found
web owner (www)…found
web group (www)…found
MASON dependencies:
Params::Validate 0.02…MISSING
Cache::Cache …MISSING
Exception::Class 1.14…MISSING
HTML::Mason 1.23…MISSING
MLDBM …MISSING
FreezeThaw …MISSING
XML::RSS …MISSING
MAILGATE dependencies:
HTML::TreeBuilder …MISSING
HTML::FormatText …MISSING
CLI dependencies:
CORE dependencies:
DBI 1.37…MISSING
Test::Inline …MISSING
Class::ReturnValue 0.40…MISSING
DBIx::SearchBuilder 1.01…MISSING
Text::Template …MISSING
HTML::Scrubber 0.08…MISSING
Log::Dispatch 2.0…MISSING
Locale::Maketext::Lexicon 0.32…MISSING
Locale::Maketext::Fuzzy …MISSING
MIME::Entity 5.108…MISSING
Mail::Mailer 1.57…MISSING
Text::Wrapper …MISSING
Time::ParseDate …MISSING
Term::ReadKey …MISSING
Text::Autoformat …MISSING
Text::Quoted 1.3…MISSING
Tree::Simple 1.04…MISSING
Module::Versions::Report …MISSING
DEV dependencies:
Regexp::Common …MISSING
Test::Inline …MISSING
WWW::Mechanize …MISSING
MODPERL2 dependencies:
Apache::DBI …MISSING
MYSQL dependencies:
DBD::mysql 2.1018…MISSING

Thnx!
Phil.From: Ruslan U. Zakirov [mailto:cubic@acronis.ru]
Sent: dinsdag 31 augustus 2004 14:32
To: Philippe Dhont (Sea-ro)
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] MISSING dependencies

Philippe Dhont (Sea-ro) wrote:

Hi,

I deleted some perl things, reinstalled perl etc…
Now executing the rt-test-dependencies and i see alot missing
dependencies.
So i install them with CPAN and i get the message that the module is
up to date, or installed but when i re-excute the dependency command i

still get all those MISSINGS…
What could go wrong ?
You run CPAN and rt-test-dependencies tools with different versions of
perl interpreter.

Please, send us output of perl -V and result of rt-test-dependencies
script.

Grtz,
Philippe


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT wiki at http://wiki.bestpractical.com

Philippe Dhont (Sea-ro) wrote:

Hi,

This is the result:

Perl -V:

Summary of my perl5 (revision 5 version 8 subversion 5) configuration:
[snip]

perl:
5.8.3users:
rt group (rt)…found
[snip]

Thnx!
Phil.
As I said you run CPAN tool and rt-test-dependencies tools with
different versions of perl.

Use /path/to/your/perl rt-test-dependecies command to override default
location.