Migrating to 5.0.1 on Postgre, and don´t search (Fulltext Index Done)

Hi All.

I´m migrating from RT 4.0.10 on Postgre 9.X. To RT 5.0.1 ons Postgre 12.X.
Done the # make upgrade-database. Without incidents.

I run fthe Full index (i have some warnings Words longer than 2047 characters are ignored. i think that there are for the attachments) with a new name for Table and Column. Add the text to the RT_SiteConfig.pm.
Im my case:

Set( %FullTextSearch,
Enable => 1,
Indexed => 1,
Column => ‘ContentIndexRT5’,
Table => ‘AttachIndexRT5’,

Stop and Start Apache2.

In i can see all my old tickets. But when i search for a common text (that works on my old RT server) i found 0 Tickets.

Could anybody help me? please.


As Update…

On my old server I search for adobe . And i get 30 tickets. On the new 0.


If search for Adobe instead adobe I get the same result. 0 tickets.


Can you check Pg and make sure the table AttachIndexRT5 exist, since that isn’t the default name its good to double check.

What is the search you’re performing? You can grab that from the Advanced tab on the search page.

1 Like


Yes,the table exists.
2021-03-08 16_25_34-pgAdmin 4

I see what you meaning…

I search from the box of the top of front page.
If i go to advanced


But i don´t want Satus= active… If i remove this i get the result that i expect when i search on my old system from the simple search…


There is a config for that feature:


1 Like