Migrating from 4.0.5 to 4.0.10 amd lost the RT "taskbar" (Home- Tickets)

Hello to all.

I want to migrate mi centos 6.3 RT 4.0.5 to a new machine with Centos 6.4
and RT 4.0.10,

I installed the new machine with RT 4.0.10, migrate the database, make and
upgrade-database. All seems fine, but i don´t see the “taskbar” in the top
of RT Homepage.

Please check this image:

Imgur

Any help?

Thanks.
Kindest Regards.

Un saludo.
Juanjo Corral

Hi,

Try to clean browser’s cache.

Make sure:

  • no errors in RT’s and apache’s logs
  • RT requests JS files via apache’s access log
  • check browser’s JS console for errorsOn Tue, Mar 26, 2013 at 3:57 PM, Juanjo juanjillo@gmail.com wrote:

Hello to all.

I want to migrate mi centos 6.3 RT 4.0.5 to a new machine with Centos 6.4
and RT 4.0.10,

I installed the new machine with RT 4.0.10, migrate the database, make and
upgrade-database. All seems fine, but i don´t see the “taskbar” in the top
of RT Homepage.

Please check this image:

Imgur: The magic of the Internet

Any help?

Thanks.
Kindest Regards.


Un saludo.
Juanjo Corral

Best regards, Ruslan.

Yes, i do a cleaning of browser cache, i use two differents browser.
And i do test in two machines.

No erros on log of httpd.
No errors on log of RT (now is debug mode)

Check Web* settings in RT site config.

Open HTML of the page, find link that points at JS file and try to
open it in browser’s tab.

Use browser’s dev tools to make sure it can load all files linked from
RT’s page.

Thanks for your help.

Hi,

Try to clean browser’s cache.

Make sure:

  • no errors in RT’s and apache’s logs
  • RT requests JS files via apache’s access log
  • check browser’s JS console for errors

Hello to all.

I want to migrate mi centos 6.3 RT 4.0.5 to a new machine with Centos
6.4
and RT 4.0.10,

I installed the new machine with RT 4.0.10, migrate the database, make
and
upgrade-database. All seems fine, but i don´t see the “taskbar” in the
top
of RT Homepage.

Please check this image:

Imgur: The magic of the Internet

Any help?

Thanks.
Kindest Regards.


Un saludo.
Juanjo Corral


Best regards, Ruslan.


Un saludo.
Juanjo Corral

Best regards, Ruslan.

I want to migrate mi centos 6.3 RT 4.0.5 to a new machine with Centos 6.4 and RT 4.0.10,

I installed the new machine with RT 4.0.10, migrate the database, make and upgrade-database.
All seems fine, but i don*t see the “taskbar” in the top of RT Homepage.

I suspect you’ve run into this, as documented in the upgrade notes.

http://bestpractical.com/rt/docs/latest/UPGRADING-4.0.html#Javascript-Changes

If you’ve copied the entire RT_Config.pm to RT_SiteConfig.pm or copied
@JSFiles to modify it, you will need to fix it. If you’ve copied all
of RT_Config.pm to RT_SiteConfig.pm you should really resolve that or
you’ll run into future problems.

-kevin

Thanks i will check it and share the results.

ThanksEl 26/03/2013 16:58, “Kevin Falcone” falcone@bestpractical.com escribió:

On Tue, Mar 26, 2013 at 12:57:49PM +0100, Juanjo wrote:

I want to migrate mi centos 6.3 RT 4.0.5 to a new machine with Centos
6.4 and RT 4.0.10,

I installed the new machine with RT 4.0.10, migrate the database,
make and upgrade-database.
All seems fine, but i don*t see the “taskbar” in the top of RT
Homepage.

I suspect you’ve run into this, as documented in the upgrade notes.

UPGRADING-4.0 - RT 5.0.3 Documentation - Best Practical

If you’ve copied the entire RT_Config.pm to RT_SiteConfig.pm or copied
@JSFiles to modify it, you will need to fix it. If you’ve copied all
of RT_Config.pm to RT_SiteConfig.pm you should really resolve that or
you’ll run into future problems.

-kevin

Y copy the RT_Congig.pm from version 4.0.10, to the RT_SiteConfig.pm. And I
put again all the configuration from my “old” 4.0.5 RT_SiteConfig.

Now all works fine.

Thanks.2013/3/26 Juanjo juanjillo@gmail.com

Thanks i will check it and share the results.

Thanks
El 26/03/2013 16:58, “Kevin Falcone” falcone@bestpractical.com escribió:

On Tue, Mar 26, 2013 at 12:57:49PM +0100, Juanjo wrote:

I want to migrate mi centos 6.3 RT 4.0.5 to a new machine with
Centos 6.4 and RT 4.0.10,

I installed the new machine with RT 4.0.10, migrate the database,
make and upgrade-database.
All seems fine, but i don*t see the “taskbar” in the top of RT
Homepage.

I suspect you’ve run into this, as documented in the upgrade notes.

UPGRADING-4.0 - RT 5.0.3 Documentation - Best Practical

If you’ve copied the entire RT_Config.pm to RT_SiteConfig.pm or copied
@JSFiles to modify it, you will need to fix it. If you’ve copied all
of RT_Config.pm to RT_SiteConfig.pm you should really resolve that or
you’ll run into future problems.

-kevin

Un saludo.
Juanjo Corral

Y copy the RT_Congig.pm from version 4.0.10, to the RT_SiteConfig.pm. And I
put again all the configuration from my “old” 4.0.5 RT_SiteConfig.

This is exact reason why we don’t recommend to copy whole RT config
into site config.

Now all works fine.

Thanks.

Thanks i will check it and share the results.

Thanks

I want to migrate mi centos 6.3 RT 4.0.5 to a new machine with
Centos 6.4 and RT 4.0.10,

I installed the new machine with RT 4.0.10, migrate the database,
make and upgrade-database.
All seems fine, but i don*t see the “taskbar” in the top of RT
Homepage.

I suspect you’ve run into this, as documented in the upgrade notes.

UPGRADING-4.0 - RT 5.0.3 Documentation - Best Practical

If you’ve copied the entire RT_Config.pm to RT_SiteConfig.pm or copied
@JSFiles to modify it, you will need to fix it. If you’ve copied all
of RT_Config.pm to RT_SiteConfig.pm you should really resolve that or
you’ll run into future problems.

-kevin


Un saludo.
Juanjo Corral

Best regards, Ruslan.